]> git.pld-linux.org Git - packages/dokuwiki-plugin-lightbox.git/commitdiff
- just collect diffs against original lightboxy 2.04 and resulting this tarball:
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 12 Mar 2009 00:05:53 +0000 (00:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  http://laurent.beneytout.free.fr/lib/exe/fetch.php?media=projects:lightbox.zip
  using the instructions: http://laurent.beneytout.free.fr/doku.php?id=projects:lightbox

Changed files:
    dokuwiki-plugin-lightbox.patch -> 1.1
    dokuwiki-plugin-lightbox.spec -> 1.2

dokuwiki-plugin-lightbox.patch [new file with mode: 0644]
dokuwiki-plugin-lightbox.spec

diff --git a/dokuwiki-plugin-lightbox.patch b/dokuwiki-plugin-lightbox.patch
new file mode 100644 (file)
index 0000000..151d2f7
--- /dev/null
@@ -0,0 +1,90 @@
+--- ./script.js        2009-03-12 01:44:39.267256244 +0200
++++ ./script.js        2008-08-08 21:38:32.000000000 +0300
+@@ -5581,13 +5581,16 @@
+ //  Configurationl
+ //
+ LightboxOptions = Object.extend({
+-    fileLoadingImage:        'images/loading.gif',     
+-    fileBottomNavCloseImage: 'images/closelabel.gif',
++// EDITED for Dokuwiki plugin
++    fileLoadingImage:        'lib/plugins/lightbox/images/loading.gif',     
++//    fileLoadingImage:        'images/loading.gif',
++    fileBottomNavCloseImage: 'lib/plugins/lightbox/images/closelabel.gif',
++//    fileBottomNavCloseImage: 'images/closelabel.gif',
+     overlayOpacity: 0.8,   // controls transparency of shadow overlay
+     animate: true,         // toggles resizing animations
+-    resizeSpeed: 7,        // controls the speed of the image resizing animations (1=slowest and 10=fastest)
++    resizeSpeed: 10,        // controls the speed of the image resizing animations (1=slowest and 10=fastest)
+     borderSize: 10,         //if you adjust the padding in the CSS, you will need to update this variable
+@@ -5723,7 +5726,10 @@
+         this.updateImageList = Prototype.emptyFunction;
+         document.observe('click', (function(event){
+-            var target = event.findElement('a[rel^=lightbox]') || event.findElement('area[rel^=lightbox]');
++            // EDITED for Dokuwiki
++            // TODO...
++            //var target = event.findElement('a[rel^=lightbox]') || event.findElement('area[rel^=lightbox]');
++            var target = event.findElement('a[class^=media]:not([class~=mediafile])') || event.findElement('area[class^=media]:not([class~=mediafile])');
+             if (target) {
+                 event.stop();
+                 this.start(target);
+@@ -5748,18 +5754,22 @@
+         this.imageArray = [];
+         var imageNum = 0;       
+-        if ((imageLink.rel == 'lightbox')){
+-            // if image is NOT part of a set, add single image to imageArray
+-            this.imageArray.push([imageLink.href, imageLink.title]);         
+-        } else {
++        // EDITED for Dokuwiki
++        // TODO...
++        //if ((imageLink.rel == 'lightbox')){
++        //     if image is NOT part of a set, add single image to imageArray
++        //    this.imageArray.push([imageLink.href, imageLink.title]);         
++        //} else {
+             // if image is part of a set..
+             this.imageArray = 
+-                $$(imageLink.tagName + '[href][rel="' + imageLink.rel + '"]').
+-                collect(function(anchor){ return [anchor.href, anchor.title]; }).
++                //$$(imageLink.tagName + '[href][rel="' + imageLink.rel + '"]').
++                $$(imageLink.tagName + '[href][class="media"]').
++                //collect(function(anchor){ return [anchor.href, anchor.title]; }).
++                collect(function(anchor){ return [anchor.href, anchor.firstChild.getAttribute('title')]; }).
+                 uniq();
+             
+             while (this.imageArray[imageNum][0] != imageLink.href) { imageNum++; }
+-        }
++        //}
+         // calculate top and left offset for the lightbox 
+         var arrayPageScroll = document.viewport.getScrollOffsets();
+--- ./css/lightbox.css 2008-03-10 06:57:10.000000000 +0200
++++ ./css/lightbox.css 2008-08-07 23:47:50.000000000 +0300
+@@ -10,11 +10,20 @@
+ #imageContainer>#hoverNav{ left: 0;}
+ #hoverNav a{ outline: none;}
+-#prevLink, #nextLink{ width: 49%; height: 100%; background-image: url(data:image/gif;base64,AAAA); /* Trick IE into showing hover */ display: block; }
++/*
++Modif DOKUWIKI
++#prevLink, #nextLink{ width: 49%; height: 100%; background-image: url(data:image/gif;base64,AAAA); \* Trick IE into showing hover \*display: block; }
++*/
++#prevLink, #nextLink{ width: 49%; height: 100%; background: transparent url(images/blank.gif) no-repeat; /* Trick IE into showing hover */ display: block; }
+ #prevLink { left: 0; float: left;}
+ #nextLink { right: 0; float: right;}
+-#prevLink:hover, #prevLink:visited:hover { background: url(../images/prevlabel.gif) left 15% no-repeat; }
+-#nextLink:hover, #nextLink:visited:hover { background: url(../images/nextlabel.gif) right 15% no-repeat; }
++/*
++Modif DOKUWIKI
++#prevLink:hover, #prevLink:visited:hover { background: url(../images/prev.gif) left 15% no-repeat; }
++#nextLink:hover, #nextLink:visited:hover { background: url(../images/next.gif) right 15% no-repeat; }
++*/
++#prevLink:hover, #prevLink:visited:hover { background: url(images/prev.gif) left 15% no-repeat; }
++#nextLink:hover, #nextLink:visited:hover { background: url(images/next.gif) right 15% no-repeat; }
+ #imageDataContainer{ font: 10px Verdana, Helvetica, sans-serif; background-color: #fff; margin: 0 auto; line-height: 1.4em; overflow: auto; width: 100%       ; }
index 655b8a64d8c000f0b25b4a8675c47c16b63754b2..a62958433509b7a46ccc161cfb28f94564cc4dd6 100644 (file)
@@ -3,11 +3,12 @@ Summary:      DokuWiki Light Box v2 plugin
 Summary(pl.UTF-8):     Wtyczka lightboxv2 dla DokuWiki
 Name:          dokuwiki-plugin-%{plugin}
 Version:       20080808
-Release:       1
+Release:       1.1
 License:       GPL v2
 Group:         Applications/WWW
-Source0:       http://laurent.beneytout.free.fr/lib/exe/fetch.php?media=projects:lightbox.zip
-# Source0-md5: 1f28817f046b94c730f4a25a7c7b676e
+Source0:       http://www.lokeshdhakar.com/projects/lightbox2/releases/lightbox2.04.zip
+# Source0-md5: c930f97a5791f202d7c48303de36f282
+Patch0:                %{name}.patch
 URL:           http://wiki.splitbrain.org/plugin:lightboxv2
 Requires:      dokuwiki >= 20061106
 BuildArch:     noarch
@@ -21,13 +22,27 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Plugin to integrate LightBox v2 javascript animation in DokuWiki.
 
 %prep
-%setup -q -n %{plugin}
-rm -f images/Thumbs.db
+%setup -qc -n %{plugin}
+(
+       cat js/prototype.js
+       cat js/scriptaculous.js
+       cat js/builder.js
+       cat js/effects.js
+       cat js/lightbox.js
+) > script.js
+%patch0 -p1
+
+rm -f images/bullet.gif
+rm -f images/donate-button.gif
+rm -f images/download-icon.gif
+rm -f images/image-1.jpg
+rm -f images/thumb-1.jpg
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{plugindir}
-cp -a . $RPM_BUILD_ROOT%{plugindir}
+cp -a images script.js $RPM_BUILD_ROOT%{plugindir}
+cp -a css/lightbox.css $RPM_BUILD_ROOT%{plugindir}/screen.css
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.097739 seconds and 4 git commands to generate.