]> git.pld-linux.org Git - packages/dokuwiki-plugin-eventum.git/blob - dokuwiki-plugin-eventum.spec
- there should be tab, not space
[packages/dokuwiki-plugin-eventum.git] / dokuwiki-plugin-eventum.spec
1 %define         plugin          eventum
2 Summary:        DokuWiki Eventum Plugin
3 Summary(pl.UTF-8):      Wtyczka Include (dołączania) dla Eventum
4 Name:           dokuwiki-plugin-%{plugin}
5 Version:        20080910
6 Release:        1
7 License:        GPL v2
8 Group:          Applications/WWW
9 URL:            https://cvs.delfi.ee/dokuwiki/plugin/eventum/
10 Requires:       dokuwiki >= 20080505
11 BuildArch:      noarch
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %define         dokudir         /usr/share/dokuwiki
15 %define         plugindir       %{dokudir}/lib/plugins/%{plugin}
16
17 %define         _cvsroot        :ext:cvs.delfi.ee:/usr/local/cvs
18 %define         _cvsmodule      dokuwiki/plugin/eventum
19
20 %description
21 Adds Eventum link button to edit toolbar.
22
23 %prep
24 %setup -qTc
25 cd ..
26 cvs -d %{_cvsroot} co -d %{name}-%{version} %{_cvsmodule}
27 cd -
28
29 # skip tagging if we checkouted from tag or have debug enabled
30 # also make make tag only if we have integer release
31 %if %{!?debug:1}%{?debug:0} && %{!?_cvstag:1}%{?_cvstag:0} && %([[ %{release} = *.* ]] && echo 0 || echo 1)
32 # do tagging by version
33 tag=%{name}-%(echo %{version} | tr . _)-%(echo %{release} | tr . _)
34
35 cd %{_specdir}
36 if [ $(cvs status -v %{name}.spec | egrep -c "$tag[[:space:]]") != 0 ]; then
37         : "Tag $tag already exists"
38         exit 1
39 fi
40 cvs tag $tag %{name}.spec
41 cd -
42 cvs tag $tag
43 %endif
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{plugindir}
48 cp -a . $RPM_BUILD_ROOT%{plugindir}
49 find $RPM_BUILD_ROOT%{plugindir} -name CVS | xargs -r rm -rf
50
51 # link issue -> eventum icon
52 install -d $RPM_BUILD_ROOT%{dokudir}/lib/images/interwiki
53 ln -s eventum.gif $RPM_BUILD_ROOT%{dokudir}/lib/images/interwiki/issue.gif
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %dir %{plugindir}
61 %{plugindir}/*.php
62 %dir %{plugindir}/lang
63 %dir %{plugindir}/lang/en
64 %{plugindir}/lang/en/lang.php
65
66 # [[issue>XXX]] icon
67 %{dokudir}/lib/images/interwiki/issue.gif
This page took 0.05308 seconds and 3 git commands to generate.