]> git.pld-linux.org Git - packages/dokuwiki-plugin-data.git/commitdiff
update patches
authorElan Ruusamäe <glen@delfi.ee>
Tue, 22 Nov 2016 21:09:40 +0000 (23:09 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 22 Nov 2016 21:09:40 +0000 (23:09 +0200)
cache-enable.patch
dokuwiki-plugin-data.spec
separate-rpmdb.patch
separator-style.patch

index 6133ac186459ac491eede40e50a41abdcb786895..0c3c191547a35dcb86fa0dada207537ac34f7b66 100644 (file)
@@ -1,15 +1,14 @@
---- syntax/table.php~  2012-08-07 18:56:10.000000000 +0300
-+++ syntax/table.php   2012-08-17 01:26:46.814865996 +0300
-@@ -204,7 +204,11 @@
-     function render($format, &$R, $data) {
-         if($format != 'xhtml') return false;
-         if(is_null($data)) return false;
+--- dokuwiki-plugin-data-20160311/syntax/table.php~    2016-11-22 23:08:27.000000000 +0200
++++ dokuwiki-plugin-data-20160311/syntax/table.php     2016-11-22 23:08:54.437219264 +0200
+@@ -245,7 +245,10 @@
+         $sqlite = $this->dthlp->_getDB();
+         if(!$sqlite) return false;
 -        $R->info['cache'] = false;
-+
 +        // disable cache only if sorting having some filters
 +        if ($data['dynfilters'] || !empty($_REQUEST['datasrt']) || !empty($_GET['dataflt']) || !empty($_REQUEST['dataofs'])) {
 +            $R->info['cache'] = false;
 +        }
  
-         $sqlite = $this->dthlp->_getDB();
-         if(!$sqlite) return false;
+         //reset counters
+         $this->sums = array();
index f55487938bd4709f28306cd4337108288f7d853f..c6e9a75b423629dea513e93e0923faa9969ca493 100644 (file)
@@ -55,13 +55,7 @@ different to the repository plugin.
 mv *-%{plugin}-*/* .
 %patch2 -p1
 %patch3 -p1
-%patch4 -p0
-
-version=$(awk '/date/{print $2}' plugin.info.txt)
-if [ $(echo "$version" | tr -d -) != %{version} ]; then
-       : %%{version} mismatch
-#      exit 1
-fi
+%patch4 -p1
 
 # nothing to do with tests
 rm -rf _test
@@ -69,6 +63,13 @@ rm -rf _test
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
+%build
+version=$(awk '/date/{print $2}' plugin.info.txt)
+if [ $(echo "$version" | tr -d -) != %{version} ]; then
+       : %%{version} mismatch
+       exit 1
+fi
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{plugindir},%{metadir}}
index 893c03b9f4daba39c54d5e88902a27c4177ead25..d16d484b0400c20a5798447af052734557f214e7 100644 (file)
@@ -10,21 +10,16 @@ CREATE TABLE rpmdb (eid INTEGER PRIMARY KEY, pid INTEGER, value);
 Handling it automatically would mean have to renumber upstream patches each
 time...
 
-#--- dokuwiki-plugin-data-20120227/db/latest.version~  2012-02-27 16:32:51.000000000 +0200
-#+++ dokuwiki-plugin-data-20120227/db/latest.version   2012-03-13 13:10:57.241251292 +0200
-#@@ -1 +1 @@
-#-5
-#+6
---- dokuwiki-plugin-data-20120227/helper.php~  2012-03-13 13:10:04.000000000 +0200
-+++ dokuwiki-plugin-data-20120227/helper.php   2012-03-13 13:11:33.742793083 +0200
-@@ -184,6 +184,7 @@
-         static $specials = array('%title%'   => array('page', 'title'),
-                                  '%pageid%'  => array('title', 'page'),
-                                  '%class%'   => array('class'),
-+                                 '%rpm%'     => array('rpm'),
-                                  '%lastmod%' => array('lastmod','timestamp'));
-         if (isset($specials[$column['title']])) {
-             $s = $specials[$column['title']];
+--- dokuwiki-plugin-data-20160311/helper.php~  2016-11-22 23:06:06.000000000 +0200
++++ dokuwiki-plugin-data-20160311/helper.php   2016-11-22 23:06:44.267324645 +0200
+@@ -385,6 +385,7 @@
+             '%title%'   => array('page', 'title'),
+             '%pageid%'  => array('title', 'page'),
+             '%class%'   => array('class'),
++            '%rpm%'     => array('rpm'),
+             '%lastmod%' => array('lastmod', 'timestamp')
+         );
+         if(isset($specials[$column['title']])) {
 --- dokuwiki-plugin-data-20120227/lang/en/lang.php~    2012-02-27 16:32:51.000000000 +0200
 +++ dokuwiki-plugin-data-20120227/lang/en/lang.php     2012-03-13 13:12:04.190745746 +0200
 @@ -16,6 +16,7 @@
@@ -35,19 +30,19 @@ time...
  $lang['lastmod']   = 'Last Modified';
  
  $lang['name']      = 'Type Alias';
---- dokuwiki-plugin-data-20100608/syntax/table.php     2010-11-03 15:20:30.000000000 +0200
-+++ dokuwiki-plugin-data-20100608/syntax/table.php     2010-12-01 19:50:59.217678000 +0200
-@@ -328,6 +328,13 @@
-                 $select[] = '" " || pages.class';
-             }elseif($key == '%title%'){
+--- dokuwiki-plugin-data-20160311/syntax/table.php~    2016-07-01 14:27:21.000000000 +0300
++++ dokuwiki-plugin-data-20160311/syntax/table.php     2016-11-22 23:08:01.967907897 +0200
+@@ -584,6 +584,13 @@
+                 $select[] = 'pages.lastmod';
+             } elseif($key == '%title%') {
                  $select[] = "pages.page || '|' || pages.title";
-+            }elseif($key == '%rpm%'){
++            } elseif($key == '%rpm%'){
 +                if(!isset($tables[$key])){
 +                    $tables[$key] = 'T'.(++$cnt);
 +                    $from  .= ' LEFT JOIN rpmdb AS '.$tables[$key].' ON '.$tables[$key].'.pid = pages.pid';
 +                }
 +                $select[] = "group_concat(".$tables[$key].".value,'\n')";
 +
-             }else{
-                 if(!isset($tables[$key])){
-                     $tables[$key] = 'T'.(++$cnt);
+             } else {
+                 if(!isset($tables[$key])) {
+                     $tables[$key] = 'T' . (++$cnt);
index 4c04bbd0aa00dd40259c604135ae80b6a4f21f69..73095f9868eb11791941cb18dbbb5ecc2868cdea 100644 (file)
@@ -7,13 +7,13 @@ table.dataplugin_table span.sep {
 
 and have list items listed below each other
 
---- data/helper.php    2010-02-23 03:00:00.000000000 +0200
-+++ data/helper.php    2009-09-10 09:00:02.000000000 +0300
-@@ -129,7 +139,7 @@
+--- dokuwiki-plugin-data-20160311/helper.php~  2016-07-01 14:27:21.000000000 +0300
++++ dokuwiki-plugin-data-20160311/helper.php   2016-11-22 23:05:37.213943088 +0200
+@@ -360,7 +360,7 @@
                      }
              }
          }
--        return join(', ',$outs);
+-        return join(', ', $outs);
 +        return join('<span class="sep">, </span>',$outs);
      }
  
This page took 0.14016 seconds and 4 git commands to generate.