- BR: setuptools, unify pypi Source URL
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 30 Oct 2019 16:51:47 +0000 (17:51 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 30 Oct 2019 16:51:47 +0000 (17:51 +0100)
docutils.spec

index 6847b52bc8caf00e6dc8205ee16eb0aaf5c5d160..54805b3c1f5586ca6a989a6d7c18a4d3ddaec3e5 100644 (file)
@@ -11,16 +11,19 @@ Version:    0.15.2
 Release:       1
 License:       Public Domain, BSD, GPL v3 (see COPYING.txt)
 Group:         Development/Tools
-# Source0:     http://downloads.sourceforge.net/docutils/%{name}-%{version}.tar.gz
-Source0:       https://pypi.debian.net/%{name}/%{name}-%{version}.tar.gz
+# original URL, but only with major releases: http://downloads.sourceforge.net/docutils/%{name}-%{version}.tar.gz
+#Source0Download: https://pypi.org/simple/docutils/
+Source0:       https://files.pythonhosted.org/packages/source/d/docutils/%{name}-%{version}.tar.gz
 # Source0-md5: e26a308d8000b0bed7416a633217c676
 URL:           http://docutils.sourceforge.net/
 %if %{with python2}
 BuildRequires: python-devel >= 1:2.6
+BuildRequires: python-setuptools
 %endif
 %if %{with python3}
 BuildRequires: python3-2to3 >= 1:3.4
 BuildRequires: python3-devel >= 1:3.4
+BuildRequires: python3-setuptools
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
This page took 0.587981 seconds and 4 git commands to generate.