]> git.pld-linux.org Git - packages/docker.git/commitdiff
up to 1.13.1 - https://github.com/docker/docker/releases/tag/v1.13.1 auto/th/docker-1.13.1-1
authorElan Ruusamäe <glen@delfi.ee>
Tue, 28 Mar 2017 10:52:57 +0000 (13:52 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 28 Mar 2017 12:13:18 +0000 (15:13 +0300)
docker.spec
init-args.patch [deleted file]

index 3fe397fa2bebe7faa04558a0332ebb222872828f..2d487e68c55e4d0a388a10bd1ae4c1f937758729 100644 (file)
@@ -7,26 +7,26 @@
 # NOTES
 # https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
 
-# v1.0.0-rc2-132-g2f7393a
-%define        runc_commit 2f7393a
-# v0.2.3-78-g03e5862
-%define        containerd_commit 03e5862
+# v1.0.0-rc2-133-g9df8b30
+%define        runc_commit 9df8b30
+# v0.2.3-85-gaa8187d
+%define        containerd_commit aa8187d
 # v0.8.0-dev.2-464-g0f53435
 %define        libnetwork_commit 0f53435
 #define        subver -rc7
 Summary:       Docker: the open-source application container engine
 Name:          docker
-Version:       1.13.0
+Version:       1.13.1
 Release:       1
 License:       Apache v2.0
 Group:         Applications/System
 # https://github.com/docker/docker/releases
 Source0:       https://github.com/docker/docker/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 23d3875ac67d5b67dd1918c45ba98537
+# Source0-md5: 032c39b2390a0f387cdb49bab8c4c712
 Source1:       https://github.com/docker/runc/archive/%{runc_commit}/runc-%{runc_commit}.tar.gz
-# Source1-md5: ab5b858b721b2fc8b581645eb35e3634
+# Source1-md5: 43ee79eaf575db8a212058c30997e45d
 Source2:       https://github.com/docker/containerd/archive/%{containerd_commit}/containerd-%{containerd_commit}.tar.gz
-# Source2-md5: 72e9315bde0c17f14d8a2fff8e0d2423
+# Source2-md5: 01c58df940b94910996ecb8096fd8b71
 Source3:       https://github.com/docker/libnetwork/archive/%{libnetwork_commit}/libnetwork-%{libnetwork_commit}.tar.gz
 # Source3-md5: 7cfbfe76355aae3577c77a6a4b2c92db
 Source4:       https://github.com/krallin/tini/archive/v0.13.0/tini-0.13.0.tar.gz
@@ -35,7 +35,6 @@ Source5:      %{name}d.sh
 Source7:       %{name}.init
 Source8:       %{name}.sysconfig
 Patch0:                systemd.patch
-Patch1:                init-args.patch
 URL:           http://www.docker.com/
 BuildRequires: btrfs-progs-devel >= 3.16.1
 BuildRequires: cmake
@@ -146,7 +145,6 @@ mv containerd-%{containerd_commit}* containerd
 mv libnetwork-%{libnetwork_commit}* libnetwork
 mv tini-* tini
 %patch0 -p1
-%patch1 -p1
 
 install -d vendor/src/github.com/docker
 ln -s $(pwd) vendor/src/github.com/docker/docker
@@ -154,11 +152,11 @@ ln -s $(pwd)/containerd containerd/vendor/src/github.com/docker/containerd
 ln -s $(pwd)/libnetwork vendor/src/github.com/docker/libnetwork
 
 %build
-v=$(awk -F= '/RUNC_COMMIT/ {print $2}' hack/dockerfile/binaries-commits)
+v=$(awk -F= '/^RUNC_COMMIT/ {print $2}' hack/dockerfile/binaries-commits)
 echo "$v" | grep "^%{runc_commit}"
-v=$(awk -F= '/CONTAINERD_COMMIT/ {print $2}' hack/dockerfile/binaries-commits)
+v=$(awk -F= '/^CONTAINERD_COMMIT/ {print $2}' hack/dockerfile/binaries-commits)
 echo "$v" | grep "^%{containerd_commit}"
-v=$(awk -F= '/LIBNETWORK_COMMIT/ {print $2}' hack/dockerfile/binaries-commits)
+v=$(awk -F= '/^LIBNETWORK_COMMIT/ {print $2}' hack/dockerfile/binaries-commits)
 echo "$v" | grep "^%{libnetwork_commit}"
 
 export GOPATH=$(pwd)/vendor:$(pwd)/containerd/vendor
diff --git a/init-args.patch b/init-args.patch
deleted file mode 100644 (file)
index 9dc7eaf..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-
-upstreamed: https://github.com/docker/docker/pull/28454
-
-do not require custom build of tini
-
-https://github.com/krallin/tini/issues/55#issuecomment-260507562
-
-host# docker run --init --rm -it glen/pld bash -l
-bash-4.4# /dev/init -- sh -c 'echo "kala" "maja"; cat /proc/$$/cmdline|tr "\0" "\n">cmdline'
-[WARN  tini (39)] Tini is not running as PID 1 and isn't registered as a child subreaper.
-Zombie processes will not be re-parented to Tini, so zombie reaping won't work.
-To fix the problem, use the -s option or set the environment variable TINI_SUBREAPER to register Tini as a child subreaper, or run Tini as PID 1.
-kala maja
-bash-4.4# cat cmdline
-sh
--c
-echo "kala" "maja"; cat /proc/$$/cmdline|tr "\0" "\n">cmdline
-bash-4.4#
-
---- docker-1.13.0-rc1/daemon/oci_linux.go~     2016-11-11 12:27:33.000000000 +0200
-+++ docker-1.13.0-rc1/daemon/oci_linux.go      2016-11-15 02:42:25.660635864 +0200
-@@ -593,7 +593,7 @@
-       if c.HostConfig.PidMode.IsPrivate() {
-               if (c.HostConfig.Init != nil && *c.HostConfig.Init) ||
-                       (c.HostConfig.Init == nil && daemon.configStore.Init) {
--                      s.Process.Args = append([]string{"/dev/init", c.Path}, c.Args...)
-+                      s.Process.Args = append([]string{"/dev/init", "--", c.Path}, c.Args...)
-                       var path string
-                       if daemon.configStore.InitPath == "" && c.HostConfig.InitPath == "" {
-                               path, err = exec.LookPath(DefaultInitBinary)
This page took 0.075245 seconds and 4 git commands to generate.