]> git.pld-linux.org Git - packages/docker.git/commitdiff
Patch out a check for the SHA1 sum of dockerinit
authorAria Stewart <aredridel@nbtsc.org>
Thu, 28 Nov 2013 19:48:33 +0000 (12:48 -0700)
committerAria Stewart <aredridel@nbtsc.org>
Thu, 28 Nov 2013 19:49:28 +0000 (12:49 -0700)
lxc-docker-nosha.patch [new file with mode: 0644]
lxc-docker.spec

diff --git a/lxc-docker-nosha.patch b/lxc-docker-nosha.patch
new file mode 100644 (file)
index 0000000..2ab4972
--- /dev/null
@@ -0,0 +1,27 @@
+Only in docker-0.7.0/: build
+diff -ur docker-0.7.0-o/utils/utils.go docker-0.7.0/utils/utils.go
+--- docker-0.7.0-o/utils/utils.go      2013-11-26 01:09:45.000000000 -0700
++++ docker-0.7.0/utils/utils.go        2013-11-28 12:39:38.000000000 -0700
+@@ -272,10 +272,6 @@
+ // Figure out the path of our dockerinit (which may be SelfPath())
+ func DockerInitPath(localCopy string) string {
+       selfPath := SelfPath()
+-      if isValidDockerInitPath(selfPath, selfPath) {
+-              // if we're valid, don't bother checking anything else
+-              return selfPath
+-      }
+       var possibleInits = []string{
+               localCopy,
+               filepath.Join(filepath.Dir(selfPath), "dockerinit"),
+@@ -291,9 +287,7 @@
+                               // LookPath already validated that this file exists and is executable (following symlinks), so how could Abs fail?
+                               panic(err)
+                       }
+-                      if isValidDockerInitPath(path, selfPath) {
+-                              return path
+-                      }
++            return path
+               }
+       }
+       return ""
+Only in docker-0.7.0/utils: utils.go~
index ca91b7e1d452e59804f760934e60938d24200c33..0086ee285123876015a38a463ffcb60efa71cd8d 100644 (file)
@@ -31,6 +31,7 @@ Suggests:     git-core >= 1.7
 Suggests:      libcgroup
 Suggests:      xz >= 1:4.9
 Provides:      group(docker)
+Patch0: lxc-docker-nosha.patch
 # only runs on x64 hosts for now:
 # https://github.com/dotcloud/docker/issues/136
 # https://github.com/dotcloud/docker/issues/611
@@ -82,6 +83,7 @@ This plugin provides syntax highlighting in Dockerfile.
 
 %prep
 %setup -q -n docker-%{version}
+%patch0 -p1
 
 install -d vendor/src/github.com/dotcloud
 ln -s $(pwd) vendor/src/github.com/dotcloud/docker
This page took 0.051232 seconds and 4 git commands to generate.