]> git.pld-linux.org Git - packages/docker.git/blobdiff - lxc-docker.spec
include pld into "build"
[packages/docker.git] / lxc-docker.spec
index 01794030659f11108404a2989024f3ee18ca1b4c..bbc14b031be38386be10a3e369debd4bfb9a5662 100644 (file)
@@ -4,29 +4,15 @@
 
 Summary:       Docker: the Linux container engine
 Name:          lxc-docker
-Version:       0.6.1
+Version:       0.6.3
 Release:       3
 License:       Apache v2.0
 Group:         Applications/System
-Source0:       https://github.com/dotcloud/docker/archive/v%{version}.tar.gz
-# Source0-md5: 487262eae6627971e9181886d65fae1a
-Source100:     https://raw.github.com/dotcloud/docker/v0.5.3/Makefile
-# Source100-md5:       44cc86a37fc5dfe59596076d346da20d
-Source1:       https://github.com/gorilla/context/archive/master.tar.gz?/gorilla-context.tgz
-# Source1-md5: 621f599f7a49f56ca89c25a6d01ecc3a
-Source2:       https://github.com/gorilla/mux/archive/master.tar.gz?/gorilla-mux.tgz
-# Source2-md5: e908c7da6b4b8b61b4733d4a348f015c
-Source3:       https://github.com/kr/pty/archive/master.tar.gz?/kr-pty.tgz
-# Source3-md5: ffdcacc582c7b6404e71c2dce638869e
-Source4:       https://github.com/dotcloud/tar/archive/master.tar.gz?/tar.tgz
-# Source4-md5: 7458ecaa777e56d124b61638d597b37f
-# $ PKG=code.google.com/p/go.net/ REV=84a4013f96e0; hg clone http://$PKG go.net && cd go.net && hg checkout $REV && cd .. && tar -cjf go.net.tar.gz2 --exclude-vcs go.net
-Source5:       go.net.tar.bz2
-# Source5-md5: c8fd9d068430ddfa42d28d4772260eda
+Source0:       https://github.com/dotcloud/docker/archive/v%{version}/docker-%{version}.tar.gz
+# Source0-md5: 7926f24106b4299ffbb669d42fd7e375
 Source6:       %{name}.init
-Patch0:                bash-comp-2.patch
 URL:           http://github.com/dotcloud/docker
-BuildRequires: golang >= 1.1
+BuildRequires: golang >= 1.1.2
 BuildRequires: rpmbuild(macros) >= 1.228
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
@@ -76,38 +62,26 @@ This package provides bash-completion for Docker.
 Pakiet ten dostarcza bashowe uzupełnianie nazw dla Dockera.
 
 %prep
-%setup -q -n docker-%{version} -a1 -a2 -a3 -a4 -a5
-cp -p %{SOURCE100} .
-%patch0 -p1
-
-# handle external deps offline, these are taken from Dockerfile
-install -d .gopath/src/github.com/{gorilla,kr,dotcloud}
-# git clone https://github.com/gorilla/context .gopath/src/github.com/gorilla/context
-mv context-master .gopath/src/github.com/gorilla/context
-# git clone https://github.com/gorilla/mux .gopath/src/github.com/gorilla/mux
-mv mux-master .gopath/src/github.com/gorilla/mux
-# git clone https://github.com/kr/pty .gopath/src/github.com/kr/pty
-mv pty-master .gopath/src/github.com/kr/pty
-# git clone https://github.com/dotcloud/tar .gopath/src/github.com/dotcloud/tar
-mv tar-master .gopath/src/github.com/dotcloud/tar
-# PKG=code.google.com/p/go.net/
-install -d .gopath/src/code.google.com/p
-mv go.net .gopath/src/code.google.com/p/go.net
+%setup -q -n docker-%{version}
 
-%build
-# avoid interfering with builder env
-unset GIT_WORK_TREE
-unset GIT_DIR
-%{__make} VERBOSE=1
+install -d vendor/src/github.com/dotcloud
+ln -s $(pwd) vendor/src/github.com/dotcloud/docker
 
-%if %{with tests}
-%{__make} test
-%endif
+%build
+export GOPATH=$(pwd)/vendor
+install -d build
+cd build
+VERSION=%{version}
+GITCOMMIT=pld-%{release} # use RPM_PACKAGE_RELEASE for this
+# Use these flags when compiling the tests and final binary
+# without '-d', as that fails now
+LDFLAGS="-X main.GITCOMMIT $GITCOMMIT -X main.VERSION $VERSION -w"
+go build -v -ldflags "$LDFLAGS" -a github.com/dotcloud/docker/docker
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/rc.d/init.d,/var/lib/docker/{containers,graph,volumes}}
-install -p bin/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
+install -p build/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/lxc-docker
 ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
 cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
This page took 0.18717 seconds and 4 git commands to generate.