]> git.pld-linux.org Git - packages/docker.git/blobdiff - lxc-docker.spec
up to 0.9.0; requires go1.2 to build
[packages/docker.git] / lxc-docker.spec
index 4da666fc3b573df06b752896c91d9749e9195e13..46ebcd96ae6aae10e1cf4f98a0d78cebc821263f 100644 (file)
@@ -4,28 +4,36 @@
 
 Summary:       Docker: the Linux container engine
 Name:          lxc-docker
-Version:       0.6.4
+Version:       0.9.0
 Release:       1
 License:       Apache v2.0
 Group:         Applications/System
 Source0:       https://github.com/dotcloud/docker/archive/v%{version}/docker-%{version}.tar.gz
-# Source0-md5: c70bb4f56ef1fee069964a5f8c7c26f9
+# Source0-md5: 5969bb91ec4f17aa381831046fb15531
+Source5:       %{name}.service
 Source6:       %{name}.init
 URL:           http://github.com/dotcloud/docker
-BuildRequires: golang >= 1.1.2
+BuildRequires: btrfs-progs-devel
+BuildRequires: device-mapper-devel
+BuildRequires: golang >= 1.2.1
 BuildRequires: rpmbuild(macros) >= 1.228
+BuildRequires: sqlite3-devel >= 3.7.9
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
+Requires:      iproute2 >= 3.5
 Requires:      iptables
-Requires:      lxc
+Requires:      lxc >= 0.8
 Requires:      rc-scripts >= 0.4.0.10
-Requires:      tar
+Requires:      tar >= 1:1.26
 Requires:      uname(release) >= 3.8
 Requires:      xz
+Suggests:      git-core >= 1.7
 Suggests:      libcgroup
+Suggests:      xz >= 1:4.9
 Provides:      group(docker)
+Patch0:                %{name}-nosha.patch
 # only runs on x64 hosts for now:
 # https://github.com/dotcloud/docker/issues/136
 # https://github.com/dotcloud/docker/issues/611
@@ -77,6 +85,7 @@ This plugin provides syntax highlighting in Dockerfile.
 
 %prep
 %setup -q -n docker-%{version}
+%patch0 -p1
 
 install -d vendor/src/github.com/dotcloud
 ln -s $(pwd) vendor/src/github.com/dotcloud/docker
@@ -86,16 +95,19 @@ export GOPATH=$(pwd)/vendor
 install -d build
 cd build
 VERSION=%{version}
-GITCOMMIT=pld-%{release} # use RPM_PACKAGE_RELEASE for this
+GITCOMMIT=pld-%{version}-%{release} # use RPM_PACKAGE_RELEASE for this
 # Use these flags when compiling the tests and final binary
 # without '-d', as that fails now
 LDFLAGS="-X main.GITCOMMIT $GITCOMMIT -X main.VERSION $VERSION -w"
 go build -v -ldflags "$LDFLAGS" -a github.com/dotcloud/docker/docker
+go build -v -ldflags "$LDFLAGS" -a ../dockerinit/dockerinit.go
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/rc.d/init.d,/var/lib/docker/{containers,graph,volumes}}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/rc.d/init.d,%{systemdunitdir},/var/lib/docker/{containers,graph,volumes}}
 install -p build/docker $RPM_BUILD_ROOT%{_bindir}/lxc-docker
+install -p build/dockerinit $RPM_BUILD_ROOT%{_bindir}/dockerinit
+install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/lxc-docker.service
 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/lxc-docker
 ln -s lxc-docker $RPM_BUILD_ROOT%{_bindir}/docker
 #cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
@@ -107,7 +119,7 @@ ln -s lxc-docker $RPM_BUILD_ROOT%{bash_compdir}/docker
 
 # vim syntax
 install -d $RPM_BUILD_ROOT%{_vimdatadir}
-cp -a contrib/vim-syntax/* $RPM_BUILD_ROOT%{_vimdatadir}
+cp -a contrib/syntax/vim/* $RPM_BUILD_ROOT%{_vimdatadir}
 %{__rm} $RPM_BUILD_ROOT%{_vimdatadir}/{LICENSE,README.md}
 
 %pre
@@ -134,9 +146,11 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README.md CHANGELOG.md CONTRIBUTING.md FIXME LICENSE AUTHORS NOTICE MAINTAINERS
+%{systemdunitdir}/lxc-docker.service
 %attr(754,root,root) /etc/rc.d/init.d/lxc-docker
 %attr(755,root,root) %{_bindir}/lxc-docker
 %attr(755,root,root) %{_bindir}/docker
+%attr(755,root,root) %{_bindir}/dockerinit
 #%{_mandir}/man1/lxc-docker.1*
 %dir %attr(700,root,root) /var/lib/docker
 %dir %attr(700,root,root) /var/lib/docker/containers
@@ -150,7 +164,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n vim-syntax-%{name}
 %defattr(644,root,root,755)
-%doc contrib/vim-syntax/{README.md,LICENSE}
+%doc contrib/syntax/vim/{README.md,LICENSE}
 %{_vimdatadir}/doc/dockerfile.txt
 %{_vimdatadir}/ftdetect/dockerfile.vim
 %{_vimdatadir}/syntax/dockerfile.vim
This page took 0.097067 seconds and 4 git commands to generate.