]> git.pld-linux.org Git - packages/docker.git/blobdiff - docker.spec
skip vim package, bundled in vim (7.4.979-2)
[packages/docker.git] / docker.spec
index de38a4940d6da52c1eb2da26892cb50d8e359fc8..5d1c084570918691256ff07c42aae8a9d5189315 100644 (file)
@@ -1,17 +1,19 @@
 #
 # Conditional build:
 %bcond_with    tests           # build without tests
+%bcond_with    vim                     # build vim syntax package
 
 Summary:       Docker: the open-source application container engine
 Name:          docker
-Version:       1.3.3
-Release:       0.4
+Version:       1.6.2
+Release:       1
 License:       Apache v2.0
 Group:         Applications/System
 Source0:       https://github.com/docker/docker/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 3fdcb25a498961f6eb14a9c1d81e9244
+# Source0-md5: 81a1a015ec0520d739ec721f8295d94f
 Source5:       %{name}.service
 Source6:       %{name}.init
+Source7:       %{name}.sysconfig
 URL:           https://github.com/docker/docker
 BuildRequires: btrfs-progs-devel
 BuildRequires: device-mapper-devel
@@ -24,7 +26,6 @@ Requires(pre):        /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires:      iproute2 >= 3.5
 Requires:      iptables
-Requires:      lxc >= 0.8
 Requires:      rc-scripts >= 0.4.0.10
 Requires:      tar >= 1:1.26
 Requires:      uname(release) >= 3.8
@@ -110,13 +111,14 @@ DEBUG=1 hack/make.sh dynbinary
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/rc.d/init.d,%{systemdunitdir}} \
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/{rc.d/init.d,sysconfig},%{systemdunitdir}} \
        $RPM_BUILD_ROOT/var/lib/docker/{aufs,containers,execdriver,graph,init,tmp,trust,vfs,volumes}
 
 install -p bundles/%{version}/dynbinary/docker-%{version} $RPM_BUILD_ROOT%{_bindir}/docker
 install -p bundles/%{version}/dynbinary/dockerinit-%{version} $RPM_BUILD_ROOT%{_bindir}/dockerinit
 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/docker
+cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/sysconfig/docker
 #cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
 # install udev rules
@@ -128,9 +130,11 @@ install -d $RPM_BUILD_ROOT%{bash_compdir}
 cp -p contrib/completion/bash/docker $RPM_BUILD_ROOT%{bash_compdir}/docker
 
 # vim syntax
+%if %{with vim}
 install -d $RPM_BUILD_ROOT%{_vimdatadir}
 cp -a contrib/syntax/vim/* $RPM_BUILD_ROOT%{_vimdatadir}
 %{__rm} $RPM_BUILD_ROOT%{_vimdatadir}/{LICENSE,README.md}
+%endif
 
 %pre
 %groupadd -g 296 docker
@@ -156,10 +160,11 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README.md CHANGELOG.md CONTRIBUTING.md LICENSE AUTHORS NOTICE MAINTAINERS
-%{systemdunitdir}/docker.service
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/docker
 %attr(754,root,root) /etc/rc.d/init.d/docker
 %attr(755,root,root) %{_bindir}/docker
 %attr(755,root,root) %{_bindir}/dockerinit
+%{systemdunitdir}/docker.service
 /lib/udev/rules.d/80-docker.rules
 #%{_mandir}/man1/lxc-docker.1*
 
@@ -178,9 +183,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{bash_compdir}/docker
 
+%if %{with vim}
 %files -n vim-syntax-%{name}
 %defattr(644,root,root,755)
 %doc contrib/syntax/vim/{README.md,LICENSE}
 %{_vimdatadir}/doc/dockerfile.txt
 %{_vimdatadir}/ftdetect/dockerfile.vim
 %{_vimdatadir}/syntax/dockerfile.vim
+%endif
This page took 0.032852 seconds and 4 git commands to generate.