]> git.pld-linux.org Git - packages/docker.git/blobdiff - docker.spec
up to 1.10.3 (2016-03-10)
[packages/docker.git] / docker.spec
index 5d1c084570918691256ff07c42aae8a9d5189315..07da71d2128a894436e11171011558b30cf14dda 100644 (file)
@@ -3,21 +3,26 @@
 %bcond_with    tests           # build without tests
 %bcond_with    vim                     # build vim syntax package
 
+# NOTES
+# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
+
 Summary:       Docker: the open-source application container engine
 Name:          docker
-Version:       1.6.2
+Version:       1.10.3
 Release:       1
 License:       Apache v2.0
 Group:         Applications/System
 Source0:       https://github.com/docker/docker/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 81a1a015ec0520d739ec721f8295d94f
+# Source0-md5: 34da67232c13c0bcc1bba8980151174d
+Source1:       %{name}.sh
 Source5:       %{name}.service
 Source6:       %{name}.init
 Source7:       %{name}.sysconfig
-URL:           https://github.com/docker/docker
-BuildRequires: btrfs-progs-devel
-BuildRequires: device-mapper-devel
-BuildRequires: golang >= 1.3.1
+URL:           http://www.docker.com/
+BuildRequires: btrfs-progs-devel >= 3.16.1
+BuildRequires: device-mapper-devel >= 2.02.89
+BuildRequires: golang >= 1.4
+BuildRequires: libseccomp-devel >= 2.2.1
 BuildRequires: rpmbuild(macros) >= 1.228
 BuildRequires: sqlite3-devel >= 3.7.9
 Requires(post,preun):  /sbin/chkconfig
@@ -44,6 +49,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                bash_compdir    %{_datadir}/bash-completion/completions
 %define                _vimdatadir             %{_datadir}/vim
+%define                _libexecdir             %{_prefix}/lib
 
 # binary stripped or something
 %define                _enable_debug_packages 0
@@ -112,12 +118,14 @@ DEBUG=1 hack/make.sh dynbinary
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,/etc/{rc.d/init.d,sysconfig},%{systemdunitdir}} \
+       $RPM_BUILD_ROOT%{_libexecdir} \
        $RPM_BUILD_ROOT/var/lib/docker/{aufs,containers,execdriver,graph,init,tmp,trust,vfs,volumes}
 
 install -p bundles/%{version}/dynbinary/docker-%{version} $RPM_BUILD_ROOT%{_bindir}/docker
 install -p bundles/%{version}/dynbinary/dockerinit-%{version} $RPM_BUILD_ROOT%{_bindir}/dockerinit
 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/docker
+install -p %{SOURCE1} $RPM_BUILD_ROOT%{_libexecdir}/docker
 cp -p %{SOURCE7} $RPM_BUILD_ROOT/etc/sysconfig/docker
 #cp -p packaging/debian/lxc-docker.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
@@ -164,6 +172,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(754,root,root) /etc/rc.d/init.d/docker
 %attr(755,root,root) %{_bindir}/docker
 %attr(755,root,root) %{_bindir}/dockerinit
+%attr(755,root,root) %{_libexecdir}/docker
 %{systemdunitdir}/docker.service
 /lib/udev/rules.d/80-docker.rules
 #%{_mandir}/man1/lxc-docker.1*
This page took 0.18957 seconds and 4 git commands to generate.