]> git.pld-linux.org Git - packages/docker-compose.git/commitdiff
up to 1.25.2 auto/th/docker-compose-1.25.2-1
authorJan Palus <atler@pld-linux.org>
Tue, 21 Jan 2020 17:20:01 +0000 (18:20 +0100)
committerJan Palus <atler@pld-linux.org>
Tue, 21 Jan 2020 17:20:01 +0000 (18:20 +0100)
docker-compose.spec
remove-requires-upper-bound.patch

index 020bff7aeb81b24416bc020b24bfab9ed46d9c21..1fa6109fbbd77e64cd4f5e55307b4be2a172534f 100644 (file)
@@ -7,13 +7,13 @@
 %define                pypi_name       docker-compose
 Summary:       Multi-container orchestration for Docker
 Name:          docker-compose
-Version:       1.25.1
+Version:       1.25.2
 Release:       1
 License:       Apache v2.0
 Group:         Applications/System
 # https://github.com/docker/compose/releases
 Source0:       https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
-# Source0-md5: 2a398250f6a1686e54e8ffd60943e6fc
+# Source0-md5: 82ac7d4449180c5fa592e7f9ced352e7
 Patch0:                remove-requires-upper-bound.patch
 URL:           https://docs.docker.com/compose/
 %if %{with tests}
index 5a28d4f9f0c1c3b338175f9f6f4cbda5118a193e..6f2bfb5de73f38da2b0b7af21bb0a87c66c2025b 100644 (file)
@@ -1,31 +1,34 @@
-diff -ur docker-compose-1.19.0.orig/requirements.txt docker-compose-1.19.0/requirements.txt
---- docker-compose-1.19.0.orig/requirements.txt        2018-03-05 21:55:17.014552784 +0100
-+++ docker-compose-1.19.0/requirements.txt     2018-03-05 21:56:54.020768816 +0100
-@@ -1,24 +1,23 @@
+diff -ur docker-compose-1.25.2.orig/requirements.txt docker-compose-1.25.2/requirements.txt
+--- docker-compose-1.25.2.orig/requirements.txt        2020-01-21 18:13:39.348446291 +0100
++++ docker-compose-1.25.2/requirements.txt     2020-01-21 18:15:48.717904899 +0100
+@@ -1,26 +1,25 @@
+-backports.shutil_get_terminal_size==1.0.0
 -backports.ssl-match-hostname==3.5.0.1; python_version < '3'
--cached-property==1.3.0
--certifi==2017.4.17
+-cached-property==1.5.1
+-certifi==2019.11.28
 -chardet==3.0.4
--colorama==0.4.0; sys_platform == 'win32'
+-colorama==0.4.3; sys_platform == 'win32'
 -docker==4.1.0
 -docker-pycreds==0.4.0
 -dockerpty==0.4.1
 -docopt==0.6.2
 -enum34==1.1.6; python_version < '3.4'
 -functools32==3.2.3.post2; python_version < '3.2'
--idna==2.5
--ipaddress==1.0.18
--jsonschema==3.0.1
--paramiko==2.6.0
+-idna==2.8
+-ipaddress==1.0.23
+-jsonschema==3.2.0
+-paramiko==2.7.1
 -pypiwin32==219; sys_platform == 'win32' and python_version < '3.6'
 -pypiwin32==223; sys_platform == 'win32' and python_version >= '3.6'
--PySocks==1.6.7
--PyYAML==4.2b1
+-PySocks==1.7.1
+-PyYAML==5.3
 -requests==2.22.0
 -six==1.12.0
+-subprocess32==3.5.4; python_version < '3.2'
 -texttable==1.6.2
--urllib3==1.24.2; python_version == '3.3'
--websocket-client==0.32.0
+-urllib3==1.25.7; python_version == '3.3'
+-websocket-client==0.57.0
++backports.shutil_get_terminal_size
 +backports.ssl-match-hostname; python_version < '3'
 +cached-property
 +certifi
@@ -46,18 +49,20 @@ diff -ur docker-compose-1.19.0.orig/requirements.txt docker-compose-1.19.0/requi
 +PyYAML
 +requests
 +six
++subprocess32; python_version < '3.2'
 +texttable
 +urllib3; python_version == '3.3'
 +websocket-client
---- docker-compose-1.25.0/setup.py.orig        2019-11-14 15:46:09.000000000 +0100
-+++ docker-compose-1.25.0/setup.py     2019-11-21 00:25:32.143128603 +0100
+diff -ur docker-compose-1.25.2.orig/setup.py docker-compose-1.25.2/setup.py
+--- docker-compose-1.25.2.orig/setup.py        2020-01-20 18:06:19.000000000 +0100
++++ docker-compose-1.25.2/setup.py     2020-01-21 18:17:44.417383294 +0100
 @@ -30,16 +30,16 @@
  
  
  install_requires = [
 -    'cached-property >= 1.2.0, < 2',
 -    'docopt >= 0.6.1, < 1',
--    'PyYAML >= 3.10, < 5',
+-    'PyYAML >= 3.10, < 6',
 -    'requests >= 2.20.0, < 3',
 -    'texttable >= 0.9.0, < 2',
 -    'websocket-client >= 0.32.0, < 1',
@@ -71,7 +76,7 @@ diff -ur docker-compose-1.19.0.orig/requirements.txt docker-compose-1.19.0/requi
 +    'requests >= 2.20.0',
 +    'texttable >= 0.9.0',
 +    'websocket-client >= 0.32.0',
-+    'docker >= 3.7.0',
++    'docker[ssh] >= 3.7.0',
 +    'dockerpty >= 0.4.1',
 +    'six >= 1.3.0',
 +    'jsonschema >= 2.5.1',
This page took 0.093443 seconds and 4 git commands to generate.