]> git.pld-linux.org Git - packages/docker-compose.git/blobdiff - docker-compose.spec
up to 1.28.5
[packages/docker-compose.git] / docker-compose.spec
index 5f467e0adab4326e4f693194be2c5c93290d06b0..5b731fb87aca4549440c519be6fbe78a3db89456 100644 (file)
@@ -2,30 +2,36 @@
 # Conditional build:
 %bcond_with    tests   # do not perform "make test"
 
+%define                module          compose
+%define                egg_name        docker_compose
 %define                pypi_name       docker-compose
 Summary:       Multi-container orchestration for Docker
 Name:          docker-compose
-Version:       1.8.0
+Version:       1.28.5
 Release:       1
 License:       Apache v2.0
 Group:         Applications/System
 # https://github.com/docker/compose/releases
 Source0:       https://files.pythonhosted.org/packages/source/d/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
-# Source0-md5: 2e01829bfecfe18832281f6432b4afb4
+# Source0-md5: a13bbf434827a963493932858aa2d052
 Patch0:                remove-requires-upper-bound.patch
 URL:           https://docs.docker.com/compose/
 %if %{with tests}
-BuildRequires: python-PyYAML
-BuildRequires: python-docker
-BuildRequires: python-docopt
-BuildRequires: python-requests
-BuildRequires: python-setuptools
-BuildRequires: python-texttable
-BuildRequires: python-websocket-client
+BuildRequires: python3-PyYAML
+BuildRequires: python3-docker
+BuildRequires: python3-docopt
+BuildRequires: python3-paramiko
+BuildRequires: python3-requests
+BuildRequires: python3-setuptools
+BuildRequires: python3-texttable
+BuildRequires: python3-websocket-client
 %endif
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
-Requires:      docker >= 1.10.0
+Requires:      docker(engine) >= 1.10.0
+Requires:      python3-docker >= 4.4.4
+Requires:      python3-paramiko >= 2.4.2
+Requires:      python3-setuptools
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -47,19 +53,18 @@ Docker-compose allows you to:
 rm -r docker_compose.egg-info
 
 %build
-%py_build
+%py3_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%py_install
-%py_postclean
+%py3_install
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGES.md CONTRIBUTING.md README.rst SWARM.md LICENSE
+%doc CHANGELOG.md CONTRIBUTING.md README.md SWARM.md LICENSE
 %attr(755,root,root) %{_bindir}/%{name}
-%{py_sitescriptdir}/compose
-%{py_sitescriptdir}/docker_compose-%{version}-py*.egg-info
+%{py3_sitescriptdir}/%{module}
+%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.074372 seconds and 4 git commands to generate.