]> git.pld-linux.org Git - packages/docker-ce.git/blobdiff - docker-ce.spec
up to 17.12.0
[packages/docker-ce.git] / docker-ce.spec
index 9665e8e392c852b41b730ff197a739350888c76d..9c5fd5b84427285af25d131f4b04e5ffee5e90ef 100644 (file)
@@ -9,30 +9,31 @@
 # NOTES
 # https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
 
-# v1.0.0-rc2-394-g810190ce
-%define        runc_commit 810190c
-# v0.2.8-45-g6e23458c
-%define        containerd_commit 6e23458
+# v1.0.0-rc2-528-g3f2f8b84
+%define        runc_commit b2567b3
+# v0.2.9-27-g06b9cb35
+%define        containerd_commit 89623f2
 # v0.8.0-dev.2-624-g7b2b1feb
 %define        libnetwork_commit 7b2b1fe
-#define        subver -rc1
+#define        subver -rc2
 Summary:       Docker CE: the open-source application container engine
 Name:          docker-ce
 # Using Docker-CE, Stay on Stable channel
 # https://docs.docker.com/engine/installation/
-Version:       17.06.2
+Version:       17.12.0
 Release:       1
 License:       Apache v2.0
 Group:         Applications/System
 # https://github.com/docker/docker-ce/releases
+#Source0:      https://github.com/docker/docker-ce/archive/v%{version}-ce%{subver}/%{name}-%{version}-ce%{subver}.tar.gz
 Source0:       https://github.com/docker/docker-ce/archive/v%{version}-ce/%{name}-%{version}-ce.tar.gz
-# Source0-md5: 45f92308bd542b6a8344c490d0383b64
+# Source0-md5: 545b780b4cf5bb1c83c5615d7153e9c7
 Source1:       https://github.com/docker/runc/archive/%{runc_commit}/runc-%{runc_commit}.tar.gz
-# Source1-md5: d2d5d628662bfbe11fd0d1bb7eb1c63c
-Source2:       https://github.com/docker/containerd/archive/%{containerd_commit}/containerd-%{containerd_commit}.tar.gz
-# Source2-md5: d1d057d831d46021cefee3a3c52c6c65
+# Source1-md5: 1a3088f614219774676fe9416f220e36
+Source2:       https://github.com/containerd/containerd/archive/%{containerd_commit}/containerd-%{containerd_commit}.tar.gz
+# Source2-md5: ada04f6ed5e19ae9da47a55778cc536b
 Source3:       https://github.com/docker/libnetwork/archive/%{libnetwork_commit}/libnetwork-%{libnetwork_commit}.tar.gz
-# Source3-md5: 9360e38c43e862e42c128db1852ac5bb
+# Source3-md5: a9beb9207b291373dc4e376f04056e8a
 Source4:       https://github.com/krallin/tini/archive/v0.13.0/tini-0.13.0.tar.gz
 # Source4-md5: c29541112a242c53c82bb6b1213f288f
 Source5:       dockerd.sh
@@ -43,10 +44,11 @@ URL:                https://www.docker.com/community-edition/
 BuildRequires: btrfs-progs-devel >= 3.16.1
 BuildRequires: cmake
 BuildRequires: device-mapper-devel >= 2.02.89
-BuildRequires: golang >= 1.6
+BuildRequires: golang >= 1.9
 BuildRequires: libseccomp-devel >= 2.2.1
 BuildRequires: rpmbuild(macros) >= 1.644
 BuildRequires: sqlite3-devel >= 3.7.9
+BuildRequires: xxd
 Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/groupdel
 Requires(pre): /usr/bin/getgid
@@ -146,14 +148,15 @@ BuildArch:        noarch
 This plugin provides syntax highlighting in Dockerfile.
 
 %prep
-%setup -q -n docker-ce-%{version}-ce%{?subver} -a1 -a2 -a3 -a4
+%setup -q -n %{name}-%{version}-ce%{?subver} -a1 -a2 -a3 -a4
 
 mv runc-%{runc_commit}* runc
 mv runc/vendor runc/src
 ln -s ../../.. runc/src/github.com/opencontainers/runc
 
 mv containerd-%{containerd_commit}* containerd
-ln -s ../../../.. containerd/vendor/src/github.com/containerd/containerd
+mv containerd/vendor containerd/src
+ln -s ../../.. containerd/src/github.com/containerd/containerd
 
 mv libnetwork-%{libnetwork_commit}* libnetwork
 install -d libnetwork/gopath
@@ -168,13 +171,10 @@ ln -s ../../../.. components/cli/.gopath/src/github.com/docker/cli
 %patch0 -p1 -d components/engine
 
 %build
-f=components/engine/hack/dockerfile/binaries-commits
-v=$(awk -F= '/^RUNC_COMMIT/ {print $2}' $f)
-echo "$v" | grep "^%{runc_commit}"
-v=$(awk -F= '/^CONTAINERD_COMMIT/ {print $2}' $f)
-echo "$v" | grep "^%{containerd_commit}"
-v=$(awk -F= '/^LIBNETWORK_COMMIT/ {print $2}' $f)
-echo "$v" | grep "^%{libnetwork_commit}"
+. components/engine/hack/dockerfile/binaries-commits
+echo "$RUNC_COMMIT" | grep "^%{runc_commit}"
+echo "$CONTAINERD_COMMIT" | grep "^%{containerd_commit}"
+echo "$LIBNETWORK_COMMIT" | grep "^%{libnetwork_commit}"
 
 export VERSION=%{version}
 export GITCOMMIT="pld/%{version}" # for cli
@@ -184,12 +184,13 @@ export DOCKER_GITCOMMIT="pld/%{version}" # for engine
 sed -i -e 's,shell git,shell false,' runc/Makefile
 GOPATH=$(pwd)/runc \
 %{__make} -C runc \
-       COMMIT=%{runc_commit}
+       COMMIT=$RUNC_COMMIT
 ./runc/runc -v
 
 # build docker-containerd
-GOPATH=$(pwd)/containerd/vendor \
-%{__make} -C containerd
+GOPATH=$(pwd)/containerd \
+%{__make} -C containerd \
+       GIT_COMMIT=$CONTAINERD_COMMIT
 
 # build docker-proxy
 cd libnetwork
@@ -207,6 +208,7 @@ cmake .
 # docker cli
 cd ../components/cli
 GOPATH=$(pwd)/.gopath \
+DISABLE_WARN_OUTSIDE_CONTAINER=1 \
 %{__make} dynbinary
 ./build/docker -v
 
This page took 0.157356 seconds and 4 git commands to generate.