]> git.pld-linux.org Git - packages/dnsmasq.git/blob - dnsmasq.spec
- inital version, fully functional
[packages/dnsmasq.git] / dnsmasq.spec
1 Summary:        A lightweight caching nameserver
2 Summary(pl):    Lekki buforuj±cy nameserver
3 Name:           dnsmasq
4 Version:        1.6
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        %{name}-%{version}.tar.gz
9 Source1:        %{name}.init
10 Source2:        %{name}.config
11 Patch0:         %{name}-cc.patch
12 URL:            http://www.thekelleys.org.uk/dnsmasq
13 PreReq:         /sbin/chkconfig
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Dnsmasq is lightweight, easy to configure DNS forwarder designed to
18 provide DNS (domain name) services to a small network where using BIND
19 would be overkill. It can be have its DNS servers automatically
20 configured by PPP or DHCP, and it can serve the names of local
21 machines which are not in the global DNS. It is ideal for networks
22 behind NAT routers and connected via modem, ISDN, ADSL, or cable-modem
23 connections.
24
25 %description -l pl
26 Dnsmasq jest lekkim, ³atwym do konfiguracji forwarderem DNS
27 zaprojektowanym do serwowania us³ugi DNS dla ma³ych sieci, gdzie u¿ywanie
28 BIND by³o by przesad±. Zewnêtrzne serwery DNS mog± byæ automatycznie
29 konfigurowane przez PPP lub DHCP. Mo¿e on serwowaæ tak¿e nazwy dla lokalnych
30 maszyn nie znajduj±cych siê w globalnym DNS. Jest idealny dla sieci za NAT
31 i po³±czonych przez modem, ISDL, ADSL lub po³±czenia kablowe.
32
33 %prep
34 %setup -q
35 %patch0 -p1
36
37 %build
38 %{__make} CC=%{__cc} OPTFLAGS="%{optflags}"
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 install -d $RPM_BUILD_ROOT{%{_sbindir},/etc/sysconfig,/etc/rc.d/init.d,%{_mandir}/man8}
44
45 install %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/dnsmasq
46 install %SOURCE2 $RPM_BUILD_ROOT/etc/sysconfig/dnsmasq
47 install dnsmasq $RPM_BUILD_ROOT%{_sbindir}
48 install dnsmasq.8 $RPM_BUILD_ROOT%{_mandir}/man8
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /sbin/chkconfig --add dnsmasq
55 if [ -f %{_localstatedir}/lock/subsys/dnsmasq ]; then
56         /etc/rc.d/init.d/dnsmasq restart >&2
57 else
58         echo "Run \"/etc/rc.d/init.d/dnsmasq start\" to start dnsmasq." >&2
59 fi
60
61 %preun
62 if [ "$1" = "0" ]; then
63         if [ -f %{_localstatedir}/lock/subsys/dnsmasq ]; then
64                 /etc/rc.d/init.d/dnsmasq stop
65         fi
66         /sbin/chkconfig --del dnsmasq
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc CHANGELOG COPYING doc.html
72 %attr(755,root,root) /etc/rc.d/init.d/dnsmasq
73 %attr(755,root,root) %{_sbindir}/dnsmasq
74 %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/dnsmasq
75 %{_mandir}/man8/*
This page took 0.068132 seconds and 4 git commands to generate.