]> git.pld-linux.org Git - packages/dnprogs.git/blobdiff - dnprogs.spec
- tabs, don't use attr(-,...)
[packages/dnprogs.git] / dnprogs.spec
index 5094198ed9f1c7b8eec70ff4ca496301c7c95c28..9adc21b752f74850a4c13bbfca4e25fd441034fc 100644 (file)
@@ -1,26 +1,22 @@
-Summary:       DECnet tools and libraries
-Summary(pl):   Narzêdzia i biblioteki DECnet
-Name:          dnprogs
-
 %define dnet_major 1
 %define dnet_version %{dnet_major}.2
-
-%define dap_major 1
-%define dap_version %{dap_major}.05a
-
+%define dap_major 2
+%define dap_version %{dap_major}.23
 %define dnprogs_version %{dap_version}
-
+Summary:       DECnet tools and libraries
+Summary(pl):   Narzêdzia i biblioteki DECnet
+Name:          dnprogs
 Version:       %{dnprogs_version}
-Release:       2
+Release:       0.1
 License:       GPL
 Group:         Networking/Utilities
-URL:           http://linux.dreamtime.org/decnet/
-Source0:       ftp://ftp.dreamtime.org/pub/decnet/%{name}-%{version}.tar.gz
-Patch0:                %{name}-1.05a-make.patch.gz
-Patch1:                %{name}-1.05a-rc.patch.gz
+Source0:       http://dl.sourceforge.net/linux-decnet/%{name}-%{version}.tar.gz
+# Source0-md5: 666e1479f60f7f0fe3bf8da3abab98bd
+URL:           http://linux-decnet.sourceforge.net/
+PreReq:                rc-scripts
+Requires(post,preun):  /sbin/chkconfig
+Requires(post):        /sbin/ldconfig
 ExclusiveOS:   Linux
-Prereq:                /sbin/chkconfig
-Prereq:                /sbin/ldconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -38,15 +34,13 @@ instructions on how to apply it.
 Programy DECnet dla Linuksa. Narzêdzia te stanowi± warstwê interfejsu
 aplikacji dla DECnetu na systemach linuksowych. Udostêpniaj± pewne
 u³atwienia w dostêpie terminalowym i plikowym miêdzy OpenVMS-em a
-Linuksem oraz zdalnym wykonywaniem poleceñ. Aby ich u¿yæ musi siê mieæ
-wbudowan± w j±do obs³ugê DECnetu. £atê oraz instrukcje dotycz±ce jej
+Linuksem oraz zdalnym wykonywaniem poleceñ. Aby ich u¿yæ trzeba mieæ
+wbudowan± w j±dro obs³ugê DECnetu. £atê oraz instrukcje dotycz±ce jej
 instalacji mo¿na uzyskaæ na stronie:
 http://linux.dreamtime.org/decnet/.
 
 %prep
 %setup -q
-%patch0 -p1 -b .make~
-%patch1 -p1 -b .rc~
 
 find . -type f -name '*~' -print0 | xargs -0 rm -f
 
@@ -87,43 +81,38 @@ rm -rf $RPM_BUILD_ROOT
 
 %postun
 /sbin/ldconfig
-if [ $1 = 0 ]; then
-    /sbin/chkconfig --del decnet
+if [ "$1" = "0" ]; then
+       /sbin/chkconfig --del decnet
 fi
 
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
 %doc Documentation/* README NEWS dnprogs.lsm
-
 %config(noreplace) %{_sysconfdir}/decnet.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/decnet.proxy
-
 %attr(754,root,root) /etc/rc.d/init.d/decnet
-%attr(-,root,root) /lib/libdnet.so.%{dnet_major}
+%attr(755,root,root) /lib/libdnet.so.%{dnet_major}
 %attr(755,root,root) /lib/libdnet.so.%{dnet_version}
-
 %attr(755,root,root) /sbin/startnet
-
 %attr(755,root,root) %{_bindir}/dncopy
 %attr(755,root,root) %{_bindir}/dndel
 %attr(755,root,root) %{_bindir}/dndir
 %attr(755,root,root) %{_bindir}/dnping
-%attr(-,root,root) %{_bindir}/dnprint
+%attr(755,root,root) %{_bindir}/dnprint
 %attr(755,root,root) %{_bindir}/dnsubmit
 %attr(755,root,root) %{_bindir}/dntask
-%attr(-,root,root) %{_bindir}/dntype
+%attr(755,root,root) %{_bindir}/dntype
 %attr(755,root,root) %{_bindir}/phone
 %attr(755,root,root) %{_bindir}/sethost
-
 %{_includedir}/netdnet
-
 %{_libdir}/libdnet.a
-%attr(-,root,root) %{_libdir}/libdnet.so
+%attr(755,root,root) %{_libdir}/libdnet.so
 %{_libdir}/libdap.a
-%attr(-,root,root) %{_libdir}/libdap.so
-%attr(-,root,root) %{_libdir}/libdap.so.%{dap_major}
+%attr(755,root,root) %{_libdir}/libdap.so
+%attr(755,root,root) %{_libdir}/libdap.so.%{dap_major}
 %attr(755,root,root) %{_libdir}/libdap.so.%{dap_version}
-
 %{_mandir}/man1/ctermd.1*
 %{_mandir}/man1/dncopy.1*
 %{_mandir}/man1/dndel.1*
@@ -138,7 +127,6 @@ fi
 %{_mandir}/man1/phone.1*
 %{_mandir}/man1/sethost.1*
 %{_mandir}/man1/startnet.1*
-
 %{_mandir}/man3/dnet_addr.3*
 %{_mandir}/man3/dnet_conn.3*
 %{_mandir}/man3/dnet_htoa.3*
@@ -148,13 +136,10 @@ fi
 %{_mandir}/man3/getnodebyname.3*
 %{_mandir}/man3/libdnet.3*
 %{_mandir}/man3/setnodeent.3*
-
 %{_mandir}/man5/decnet.conf.5*
 %{_mandir}/man5/decnet.proxy.5*
-
 %{_mandir}/man8/fal.8*
 %{_mandir}/man8/phoned.8*
-
 %attr(755,root,root) %{_sbindir}/ctermd
 %attr(755,root,root) %{_sbindir}/dnmirror
 %attr(755,root,root) %{_sbindir}/fal
This page took 0.138045 seconds and 4 git commands to generate.