]> git.pld-linux.org Git - packages/dmsdos.git/commitdiff
- optflags patch for dmsdos
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 3 Apr 2002 13:05:18 +0000 (13:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dmsdos-opt.patch -> 1.1

dmsdos-opt.patch [new file with mode: 0644]

diff --git a/dmsdos-opt.patch b/dmsdos-opt.patch
new file mode 100644 (file)
index 0000000..ccfa917
--- /dev/null
@@ -0,0 +1,57 @@
+--- dmsdos-0.9.2.2/src/Makefile.orig   Fri Oct 22 18:17:28 1999
++++ dmsdos-0.9.2.2/src/Makefile        Wed Apr  3 14:57:01 2002
+@@ -12,24 +12,24 @@
+ # guess some special flags for CPU type - used for optimization only
+ CPUFLAGS=
+ ifeq ($(CONFIG_M386),y)
+-CPUFLAGS= -m386 -DCPU=386 -DUSE_ASM
++CPUFLAGS= -DCPU=386 -DUSE_ASM
+ endif
+ ifeq ($(CONFIG_M486),y)
+-CPUFLAGS= -m486 -DCPU=486 -DUSE_ASM
++CPUFLAGS= -DCPU=486 -DUSE_ASM
+ endif
+ ifeq ($(CONFIG_M586),y)
+-CPUFLAGS= -m486 -DCPU=586 -DUSE_ASM
++CPUFLAGS= -DCPU=586 -DUSE_ASM
+ endif
+ # this one is new in 2.2.x kernels...
+ ifeq ($(CONFIG_M586TSC),y)
+-CPUFLAGS= -m486 -DCPU=586 -DUSE_ASM
++CPUFLAGS= -DCPU=586 -DUSE_ASM
+ endif
+ ifeq ($(CONFIG_M686),y)
+-CPUFLAGS= -m486 -DCPU=686 -DUSE_ASM
++CPUFLAGS= -DCPU=686 -DUSE_ASM
+ endif
+ # this one is new in 2.3.x kernels...
+ ifeq ($(CONFIG_MK7),y)
+-CPUFLAGS= -m486 -DCPU=686 -DUSE_ASM
++CPUFLAGS= -DCPU=686 -DUSE_ASM
+ endif
+ #
+ # Okay, that's it :)
+@@ -72,7 +72,7 @@
+ #
+ # CFLAGS for dmsdos module
+ # note: some macro expansions require at least -O
+-CFLAGS= -Wall -Wstrict-prototypes -O3 -fomit-frame-pointer -D__KERNEL__ -DMODULE
++CFLAGS= -Wall -Wstrict-prototypes $(OPT) -fomit-frame-pointer -D__KERNEL__ -DMODULE
+ CFLAGS+= $(CPUFLAGS)
+ #
+ # The next lines add some stuff automatically for people using modversions
+@@ -83,12 +83,12 @@
+ #
+ # CFLAGS for the dmsdos daemon
+ # note: some macro expansions require at least -O
+-DCFLAGS= -Wall -O3 -D__DMSDOS_DAEMON__
++DCFLAGS= -Wall $(OPT) -D__DMSDOS_DAEMON__
+ DCFLAGS+= $(CPUFLAGS)
+ #
+ # CFLAGS for the dmsdos library
+ # note: some macro expansions require at least -O
+-LCFLAGS= -Wall -O -ggdb -D__DMSDOS_LIB__ -DUSE_FLOCK
++LCFLAGS= -Wall $(OPT) -D__DMSDOS_LIB__ -DUSE_FLOCK
+ LCFLAGS+= $(CPUFLAGS) $(LIBC6FLAGS)
+ # uncomment the next line if you want a shared library
+ # LIB_SHARED = 1
This page took 0.037866 seconds and 4 git commands to generate.