]> git.pld-linux.org Git - packages/dmraid.git/commitdiff
- fix build with --as-needed:
authorsparky <sparky@pld-linux.org>
Sun, 30 Jul 2006 23:22:46 +0000 (23:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  libdmraid.so is the one linked with libdevmapper.so, not dmraid executable

Changed files:
    dmraid-as-needed.patch -> 1.1

dmraid-as-needed.patch [new file with mode: 0644]

diff --git a/dmraid-as-needed.patch b/dmraid-as-needed.patch
new file mode 100644 (file)
index 0000000..1981ab2
--- /dev/null
@@ -0,0 +1,38 @@
+--- dmraid/lib/Makefile.in     2006-07-30 22:48:53.000000000 +0000
++++ dmraid.as-needed/lib/Makefile.in   2006-07-30 22:52:10.000000000 +0000
+@@ -53,6 +53,24 @@
+   endif
+ endif
++ifeq ("@KLIBC@", "yes")
++      DMRAIDLIBS += -ldevmapper_klibc
++else
++      ifeq ("@DIETLIBC@", "yes")
++              DMRAIDLIBS += -ldevmapper_dietc
++      else
++              DMRAIDLIBS += -ldevmapper
++      endif
++
++#     ifeq ("@LIBSELINUX@", "yes")
++#             DMRAIDLIBS += -lselinux
++#     endif
++#
++#     ifeq ("@LIBSEPOL@", "yes")
++#             DMRAIDLIBS += -lsepol
++#     endif
++endif
++
+ all:
+       @echo "$(TARGETS) $(INSTALL_TARGETS)"
+--- dmraid/make.tmpl.in        2006-07-30 22:55:01.000000000 +0000
++++ dmraid.as-needed/make.tmpl.in      2006-07-30 22:57:38.000000000 +0000
+@@ -129,7 +129,7 @@
+ %.so: $(OBJECTS)
+       $(CC) -shared -Wl,-soname,$(notdir $@).$(DMRAID_LIB_VERSION) \
+-      -Wl,--version-script,.export.sym $(OBJECTS) -o $@
++      -Wl,--version-script,.export.sym $(DMRAIDLIBS) $(LDFLAGS) $(OBJECTS) -o $@
+ $(LIB_STATIC): $(OBJECTS)
+       $(RM) $@
This page took 0.131204 seconds and 4 git commands to generate.