]> git.pld-linux.org Git - packages/dmapi.git/commitdiff
- added miscfix patch for proper headers detection
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 8 Aug 2003 19:49:57 +0000 (19:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    dmapi-miscfix.patch -> 1.1
    dmapi.spec -> 1.26

dmapi-miscfix.patch [new file with mode: 0644]
dmapi.spec

diff --git a/dmapi-miscfix.patch b/dmapi-miscfix.patch
new file mode 100644 (file)
index 0000000..e0d6e21
--- /dev/null
@@ -0,0 +1,28 @@
+--- dmapi-2.0.8/m4/manual_format.m4.orig       2003-06-25 03:51:30.000000000 +0200
++++ dmapi-2.0.8/m4/manual_format.m4    2003-08-08 21:25:15.000000000 +0200
+@@ -6,12 +6,5 @@
+ # 
+ AC_DEFUN([AC_MANUAL_FORMAT],
+   [ have_zipped_manpages=false
+-    for d in ${prefix}/share/man ${prefix}/man ; do
+-        if test -f $d/man1/man.1.gz
+-        then
+-            have_zipped_manpages=true
+-            break
+-        fi
+-    done
+     AC_SUBST(have_zipped_manpages)
+   ])
+--- dmapi-2.0.8/m4/package_utilies.m4.orig     2003-06-25 03:51:30.000000000 +0200
++++ dmapi-2.0.8/m4/package_utilies.m4  2003-08-08 21:25:25.000000000 +0200
+@@ -17,9 +17,7 @@
+ #  MSGFMT MSGMERGE RPM
+ #
+ AC_DEFUN([AC_PACKAGE_UTILITIES],
+-  [ if test -z "$CC"; then
+-        AC_PROG_CC
+-    fi
++  [ AC_PROG_CC
+     cc="$CC"
+     AC_SUBST(cc)
+     AC_PACKAGE_NEED_UTILITY($1, "$cc", cc, [C compiler])
index 39317a6ed469f9452b8e743f6e84660ba3ee1401..d6e1cdc4f39f4959a22c32d2eba4f0cc80c9e418 100644 (file)
@@ -7,8 +7,10 @@ License:       LGPL/GPL
 Group:         Libraries
 Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
 # Source0-md5: a8e2aef7a50a161b92ee30a300f84b4e
+Patch0:                %{name}-miscfix.patch
 URL:           http://oss.sgi.com/projects/xfs/
 BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: xfsprogs-devel >= 2.0.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -61,12 +63,15 @@ Static version of DMAPI library.
 Statyczna wersja biblioteki DMAPI.
 
 %prep
-%setup  -q
+%setup -q
+%patch -p1
 
 %build
-DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
+rm -f aclocal.m4
+%{__aclocal} -I m4
 %{__autoconf}
 %configure \
+       DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
        OPTIMIZER="%{rpmcflags}"
 
 %{__make}
@@ -85,7 +90,8 @@ export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV
        DIST_MANIFEST=$DIST_INSTALL_DEV
 
 rm -f $RPM_BUILD_ROOT%{_libexecdir}/libdm.so
-ln -sf %{_libdir}/libdm.so.0.0.4 $RPM_BUILD_ROOT%{_libexecdir}/libdm.so
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libdm.so.*.*.*) \
+       $RPM_BUILD_ROOT%{_libexecdir}/libdm.so
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -101,8 +107,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%{_libexecdir}/lib*.la
 %attr(755,root,root) %{_libexecdir}/lib*.so
+%{_libexecdir}/lib*.la
 %{_includedir}/xfs/*
 %{_mandir}/man3/*
 
This page took 0.067208 seconds and 4 git commands to generate.