]> git.pld-linux.org Git - packages/djvulibre.git/blame_incremental - djvulibre.spec
- x32 rebuild
[packages/djvulibre.git] / djvulibre.spec
... / ...
CommitLineData
1# TODO: use system qt qt.qm files instead of included copies
2#
3# Conditional build:
4%define base_ver 3.5.25
5%define minor_ver .3
6#
7Summary: DjVu viewers, encoders and utilities
8Summary(pl.UTF-8): DjVu - przeglądarki, dekodery oraz narzędzia
9Name: djvulibre
10Version: %{base_ver}%{minor_ver}
11Release: 4
12License: GPL v2+
13Group: Applications/Graphics
14Source0: http://downloads.sourceforge.net/djvu/%{name}-%{version}.tar.gz
15# Source0-md5: 5f45d6cd5700b4dd31b1eb963482089b
16Patch0: %{name}-opt.patch
17Patch1: djvulibre-3.5.22-cdefs.patch
18URL: http://djvu.sourceforge.net/
19BuildRequires: autoconf >= 2.65
20BuildRequires: automake
21BuildRequires: libjpeg-devel
22BuildRequires: libstdc++-devel
23BuildRequires: libtool >= 2:2
24BuildRequires: pkgconfig
25BuildRequires: rpmbuild(macros) >= 1.357
26Obsoletes: djvu
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30DjVu is a web-centric format and software platform for distributing
31documents and images. DjVu content downloads faster, displays and
32renders faster, looks nicer on a screen, and consume less client
33resources than competing formats. DjVu was originally developed at
34AT&T Labs-Research by Leon Bottou, Yann LeCun, Patrick Haffner, and
35many others. In March 2000, AT&T sold DjVu to LizardTech Inc. who now
36distributes Windows/Mac plug-ins, and commercial encoders (mostly on
37Windows).
38
39In an effort to promote DjVu as a Web standard, the LizardTech
40management was enlightened enough to release the reference
41implementation of DjVu under the GNU GPL in October 2000. DjVuLibre
42(which means free DjVu), is an enhanced version of that code
43maintained by the original inventors of DjVu. It is compatible with
44version 3.5 of the LizardTech DjVu software suite.
45
46This package of DjVulibre 3.5 contains:
47- A full-fledged wavelet-based compressor for pictures.
48- A simple compressor for bitonal (black and white) scanned pages.
49- A compressor for palettized images (a la GIF/PNG).
50- A set of utilities to manipulate and assemble DjVu images and
51 documents.
52- A set of decoders to convert DjVu to a number of other formats.
53- An up-to-date version of the C++ DjVu Reference Library.
54
55%description -l pl.UTF-8
56DjVu jest przeznaczonym głównie dla WWW formatem i platformą
57programową do dystrybucji dokumentów i obrazków. Dane w DjVu ściągają
58się szybciej, wyświetlają szybciej, wyglądają ładniej na ekranie i
59zajmują mniej zasobów po stronie klienckiej niż inne formaty. DjVu
60oryginalnie został stworzony w AT&T Labs-Research przez Leona Bottou,
61Yanna LeCun, Patricka Haffnera i wielu innych. W marcu 2000 AT&T
62sprzedało DjVu firmie LizardTech Inc., które teraz rozpowszechnia
63wtyczki dla Windows i Maca oraz komercyjne kodery (głównie dla
64Windows).
65
66Aby wypromować DjVu jako sieciowy standard, LizardTech udostępnił
67wzorcową implementację DjVu na licencji GPL w październiku 2000.
68DjVuLibre (czyli wolne DjVu) jest rozszerzoną wersją tego kodu
69rozwijaną przez pomysłodawców DjVu. Jest kompatybilna z wersją 3.5
70oprogramowania LizardTech DjVu.
71
72Ten pakiet zawiera: bibliotekę w C++, zestaw kompresorów, dekoderów i
73narzędzi do plików w formacie DjVu.
74
75%package devel
76Summary: Header files for DjVu library
77Summary(pl.UTF-8): Pliki nagłówkowe biblioteki DjVu
78Group: Development/Libraries
79Requires: %{name} = %{version}-%{release}
80Requires: libjpeg-devel
81Requires: libstdc++-devel
82
83%description devel
84Header files for DjVu library.
85
86%description devel -l pl.UTF-8
87Pliki nagłówkowe biblioteki DjVu.
88
89%prep
90%setup -q -n %{name}-%{base_ver}
91%patch0 -p1
92%patch1 -p1
93
94%build
95%{__libtoolize}
96%{__aclocal} -I config
97%{__autoconf}
98%configure \
99 PTHREAD_LIBS="-lpthread" \
100 --disable-desktopfiles
101
102%{__make} -j1
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107%{__make} install \
108 DESTDIR=$RPM_BUILD_ROOT
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(644,root,root,755)
118%doc COPYRIGHT NEWS README doc/*
119%attr(755,root,root) %{_bindir}/any2djvu
120%attr(755,root,root) %{_bindir}/bzz
121%attr(755,root,root) %{_bindir}/c44
122%attr(755,root,root) %{_bindir}/cjb2
123%attr(755,root,root) %{_bindir}/cpaldjvu
124%attr(755,root,root) %{_bindir}/csepdjvu
125%attr(755,root,root) %{_bindir}/ddjvu
126%attr(755,root,root) %{_bindir}/djvm
127%attr(755,root,root) %{_bindir}/djvmcvt
128%attr(755,root,root) %{_bindir}/djvu*
129%attr(755,root,root) %{_libdir}/libdjvulibre.so.*.*.*
130%attr(755,root,root) %ghost %{_libdir}/libdjvulibre.so.21
131%{_mandir}/man1/any2djvu.1*
132%{_mandir}/man1/bzz.1*
133%{_mandir}/man1/c44.1*
134%{_mandir}/man1/cjb2.1*
135%{_mandir}/man1/cpaldjvu.1*
136%{_mandir}/man1/csepdjvu.1*
137%{_mandir}/man1/ddjvu.1*
138%{_mandir}/man1/djvm.1*
139%{_mandir}/man1/djvmcvt.1*
140%{_mandir}/man1/djvu*.1*
141%dir %{_datadir}/djvu
142%dir %{_datadir}/djvu/osi
143%{_datadir}/djvu/osi/languages.xml
144%lang(cs) %{_datadir}/djvu/osi/cs
145%lang(de) %{_datadir}/djvu/osi/de
146%{_datadir}/djvu/osi/en
147%lang(fr) %{_datadir}/djvu/osi/fr
148%lang(ja) %{_datadir}/djvu/osi/ja
149%lang(zh) %{_datadir}/djvu/osi/zh
150%{_datadir}/djvu/pubtext
151
152%files devel
153%defattr(644,root,root,755)
154%attr(755,root,root) %{_libdir}/libdjvulibre.so
155%{_libdir}/libdjvulibre.la
156%{_includedir}/libdjvu
157%{_pkgconfigdir}/ddjvuapi.pc
This page took 0.147355 seconds and 4 git commands to generate.