]> git.pld-linux.org Git - packages/djbdns.git/commitdiff
- fixes build
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 22 May 2008 16:41:55 +0000 (16:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    djbdns-ipv6-incfix.patch -> 1.1

djbdns-ipv6-incfix.patch [new file with mode: 0644]

diff --git a/djbdns-ipv6-incfix.patch b/djbdns-ipv6-incfix.patch
new file mode 100644 (file)
index 0000000..59fb18a
--- /dev/null
@@ -0,0 +1,83 @@
+http://bugs.gentoo.org/show_bug.cgi?id=8236
+
+diff -ur djbdns-1.05/Makefile djbdns-1.05.fixed/Makefile
+--- djbdns-1.05/Makefile       Mon Sep 23 01:04:22 2002
++++ djbdns-1.05.fixed/Makefile Mon Sep 23 01:09:11 2002
+@@ -332,7 +332,7 @@
+ dns_transmit.o: \
+ compile dns_transmit.c socket.h uint16.h alloc.h error.h byte.h \
+-uint16.h dns.h stralloc.h gen_alloc.h iopause.h taia.h tai.h uint64.h \
++uint32.h dns.h stralloc.h gen_alloc.h iopause.h taia.h tai.h uint64.h \
+ taia.h
+       ./compile dns_transmit.c
+@@ -855,15 +855,15 @@
+       rm -f trylsock.o trylsock
+ socket_accept.o: \
+-compile socket_accept.c byte.h socket.h uint16.h
++compile socket_accept.c byte.h socket.h uint16.h uint32.h
+       ./compile socket_accept.c
+ socket_accept6.o: \
+-compile socket_accept6.c byte.h socket.h uint16.h
++compile socket_accept6.c byte.h socket.h uint16.h uint32.h
+       ./compile socket_accept6.c
+ socket_bind.o: \
+-compile socket_bind.c byte.h socket.h uint16.h
++compile socket_bind.c byte.h socket.h uint16.h uint32.h
+       ./compile socket_bind.c
+ socket_bind6.o: \
+@@ -871,7 +871,7 @@
+       ./compile socket_bind6.c
+ socket_conn.o: \
+-compile socket_conn.c byte.h socket.h uint16.h
++compile socket_conn.c byte.h socket.h uint16.h uint32.h
+       ./compile socket_conn.c
+ socket_connect6.o: \
+@@ -879,11 +879,11 @@
+       ./compile socket_connect6.c
+ socket_listen.o: \
+-compile socket_listen.c socket.h uint16.h
++compile socket_listen.c socket.h uint16.h uint32.h
+       ./compile socket_listen.c
+ socket_recv.o: \
+-compile socket_recv.c byte.h socket.h uint16.h
++compile socket_recv.c byte.h socket.h uint16.h uint32.h
+       ./compile socket_recv.c
+ socket_recv6.o: \
+@@ -891,7 +891,7 @@
+       ./compile socket_recv6.c
+ socket_send.o: \
+-compile socket_send.c byte.h socket.h uint16.h
++compile socket_send.c byte.h socket.h uint16.h uint32.h
+       ./compile socket_send.c
+ socket_send6.o: \
+@@ -899,7 +899,7 @@
+       ./compile socket_send6.c
+ socket_tcp.o: \
+-compile socket_tcp.c ndelay.h socket.h uint16.h
++compile socket_tcp.c ndelay.h socket.h uint16.h uint32.h
+       ./compile socket_tcp.c
+ socket_tcp6.o: \
+@@ -907,7 +907,7 @@
+       ./compile socket_tcp6.c
+ socket_udp.o: \
+-compile socket_udp.c ndelay.h socket.h uint16.h
++compile socket_udp.c ndelay.h socket.h uint16.h uint32.h
+       ./compile socket_udp.c
+ socket_udp6.o: \
This page took 0.083793 seconds and 4 git commands to generate.