]> git.pld-linux.org Git - packages/discount.git/commitdiff
new, version 2.1.8
authorElan Ruusamäe <glen@delfi.ee>
Sat, 17 Oct 2015 11:44:21 +0000 (14:44 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 17 Oct 2015 11:44:21 +0000 (14:44 +0300)
based on fedora package 1aaa7d2

discount-ldconfig.patch [new file with mode: 0644]
discount.spec [new file with mode: 0644]

diff --git a/discount-ldconfig.patch b/discount-ldconfig.patch
new file mode 100644 (file)
index 0000000..c5c6017
--- /dev/null
@@ -0,0 +1,10 @@
+--- configure.inc.orig 2012-01-22 23:48:19.262732384 +0000
++++ configure.inc      2012-01-22 23:48:49.529329922 +0000
+@@ -1267,7 +1267,6 @@
+ install)$PROG_INSTALL -c \$FULLNAME "\$1"
+       $PROG_LN_S -f \$FULLNAME \$1/\$LIBNAME.\$MAJOR
+       $PROG_LN_S -f \$FULLNAME \$1/\$LIBNAME
+-      test "$LDCONFIG" && $LDCONFIG "\$1"
+       ;;
+ esac
+ EOF
diff --git a/discount.spec b/discount.spec
new file mode 100644 (file)
index 0000000..f7046cc
--- /dev/null
@@ -0,0 +1,105 @@
+Summary:       A command-line utility for converting Markdown files into HTML
+Name:          discount
+Version:       2.1.8
+Release:       1
+License:       BSD
+Group:         Applications
+URL:           http://www.pell.portland.or.us/~orc/Code/discount
+Source0:       %{url}/%{name}-%{version}.tar.gz
+# Source0-md5: fcb1e7a3d19c2e666655fa8a28066e76
+Patch0:                %{name}-ldconfig.patch
+Requires:      libmarkdown = %{version}-%{release}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+DISCOUNT is an implementation of John Gruber's Markdown language in C.
+It includes all of the original Markdown features, along with a few
+extensions, and passes the Markdown test suite.
+
+%package -n libmarkdown
+Summary:       A fast implementation of the Markdown language in C
+Group:         Libraries
+
+%description -n libmarkdown
+libmarkdown is the library portion of discount, a fast Markdown
+language implementation, written in C.
+
+%package -n libmarkdown-devel
+Summary:       Development headers for the libmarkdown library
+Group:         Development/Libraries
+Requires:      libmarkdown = %{version}-%{release}
+
+%description -n libmarkdown-devel
+This package contains development headers and developer-oriented man
+pages for libmarkdown.
+
+%prep
+%setup -q
+%patch0
+
+%build
+# NOTE: not autoconf based configure
+CC="%{__cc}" \
+CFLAGS="%{rpmcflags}" \
+LDFLAGS="%{rpmldflags}" \
+./configure.sh \
+       --shared \
+       --prefix=%{_prefix} \
+       --execdir=%{_bindir} \
+       --libdir=%{_libdir} \
+       --mandir=%{_mandir} \
+       --enable-all-features \
+       --with-fenced-code
+
+%{__make}
+
+%if %{with tests}
+%{__make} test
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__make} install.everything \
+       DESTDIR=$RPM_BUILD_ROOT
+
+# Rename sample programs (names are too generic) and matching man1 pages
+mv $RPM_BUILD_ROOT%{_bindir}/makepage $RPM_BUILD_ROOT%{_bindir}/discount-makepage
+mv $RPM_BUILD_ROOT%{_bindir}/mkd2html $RPM_BUILD_ROOT%{_bindir}/discount-mkd2html
+mv $RPM_BUILD_ROOT%{_bindir}/theme $RPM_BUILD_ROOT%{_bindir}/discount-theme
+mv $RPM_BUILD_ROOT%{_mandir}/man1/makepage.1 \
+   $RPM_BUILD_ROOT%{_mandir}/man1/discount-makepage.1
+mv $RPM_BUILD_ROOT%{_mandir}/man1/mkd2html.1 \
+   $RPM_BUILD_ROOT%{_mandir}/man1/discount-mkd2html.1
+mv $RPM_BUILD_ROOT%{_mandir}/man1/theme.1 \
+   $RPM_BUILD_ROOT%{_mandir}/man1/discount-theme.1
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -n libmarkdown -p /sbin/ldconfig
+%postun        -n libmarkdown -p /sbin/ldconfig
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/markdown
+%attr(755,root,root) %{_bindir}/discount-makepage
+%attr(755,root,root) %{_bindir}/discount-mkd2html
+%attr(755,root,root) %{_bindir}/discount-theme
+%{_mandir}/man1/markdown.1*
+%{_mandir}/man7/markdown.7*
+%{_mandir}/man1/discount-*.1*
+%{_mandir}/man7/mkd-*.7*
+
+%files -n libmarkdown
+%defattr(644,root,root,755)
+%doc README COPYRIGHT CREDITS
+%attr(755,root,root) %{_libdir}/libmarkdown.so.*.*.*
+%ghost %{_libdir}/libmarkdown.so.2
+
+%files -n libmarkdown-devel
+%defattr(644,root,root,755)
+%{_libdir}/libmarkdown.so
+%{_includedir}/mkdio.h
+%{_mandir}/man3/markdown.3*
+%{_mandir}/man3/mkd_*.3*
+%{_mandir}/man3/mkd-*.3*
This page took 0.092862 seconds and 4 git commands to generate.