]> git.pld-linux.org Git - packages/dirac.git/blob - dirac.spec
- pl for -libs
[packages/dirac.git] / dirac.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        General purpose video codec
7 Summary(pl.UTF-8):      Kodek obrazu ogólnego przeznaczenia
8 Name:           dirac
9 Version:        1.0.2
10 Release:        3
11 License:        MPL v1.1 or GPL v2 or LGPL v2.1
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/dirac/%{name}-%{version}.tar.gz
14 # Source0-md5:  a57c2c5e58062d437d9ab13dffb28f0f
15 Patch0:         %{name}-am.patch
16 URL:            http://www.bbc.co.uk/rd/projects/dirac/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:1.5
21 BuildRequires:  perl-base
22 %if %{with apidocs}
23 BuildRequires:  doxygen
24 BuildRequires:  tetex-dvips
25 BuildRequires:  tetex-format-latex
26 BuildRequires:  tetex-metafont
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _noautocompressdoc      *.map *.dot
31
32 %description
33 Dirac is a general-purpose video codec aimed at resolutions from QCIF
34 (180x144) to HDTV (1920x1080) progressive or interlaced. It uses
35 wavelets, motion compensation and arithmetic coding.
36
37 %description -l pl.UTF-8
38 Dirac jest kodekiem ogólnego przeznaczenia dla obrazu o
39 rozdzielczościach od QCIF (180x144) do HDTV (1920x1080). Kodek ten
40 wykorzystuje fale elementarne (wavelets), kompensację ruchu (motion
41 compensation) oraz kodowanie arytmetyczne (arithmetic coding).
42
43 %package libs
44 Summary:        Libraries for dirac codec
45 Summary(pl.UTF-8):      Biblioteki kodeka dirac
46 Group:          Libraries
47 Conflicts:      dirac < 1.0.2-3
48
49 %description libs
50 Dirac is a general-purpose video codec aimed at resolutions from QCIF
51 (180x144) to HDTV (1920x1080) progressive or interlaced. It uses
52 wavelets, motion compensation and arithmetic coding.
53
54 This package contains libraries for dirac.
55
56 %description libs -l pl.UTF-8
57 Dirac jest kodekiem ogólnego przeznaczenia dla obrazu o
58 rozdzielczościach od QCIF (180x144) do HDTV (1920x1080). Kodek ten
59 wykorzystuje fale elementarne (wavelets), kompensację ruchu (motion
60 compensation) oraz kodowanie arytmetyczne (arithmetic coding).
61
62 Ten pakiet zawiera biblioteki kodeka dirac.
63
64 %package devel
65 Summary:        Header files for dirac library
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki dirac
67 Group:          Development/Libraries
68 Requires:       %{name}-libs = %{version}-%{release}
69 Requires:       libstdc++-devel
70
71 %description devel
72 Header files for dirac library.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe biblioteki dirac.
76
77 %package static
78 Summary:        Static dirac library
79 Summary(pl.UTF-8):      Statyczna biblioteka dirac
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static dirac library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka dirac.
88
89 %package apidocs
90 Summary:        dirac API documentation
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki dirac
92 Group:          Documentation
93
94 %description apidocs
95 API and internal documentation for dirac library.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API biblioteki dirac.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal} -I m4
107 %{__autoconf}
108 %{__automake}
109 %configure \
110         %{!?with_static_libs:--disable-static}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         CPPUNITTESTS_DIR=
119
120 rm -f doc/api/html/*.md5
121 rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/dirac
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   libs -p /sbin/ldconfig
127 %postun libs -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc AUTHORS ChangeLog NEWS README TODO
132 %attr(755,root,root) %{_bindir}/BMPtoRGB
133 %attr(755,root,root) %{_bindir}/RGBtoBMP
134 %attr(755,root,root) %{_bindir}/RGBtoUYVY
135 %attr(755,root,root) %{_bindir}/RGBtoYUV411
136 %attr(755,root,root) %{_bindir}/RGBtoYUV420
137 %attr(755,root,root) %{_bindir}/RGBtoYUV422
138 %attr(755,root,root) %{_bindir}/RGBtoYUV444
139 %attr(755,root,root) %{_bindir}/UYVYtoRGB
140 %attr(755,root,root) %{_bindir}/UYVYtoYUV422
141 %attr(755,root,root) %{_bindir}/YUV411toRGB
142 %attr(755,root,root) %{_bindir}/YUV420Down2x2
143 %attr(755,root,root) %{_bindir}/YUV420ItoYUV422I
144 %attr(755,root,root) %{_bindir}/YUV420pt75filter
145 %attr(755,root,root) %{_bindir}/YUV420toRGB
146 %attr(755,root,root) %{_bindir}/YUV420toYUV422
147 %attr(755,root,root) %{_bindir}/YUV422ItoYUV420I
148 %attr(755,root,root) %{_bindir}/YUV422toRGB
149 %attr(755,root,root) %{_bindir}/YUV422toUYVY
150 %attr(755,root,root) %{_bindir}/YUV422toYUV420
151 %attr(755,root,root) %{_bindir}/YUV444toRGB
152 %attr(755,root,root) %{_bindir}/create_dirac_testfile.pl
153 %attr(755,root,root) %{_bindir}/dirac_decoder
154 %attr(755,root,root) %{_bindir}/dirac_encoder
155 %attr(755,root,root) %{_bindir}/dirac_instrumentation
156
157 %files libs
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libdirac_decoder.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libdirac_decoder.so.0
161 %attr(755,root,root) %{_libdir}/libdirac_encoder.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libdirac_encoder.so.0
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libdirac_decoder.so
167 %attr(755,root,root) %{_libdir}/libdirac_encoder.so
168 %{_libdir}/libdirac_decoder.la
169 %{_libdir}/libdirac_encoder.la
170 %{_includedir}/%{name}
171 %{_pkgconfigdir}/dirac.pc
172
173 %if %{with static_libs}
174 %files static
175 %defattr(644,root,root,755)
176 %{_libdir}/libdirac_decoder.a
177 %{_libdir}/libdirac_encoder.a
178 %endif
179
180 %if %{with apidocs}
181 %files apidocs
182 %defattr(644,root,root,755)
183 %doc doc/html
184 %doc doc/dirac_api_{foot,head}.html
185 %endif
This page took 0.03893 seconds and 3 git commands to generate.