]> git.pld-linux.org Git - packages/dime.git/blob - dime.spec
94cdbd4bc06aadf41befdf4e5ac1c810774f72bc
[packages/dime.git] / dime.spec
1 Summary:        DIME - DXF Import, manipulation and Export library
2 Summary(pl):    DIME - biblioteka do manipulacji plikami w formacie DXF
3 Name:           dime
4 Version:        0.9.1
5 Release:        3
6 License:        GPL
7 Group:          Libraries
8 # Old site:     ftp://ftp.sim.no/pub/dime/
9 # New site(?):  http://download.berlios.de/cad2octree/
10 Source0:        %{name}-%{version}-src.tar.bz2
11 # Source0-md5:  142af240cd35508d606917a38164c759
12 Source1:        %{name}-%{version}-doc.tar.bz2
13 # Source1-md5:  994706320ce7d222a1597913ba0cbee0
14 BuildRequires:  gcc-c++
15 BuildRequires:  tetex-dvips
16 BuildRequires:  tetex-fonts-ams
17 BuildRequires:  tetex-format-latex
18 BuildRequires:  tetex-makeindex
19 BuildRequires:  tetex-metafont
20 BuildRequires:  tetex-tex-misc
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Dime is a C++ class library for reading, constructing, manipulating,
25 and writing DXF file data. The name is an acronym for DXF Import,
26 Manipulation, and Export library. The DXF file format originates from
27 AutoCAD, but is now in widespread use.
28
29 The focus of the library is primarily on the following items:
30
31 - loading DXF files into a dime object hierarchy containing the DXF
32   data
33 - building dime object hierarchies from scratch
34 - extracting geometry data from dime object hierarchies
35 - manipulating dime object hierarchies
36 - traversing the dime object hierarchies while performing various
37   tasks
38 - saving dime object hierarchies as files conforming to the DXF file
39   format
40
41 The intended purpose of dime was on importing and exporting DXF files.
42 For this kind of usage, special memory management techniques has been
43 implemented, that can be used to boost the performance significantly.
44
45 %description -l pl
46 Dime jest bibliotek± klas C++ s³u¿±c± odczytywaniu, tworzeniu,
47 modyfikacji i zachowywaniu danych w plikach DXF. Nazwa jest skrótem od
48 pierwszych liter: s³ów DXF Import, Manipulation, and Export library.
49 Format pliku DXF pochodzi z AutoCAD-a, obecnie jest jednak bardzo
50 popularny.
51
52 Bibliotek obs³uguje g³ównie nastêpuj±ce funkcje:
53 - ³adowanie plików DXF do hierarchii obiektu dime zawieraj±cej dane
54   DXF
55 - budowanie hierarchii obiektów dime od zera
56 - ekstrakcja danych geometrycznych z hierarchii obiektów dime
57 - manipulacja hierarchi± obiektów dime
58 - przegl±d hierarchii obiektów dime podczas wykonywania ró¿nych zadañ
59 - zachowywanie obiektów hierarchii dime w postaci plików zgodnych z
60   formatem DXF Oryginalnym celem dime by³o importowanie i eksportowanie
61   plików DXF. Dlatego zaimplementowano specjalne techniki zarz±dzania
62   pamiêci±, dziêki którym mo¿na znacznie zwiêkszyæ wydajno¶æ.
63
64 %package devel
65 Summary:        DIME - development files
66 Summary(pl):    DIME - czê¶æ dla programistów
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description devel
71 Dime development files.
72
73 %description devel -l pl
74 Pliki dime przeznaczone dla programistów.
75
76 %package documentation
77 Summary:        DIME doc
78 Summary(pl):    DIME - dokumentacja
79 Group:          Documentation
80
81 %description documentation
82 Dime documentation.
83
84 %description documentation -l pl
85 Dokumentacja dime.
86
87 %prep
88 %setup -q
89 %setup -q -D -b1
90
91 %build
92 %{__make} -C build \
93         CC="%{__cxx}" \
94         OPT="%{rpmcflags}"
95
96 %{__make} -C docs/latex refman.ps
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
101         $RPM_BUILD_ROOT%{_docdir}/%{name}-documentation-%{version}/{latex,html}
102
103 cp -rp include/* $RPM_BUILD_ROOT%{_includedir}
104 install build/libdime.a $RPM_BUILD_ROOT%{_libdir}
105 cp -rp docs/latex/*.tex $RPM_BUILD_ROOT%{_docdir}/%{name}-documentation-%{version}/latex
106 cp -rp docs/latex/*.sty $RPM_BUILD_ROOT%{_docdir}/%{name}-documentation-%{version}/latex
107
108 cp -rp docs/latex/* $RPM_BUILD_ROOT%{_docdir}/%{name}-documentation-%{version}/html
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README TODO ChangeLog
116 %{_libdir}/libdime.a
117
118 %files devel
119 %defattr(644,root,root,755)
120 %doc docs/latex/refman.ps ChangeLog README TODO
121 %{_includedir}/dime
122
123 %files documentation
124 %defattr(644,root,root,755)
125 #%doc docs/html/* docs/latex/*.tex docs/latex/*.sty
126 %dir %{_docdir}/%{name}-documentation-%{version}
127 %{_docdir}/%{name}-documentation-%{version}/latex
128 %{_docdir}/%{name}-documentation-%{version}/html
This page took 0.056576 seconds and 2 git commands to generate.