]> git.pld-linux.org Git - packages/dime.git/blob - dime.spec
- changed all BuildRoot definitons
[packages/dime.git] / dime.spec
1 Summary:        DIME - DXF Import, manipulation and Export library.
2 Summary(pl):    DIME - biblioteka do manipulacji plikami w formacie DXF.
3 Name:           dime
4 Version:        0.9.1
5 Release:        1
6 Copyright:      GPL
7 Group:          Libraries
8 Group(pl):      Biblioteki
9 Source0:        ftp://ftp.sim.no/pub/dime/%name-%version-src.tar.bz2
10 Source1:        ftp://ftp.sim.no/pub/dime/%name-%version-doc.tar.bz2
11 #Patch:
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %define _prefix /usr
15
16 %description
17 Dime is a C++ class library for reading, constructing, manipulating, and
18 writing DXF file data.
19 The name is an acronym for DXF Import, Manipulation, and Export library.
20 The DXF file format originates from AutoCAD, but is now in widespread use.
21
22 The focus of the library is primarily on the following items:
23
24 - loading DXF files into a dime object hierarchy containing the DXF data
25 - building dime object hierarchies from scratch
26 - extracting geometry data from dime object hierarchies
27 - manipulating dime object hierarchies
28 - traversing the dime object hierarchies while performing various tasks
29 - saving dime object hierarchies as files conforming to the DXF file format
30
31 The intended purpose of dime was on importing and exporting DXF files.
32 For this kind of usage, special memory management techniques has been
33 implemented, that can be used to boost the performance significantly.
34
35 %description -l pl
36 Dime jest bibliotek± klas C++ s³u¿±c± odczytywaniu, tworzeniu, modyfikacji 
37 i zachowywaniu danych w plikach DXF. Nazwa jest skrótem od pierwszych liter:
38 s³ów DXF Import, Manipulation, and Export library. Format pliku DXF pochodzi
39 z AutoCAD-a, obecnie jest jednak bardzo popularny.
40
41 Bibliotek obs³uguje g³ównie nastêpuj±ce funkcje:
42 - ³adowanie plików DXF do hierarchii obiektu dime zawieraj±cej dane DXF
43 - budowanie hierarchii obiektów dime od zera
44 - ekstrakcja danych geometrycznych z hierarchii obiektów dime
45 - manipulacja hierarchi± obiektów dime
46 - przegl±d hierarchii obiektów dime podczas wykonywania ró¿nych zadañ
47 - zachowywanie obiektów hierarchii dime w postaci plików zgodnych z formatem
48 DXF
49 Oryginalnym celem dime by³o importowanie i eksportowanie plików DXF.
50 Dlatego zaimplementowano specjalne techniki zarz±dzania pamiêci±, dziêki
51 którym mo¿na znacznie zwiêkszyæ wydajno¶æ.
52
53 %package devel
54 Summary:        DIME devel
55 Summary(pl):    DIME devel
56 Group:          Development/Libraries
57 Group(pl):      Programowanie/Biblioteki
58
59 %description devel
60 %description -l pl devel
61
62 %package documentation
63 Summary:        DEME doc
64 Summary(pl):    DIME doc
65 Group:          Documentation/Libraries
66 Group(pl):      Dokumentacja/Biblioteki
67
68 %description documentation
69 %description -l pl documentation
70
71 %prep
72 %setup -q
73 %setup -q -D -b1
74
75 %build
76 cd build
77 make RPM_OPT_FLAGS="$RPM_OPT_FLAGS"
78 cd ../docs/latex
79 make refman.ps
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}}
84
85 install -d $RPM_BUILD_ROOT/%{datadir}/doc/%name-documentation-%version/{latex,html}
86
87 cp -rp include/* $RPM_BUILD_ROOT%{_includedir}
88 install -s build/libdime.a $RPM_BUILD_ROOT%{_libdir}
89 cp -rp docs/latex/*.tex $RPM_BUILD_ROOT/%{datadir}/doc/%name-documentation-%version/latex
90 cp -rp docs/latex/*.sty $RPM_BUILD_ROOT/%{datadir}/doc/%name-documentation-%version/latex
91
92 cp -rp docs/latex/*  $RPM_BUILD_ROOT/%{datadir}/doc/%name-documentation-%version/html
93
94 bzip2 -9 README TODO ChangeLog
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644, root, root, 755)
101 %doc
102 %attr(644,root,root) %{_libdir}/libdime.a
103
104 %files devel
105 %defattr(644, root, root, 755)
106 %doc docs/latex/refman.ps ChangeLog.bz2 README.bz2 TODO.bz2
107 %{_includedir}/dime/
108
109 %files documentation
110 %defattr(644,root,root,755)
111 #%doc docs/html/* docs/latex/*.tex docs/latex/*.sty
112 %attr(644,root,root) /%{datadir}/doc/%name-documentation-%version/latex
113 %attr(644,root,root) /%{datadir}/doc/%name-documentation-%version/html
This page took 0.099741 seconds and 3 git commands to generate.