]> git.pld-linux.org Git - packages/dietlibc.git/commitdiff
always pass MYARCH explicitly master
authorJan Palus <atler@pld-linux.org>
Sat, 14 Nov 2020 00:10:50 +0000 (01:10 +0100)
committerJan Palus <atler@pld-linux.org>
Sat, 14 Nov 2020 00:14:29 +0000 (01:14 +0100)
MYARCH defaults to `uname -m` which is host arch while it should
consider %{_target_cpu} instead. %{libarch} happens to be already
normalized to values expected by Makefile

dietlibc.spec

index e8045a767ca9ca64be5ee3721af2cfb757f88fac..4c41eb4af88e8636174c198d2ca92dfd19f1d18c 100644 (file)
@@ -125,18 +125,14 @@ CC="%{__cc}"
 sparc32 \
 %endif
 %{__make} -j1 all \
-%ifarch x32
-       MYARCH=x32 \
-%endif
+       MYARCH=%{libarch} \
        prefix=%{dietprefix} \
        CC="${CC#*ccache }"
 
 %if %{with dynamic}
 # 'dyn' target is not SMP safe
 %{__make} -j1 dyn \
-%ifarch x32
-       MYARCH=x32 \
-%endif
+       MYARCH=%{libarch} \
        prefix=%{dietprefix} \
        CC="${CC}"
 %endif
@@ -149,9 +145,7 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_mandir}/man1}
 sparc32 \
 %endif
 %{__make} install \
-%ifarch x32
-       MYARCH=x32 \
-%endif
+       MYARCH=%{libarch} \
        DESTDIR=$RPM_BUILD_ROOT \
        prefix=%{dietprefix}
 
This page took 0.07052 seconds and 4 git commands to generate.