]> git.pld-linux.org Git - packages/dict-jargon.git/blob - dict-jargon.spec
- /etc/dictd is used instead of modify /etc/dictd.conf in %post
[packages/dict-jargon.git] / dict-jargon.spec
1 %define         dictname jargon
2 Summary:        The On-Line Hacker Jargon File dictionary for dictd
3 Name:           dict-%{dictname}
4 Version:        4.2.0
5 Release:        2
6 License:        GPL
7 Group:          Applications/Dictionaries
8 Group(pl):      Aplikacje/S³owniki
9 URL:            http://www.dict.org/
10 Source0:        ftp://ftp.dict.org/pub/dict/%{name}-%{version}.tar.gz
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12 BuildRequires:  dictzip
13 Requires:       dictd 
14 Requires:       %{_sysconfdir}/dictd
15 BuildArch:      noarch
16
17 %description 
18 This package contains The On-Line Hacker Jargon File, version 4.2.0,
19 formatted for use by the dictionary server in the dictd package.
20
21 %prep
22 %setup -q
23
24 %build
25 %configure 
26 %{__make} db 
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT{%{_datadir}/dictd/,%{_sysconfdir}/dictd}
31 %{__make} install dictdir="$RPM_BUILD_ROOT%{_datadir}/dictd/"
32
33 dictprefix=%{_datadir}/dictd/%{dictname}
34 echo "# The On-Line Hacker Jargon File dictionary
35 database %{dictname} {
36     data  \"$dictprefix.dict.dz\"
37     index \"$dictprefix.index\" 
38 }
39 " > $RPM_BUILD_ROOT%{_sysconfdir}/dictd/%{dictname}.dictconf
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %postun
45 if [ -f /var/lock/subsys/dictd ]; then
46         /etc/rc.d/init.d/dictd restart 1>&2
47 fi
48
49 %post
50 if [ -f /var/lock/subsys/dictd ]; then
51         /etc/rc.d/init.d/dictd restart 1>&2
52 fi
53
54 %files
55 %defattr(644,root,root,755)
56 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/dictd/*.dictconf
57 %{_datadir}/dictd/%{dictname}*
This page took 0.058581 seconds and 4 git commands to generate.