]> git.pld-linux.org Git - packages/dia.git/commitdiff
- updated to 0.97.3 auto/th/dia-0.97.3-1
authorŁukasz Kieś <kiesiu@pld-linux.org>
Sun, 14 Feb 2016 14:33:10 +0000 (15:33 +0100)
committerŁukasz Kieś <kiesiu@pld-linux.org>
Sun, 14 Feb 2016 14:33:10 +0000 (15:33 +0100)
- glib patches applied upstream
- python patch is no longer needed - different logic applied upstream

dia-glib.patch [deleted file]
dia-glib2.patch [deleted file]
dia-python.patch [deleted file]
dia.spec

diff --git a/dia-glib.patch b/dia-glib.patch
deleted file mode 100644 (file)
index 17f6199..0000000
+++ /dev/null
@@ -1,85 +0,0 @@
-diff -up dia-0.97.2/app/render_gdk.c.glib dia-0.97.2/app/render_gdk.c
---- dia-0.97.2/app/render_gdk.c.glib   2013-05-02 14:23:22.294850484 +0200
-+++ dia-0.97.2/app/render_gdk.c        2013-05-02 14:26:51.176963531 +0200
-@@ -50,7 +50,21 @@ static void copy_to_window (DiaRenderer
-                 gpointer window,
-                 int x, int y, int width, int height);
--static void dia_gdk_renderer_iface_init (DiaInteractiveRendererInterface* iface)
-+typedef struct _DiaGdkInteractiveRenderer DiaGdkInteractiveRenderer;
-+struct _DiaGdkInteractiveRenderer
-+{
-+  DiaGdkRenderer parent_instance; /*!< inheritance in object oriented C */
-+};
-+typedef struct _DiaGdkInteractiveRendererClass DiaGdkInteractiveRendererClass;
-+struct _DiaGdkInteractiveRendererClass
-+{
-+  DiaGdkRendererClass parent_class; /*!< the base class */
-+};
-+#define DIA_TYPE_GDK_INTERACTIVE_RENDERER           (dia_gdk_interactive_renderer_get_type ())
-+#define DIA_GDK_INTERACTIVE_RENDERER(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), DIA_TYPE_GDK_INTERACTIVE_RENDERER, DiaGdkInteractiveRenderer))
-+
-+static void
-+dia_gdk_renderer_iface_init (DiaInteractiveRendererInterface* iface)
- {
-   iface->clip_region_clear = clip_region_clear;
-   iface->clip_region_add_rect = clip_region_add_rect;
-@@ -61,36 +75,35 @@ static void dia_gdk_renderer_iface_init
-   iface->set_size = set_size;
- }
-+G_DEFINE_TYPE_WITH_CODE (DiaGdkInteractiveRenderer, dia_gdk_interactive_renderer, DIA_TYPE_GDK_RENDERER,
-+                       G_IMPLEMENT_INTERFACE (DIA_TYPE_INTERACTIVE_RENDERER_INTERFACE, dia_gdk_renderer_iface_init));
-+
-+static void
-+dia_gdk_interactive_renderer_class_init(DiaGdkInteractiveRendererClass *klass)
-+{
-+}
-+static void
-+dia_gdk_interactive_renderer_init(DiaGdkInteractiveRenderer *object)
-+{
-+  DiaGdkInteractiveRenderer *ia_renderer = DIA_GDK_INTERACTIVE_RENDERER (object);
-+  DiaGdkRenderer *renderer = DIA_GDK_RENDERER(object);
-+  DiaRenderer *dia_renderer = DIA_RENDERER(object);
-+  
-+  dia_renderer->is_interactive = 1;
-+
-+  renderer->gc = NULL;
-+  renderer->pixmap = NULL;
-+  renderer->clip_region = NULL;
-+}
-+
- DiaRenderer *
- new_gdk_renderer(DDisplay *ddisp)
- {
-   DiaGdkRenderer *renderer;
-   GType renderer_type = 0;
--  renderer = g_object_new (DIA_TYPE_GDK_RENDERER, NULL);
-+  renderer = g_object_new (DIA_TYPE_GDK_INTERACTIVE_RENDERER, NULL);
-   renderer->transform = dia_transform_new (&ddisp->visible, &ddisp->zoom_factor);
--  if (!DIA_GET_INTERACTIVE_RENDERER_INTERFACE (renderer))
--    {
--      static const GInterfaceInfo irenderer_iface_info = 
--      {
--        (GInterfaceInitFunc) dia_gdk_renderer_iface_init,
--        NULL,           /* iface_finalize */
--        NULL            /* iface_data     */
--      };
--
--      renderer_type = DIA_TYPE_GDK_RENDERER;
--      /* register the interactive renderer interface */
--      g_type_add_interface_static (renderer_type,
--                                   DIA_TYPE_INTERACTIVE_RENDERER_INTERFACE,
--                                   &irenderer_iface_info);
--
--    }
--  renderer->parent_instance.is_interactive = 1;
--  renderer->gc = NULL;
--
--  renderer->pixmap = NULL;
--  renderer->clip_region = NULL;
--
-   return DIA_RENDERER(renderer);
- }
diff --git a/dia-glib2.patch b/dia-glib2.patch
deleted file mode 100644 (file)
index 5e20b35..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -ur dia-0.97.2.orig//objects/custom/shape_typeinfo.c dia-0.97.2/objects/custom/shape_typeinfo.c
---- dia-0.97.2.orig//objects/custom/shape_typeinfo.c   2009-11-07 14:28:34.000000000 +0000
-+++ dia-0.97.2/objects/custom/shape_typeinfo.c 2012-10-18 08:46:23.491696996 +0000
-@@ -27,8 +27,7 @@
- #include "custom_util.h"
- #include <string.h>
- #include <stdarg.h>
--#include <glib/gstrfuncs.h>
--#include <glib/gstdio.h>
-+#include <glib.h>
- #include <libxml/parser.h>
- /*
-diff -ur dia-0.97.2.orig//tests/test-boundingbox.c dia-0.97.2/tests/test-boundingbox.c
---- dia-0.97.2.orig//tests/test-boundingbox.c  2009-11-07 14:28:35.000000000 +0000
-+++ dia-0.97.2/tests/test-boundingbox.c        2012-10-18 08:46:47.645634337 +0000
-@@ -28,9 +28,6 @@
- #include <glib.h>
- #include <glib-object.h>
--#if GLIB_CHECK_VERSION(2,16,0)
--#include <glib/gtestutils.h>
--#endif
- #include "dialib.h"
- /*
-diff -ur dia-0.97.2.orig//tests/test-objects.c dia-0.97.2/tests/test-objects.c
---- dia-0.97.2.orig//tests/test-objects.c      2009-11-07 14:28:35.000000000 +0000
-+++ dia-0.97.2/tests/test-objects.c    2012-10-18 08:46:55.477634719 +0000
-@@ -28,10 +28,6 @@
- #include <glib.h>
- #include <glib-object.h>
--#if GLIB_CHECK_VERSION(2,16,0)
--#include <glib/gtestutils.h>
--#endif
--
- #include "object.h"
- #include "plug-ins.h"
- #include "dialib.h"
diff --git a/dia-python.patch b/dia-python.patch
deleted file mode 100644 (file)
index 158ee0f..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
---- dia-0.97.2/acinclude.m4~   2011-03-20 12:18:13.000000000 +0100
-+++ dia-0.97.2/acinclude.m4    2011-12-31 13:03:18.989732048 +0100
-@@ -224,30 +224,13 @@
- [AC_REQUIRE([AM_PATH_PYTHON])
- AC_REQUIRE([AM_CHECK_PYTHON_HEADERS])
--AC_MSG_CHECKING(for libpython${PYTHON_VERSION}.a)
-+AC_MSG_CHECKING(for libpython${PYTHON_VERSION})
- py_config_dir="$py_prefix/$py_lib/python${PYTHON_VERSION}/config"
- py_makefile="${py_config_dir}/Makefile"
--if test -f "$py_makefile"; then
--dnl extra required libs
--  py_basemodlibs=`sed -n -e 's/^BASEMODLIBS=\(.*\)/\1/p' $py_makefile`
--  py_other_libs=`sed -n -e 's/^LIBS=\(.*\)/\1/p' $py_makefile`
--
--dnl now the actual libpython
--  if test -e "$PYTHON_PREFIX/${py_lib}/libpython${PYTHON_VERSION}.so"; then
--    PYTHON_LIBS="-L${py_config_dir} -lpython${PYTHON_VERSION} $py_basemodlibs $py_other_libs"
--    AC_MSG_RESULT(found)
--  elif test -e "${py_prefix}/${py_lib}/libpython${PYTHON_VERSION}.a"; then
--    dnl Same as above, but looking into the previous location: bug #581533
--    PYTHON_LIBS="-L${py_config_dir} -lpython${PYTHON_VERSION} $py_basemodlibs $py_other_libs"
--    AC_MSG_RESULT(found)
--  else
--    AC_MSG_RESULT(not found lib)
--  fi
--else
--  AC_MSG_RESULT(not found config)
--fi
-+PYTHON_LIBS="-lpython${PYTHON_VERSION} $py_basemodlibs $py_other_libs"
-+AC_MSG_RESULT(found)
- AC_SUBST(PYTHON_LIBS)])
- # We need this because freetype is optional
index 71e92a3c7594b387dd24dcbeeb15a4ae85e99d3c..42b2030b8361239ea4d564ea0181f2544661b03c 100644 (file)
--- a/dia.spec
+++ b/dia.spec
@@ -7,13 +7,13 @@ Summary(ru.UTF-8):    Программа для рисования диаграмм
 Summary(uk.UTF-8):     Програма для малювання діаграм
 Summary(zh_CN.UTF-8):  基于GTK+的流程图程序
 Name:          dia
-Version:       0.97.2
-Release:       8
+Version:       0.97.3
+Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         X11/Applications/Graphics
 Source0:       http://ftp.gnome.org/pub/gnome/sources/dia/0.97/%{name}-%{version}.tar.xz
-# Source0-md5: 1e1180a513fb567709b09bc19f12105e
+# Source0-md5: 0e744a0f6a6c4cb6a089e4d955392c3c
 Source1:       http://dia-installer.de/shapes/central_data_processing/central_data_processing.zip
 # Source1-md5: 103865b35609d2a0f8a0e034c49cf130
 Source2:       http://dia-installer.de/shapes/chemistry_lab/chemistry_lab.zip
@@ -36,10 +36,7 @@ Source10:    http://dia-installer.de/shapes/renewable_energy/renewable_energy.zip
 # Source10-md5:        13e7e934ab87b924101faaf56414ad00
 Source11:      http://dia-installer.de/shapes/scenegraph/scenegraph.zip
 # Source11-md5:        2bca8efa9bae10c13968ebacc9f1a00b
-Patch0:                %{name}-python.patch
-Patch1:                %{name}-wmf-cast.patch
-Patch2:                %{name}-glib2.patch
-Patch3:                %{name}-glib.patch
+Patch0:                %{name}-wmf-cast.patch
 URL:           https://live.gnome.org/Dia
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -131,9 +128,6 @@ PostScript(TM).
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 %{__sed} -i -e s#sr@Latn#sr@latin# po/LINGUAS
 mv -f po/sr@{Latn,latin}.po
@@ -147,6 +141,7 @@ mv -f po/sr@{Latn,latin}.po
 %{__automake}
 %{__sed} -i -e 's|/lib/|/%{_lib}/|' configure
 %configure \
+       --disable-silent-rules \
        --enable-gnome \
        --with-python \
        --with-xslt-prefix=%{_libdir}
This page took 0.097666 seconds and 4 git commands to generate.