]> git.pld-linux.org Git - packages/di.git/commitdiff
- set proper CFLAGS, add our LDFLAGS auto/th/di-4_12-1
authorlisu <lisu@pld-linux.org>
Mon, 21 Jan 2008 06:45:34 +0000 (06:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    di-Makefile.patch -> 1.1

di-Makefile.patch [new file with mode: 0644]

diff --git a/di-Makefile.patch b/di-Makefile.patch
new file mode 100644 (file)
index 0000000..ae801b3
--- /dev/null
@@ -0,0 +1,46 @@
+--- di-4.12/Makefile~  2008-01-21 08:32:54.000000000 +0100
++++ di-4.12/Makefile   2008-01-21 08:32:44.000000000 +0100
+@@ -70,7 +70,7 @@
+ # have to get various environment variables set up.
+ all:
+-      ./Build
++      ./Build -mkc
+ di-all:       config.h $(PROG)$(EXE_EXT) hasnls$(EXE_EXT)
+@@ -93,15 +93,14 @@
+               CC=cl LD=cl EXE_EXT=".exe" OBJ_EXT=".obj" \
+               CFLAGS="$(CFLAGS) -nologo -O2 \
+               -DDEFAULT_FORMAT=\\\"sMbuvpT\\\"" \
+-              LDFLAGS="-nologo -O2" $(PROG).exe
++              LDFLAGS="-nologo" $(PROG).exe
+ # This was tested using cygwin
+ windows-gcc:  wconfig.h
+       $(MAKE) -f Makefile \
+               CC=gcc LD=gcc EXE_EXT=".exe" OBJ_EXT=".o" \
+               CFLAGS="$(CFLAGS) -g -O2 \
+-              -DDEFAULT_FORMAT=\\\"sMbuvpT\\\"" \
+-              LDFLAGS="-g -O2" $(PROG).exe
++              -DDEFAULT_FORMAT=\\\"sMbuvpT\\\""
+ ####################
+@@ -202,14 +201,14 @@
+               getopt$(OBJ_EXT)
+       @test ! -f reqlibs.txt || echo "*** Using libs: `cat reqlibs.txt`"
+       $(CC) -o $(PROG)$(EXE_EXT) \
+-              $(CFLAGS) $(LDFLAGS) \
++              $(CFLAGS) $(OPTFLAGS) $(LDFLAGS) \
+               di$(OBJ_EXT) dilib$(OBJ_EXT) \
+               getopt$(OBJ_EXT) $(LIBS) \
+               `test ! -f reqlibs.txt || cat reqlibs.txt`
+ hasnls$(EXE_EXT):     hasnls$(OBJ_EXT)
+       $(CC) -o hasnls$(EXE_EXT) \
+-              $(CFLAGS) $(LDFLAGS) \
++              $(CFLAGS) $(OPTFLAGS) $(LDFLAGS) \
+               hasnls$(OBJ_EXT)
+ ###
This page took 0.079437 seconds and 4 git commands to generate.