]> git.pld-linux.org Git - packages/devsec.git/blob - devsec.spec
- tabs in preamble
[packages/devsec.git] / devsec.spec
1 # TODO:
2 # - use system libs: ffmpeg!!, mpeg4ip
3 # - requires webserver?
4 # - move cgi files to webappdir, move html files to own directory
5 # - add webapps configuration
6 # - move camera configs to /etc
7 #
8 Summary:        Devolution Security - video surveillance system for the Linux/X11 platform
9 Summary(pl.UTF-8):      Devolution Security - system do nadzoru obrazu dla platformy Linux/X11
10 Name:           devsec
11 Version:        3.0.6
12 Release:        0.2
13 License:        GPL v2
14 Group:          Applications/Multimedia
15 Source0:        http://dl.sourceforge.net/devsec/%{name}-%{version}.tar.gz
16 # Source0-md5:  539db08716f0237c8a8c06c25b368b4b
17 Patch0:         %{name}-no_extern.patch
18 URL:            http://devsec.sourceforge.net/
19 BuildRequires:  SDL-devel >= 1.2.7
20 BuildRequires:  faac-devel >= 1.18
21 # Should be required:
22 #BuildRequires: ffmpeg-devel
23 BuildRequires:  imlib-devel >= 1.9.14
24 BuildRequires:  lame-libs-devel >= 3.95
25 BuildRequires:  libcgi-devel
26 BuildRequires:  libogg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtemplate-devel
29 BuildRequires:  libvorbis-devel
30 # Required for manuals from ffmpeg (to be removed):
31 BuildRequires:  perl-tools-pod
32 BuildRequires:  rpmbuild(macros) >= 1.268
33 Requires:       %{name}-libs = %{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _webapps        /etc/webapps
37 %define         _webapp         %{name}
38 %define         _webappdir      %{_prefix}/lib/%{_webapp}
39
40 %description
41 Devolution Security is a video surveillance system for the Linux/X11
42 platform. Features:
43  - Up to 16 cameras
44  - Motion detection
45  - Record on motion detection
46  - Record up to 25 fps MPEG4 video
47  - Multicast live streams to local network
48  - Unicast to internet IP address
49  - Very configurable
50  - Themeable X11 interface
51  - Configurable helper buttons
52  - Web based interface
53
54 %description -l pl.UTF-8
55 Devolution Security to system do nadzoru obrazu dla platformy
56 Linux/X11. Możliwości:
57  - do 16 kamer
58  - wykrywanie ruchu
59  - nagrywanie przy wykryciu ruchu
60  - nagrywanie obrazu MPEG4 do 25 klatek/sekundę
61  - udostępnianie strumieni na żywo w sieci lokalnej
62  - kierowanie strumienia na internetowy adres IP
63  - duża konfigurowalność
64  - interfejs X11 z obsługą motywów
65  - konfigurowalne przyciski pomocnicze
66  - interfejs WWW
67
68 %package cgi
69 Summary:        Web based interface for Devolution Security
70 Summary(pl.UTF-8):      Interfejs WWW do Devolution Security
71 Group:          Applications/WWW
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       webapps
74
75 %description cgi
76 Web based interface for Devolution Security.
77
78 %description cgi -l pl.UTF-8
79 Interfejs WWW do Devolution Security.
80
81 %package libs
82 Summary:        Devolution Security libraries
83 Summary(pl.UTF-8):      Biblioteki Devolution Security
84 Group:          Libraries
85
86 %description libs
87 Devolution Security libraries.
88
89 %description libs -l pl.UTF-8
90 Biblioteki Devolution Security.
91
92 %package devel
93 Summary:        Header files for Devolution Security libraries
94 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Devolution Security
95 Group:          Development/Libraries
96 Requires:       %{name}-libs = %{version}-%{release}
97
98 %description devel
99 Header files for Devolution Security libraries.
100
101 %description devel -l pl.UTF-8
102 Pliki nagłówkowe bibliotek Devolution Security.
103
104 %package static
105 Summary:        Static Devolution Security libraries
106 Summary(pl.UTF-8):      Statyczne biblioteki Devolution Security
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109
110 %description static
111 Static Devolution Security libraries.
112
113 %description static -l pl.UTF-8
114 Statyczne biblioteki Devolution Security.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119
120 %build
121 %configure
122 %{__make} \
123         CC="%{__cc}"
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT{%{_webapps}/%{_webapp},%{_webappdir}}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   libs -p /sbin/ldconfig
136 %postun libs -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS CONSUMER_KEYS ChangeLog README
141 #%%dir %{_sysconfdir}
142 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
143 #%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
144 %attr(755,root,root) %{_bindir}/*
145 %dir %{_libdir}/dtk
146 %dir %{_libdir}/dtk/config
147 %dir %{_libdir}/dtk/config/%{name}
148 %config(noreplace) %verify(not md5 mtime size) %{_libdir}/dtk/config/%{name}/*.conf
149 %dir %{_libdir}/dtk/config/%{name}/messages
150 %{_libdir}/dtk/config/%{name}/messages/*.ulaw
151 %dir %{_libdir}/dtk/config/%{name}/mp4live
152 %config(noreplace) %verify(not md5 mtime size) %{_libdir}/dtk/config/%{name}/mp4live/*.conf
153 %dir %{_libdir}/dtk/skins
154 %attr(755,root,root) %{_libdir}/dtk/skins/*.so
155 %{_libdir}/dtk/skins/*.la
156 %dir %{_pixmapsdir}/%{name}
157 %{_pixmapsdir}/%{name}/*.png
158 %{_pixmapsdir}/%{name}/*.yuv
159
160 %files cgi
161 %defattr(644,root,root,755)
162 %attr(755,root,root) /home/httpd/cgi-bin/index.cgi
163 /home/httpd/cgi-bin/templates
164 /home/httpd/html/*.css
165 /home/httpd/html/*.html
166 %dir /home/httpd/html/images
167 /home/httpd/html/images/*.jpg
168 /home/httpd/html/images/*.png
169
170 %files libs
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/lib*.so.*.*
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/lib*.so
177 %{_libdir}/*.la
178 %{_includedir}/*.h
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/lib*.a
This page took 0.075896 seconds and 3 git commands to generate.