]> git.pld-linux.org Git - packages/device-mapper.git/commitdiff
- adds '--disable-dynamic-link' option to device-mapper's configure script
authorJacek Konieczny <jajcus@pld-linux.org>
Sun, 31 Jul 2005 17:51:28 +0000 (17:51 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    device-mapper-disable_dynamic_link.patch -> 1.1

device-mapper-disable_dynamic_link.patch [new file with mode: 0644]

diff --git a/device-mapper-disable_dynamic_link.patch b/device-mapper-disable_dynamic_link.patch
new file mode 100644 (file)
index 0000000..76579fe
--- /dev/null
@@ -0,0 +1,47 @@
+diff -durN -x '*~' device-mapper.1.01.03.orig/configure.in device-mapper.1.01.03/configure.in
+--- device-mapper.1.01.03.orig/configure.in    2005-06-13 16:07:29.000000000 +0200
++++ device-mapper.1.01.03/configure.in 2005-07-31 19:10:30.000000000 +0200
+@@ -178,6 +178,8 @@
+ dnl -- Enables staticly-linked tools
+ AC_ARG_ENABLE(static_link, [  --enable-static_link    Use this to link the tools to their libraries
+                           statically.  Default is dynamic linking],  STATIC_LINK=$enableval, STATIC_LINK=no)
++AC_ARG_ENABLE(dynamic_link, [  --disable-dynamic_link    Use this not to link the tools to their libraries
++                          statically.  Default is dynamic linking],  DYNAMIC_LINK=$enableval, DYNAMIC_LINK=yes)
+ ################################################################################
+ dnl -- Clear default exec_prefix - install into /sbin rather than /usr/sbin
+@@ -324,6 +326,7 @@
+ ################################################################################
+ AC_SUBST(JOBS)
+ AC_SUBST(STATIC_LINK)
++AC_SUBST(DYNAMIC_LINK)
+ AC_SUBST(OWNER)
+ AC_SUBST(GROUP)
+ AC_SUBST(LIBS)
+diff -durN -x '*~' device-mapper.1.01.03.orig/dmsetup/Makefile.in device-mapper.1.01.03/dmsetup/Makefile.in
+--- device-mapper.1.01.03.orig/dmsetup/Makefile.in     2005-01-27 17:16:52.000000000 +0100
++++ device-mapper.1.01.03/dmsetup/Makefile.in  2005-07-31 19:10:13.000000000 +0200
+@@ -16,8 +16,10 @@
+ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
++ifeq ("@DYNAMIC_LINK@", "yes")
+ TARGETS = dmsetup
+ INSTALL_TYPE = install_dynamic
++endif
+ ifeq ("@STATIC_LINK@", "yes")
+   TARGETS += dmsetup.static
+diff -durN -x '*~' device-mapper.1.01.03.orig/lib/Makefile.in device-mapper.1.01.03/lib/Makefile.in
+--- device-mapper.1.01.03.orig/lib/Makefile.in 2005-04-28 00:32:00.000000000 +0200
++++ device-mapper.1.01.03/lib/Makefile.in      2005-07-31 19:10:13.000000000 +0200
+@@ -45,7 +45,9 @@
+ .PHONY: install_dynamic install_static \
+       install_fs install_ioctl install_ioctl_static
++ifeq ("@DYNAMIC_LINK@", "yes")
+ INSTALL_TYPE = install_dynamic
++endif
+ ifeq ("@STATIC_LINK@", "yes")
+   INSTALL_TYPE += install_static
This page took 0.062375 seconds and 4 git commands to generate.