]> git.pld-linux.org Git - packages/devhelp.git/blob - devhelp.spec
- post gtk-doc cleanup
[packages/devhelp.git] / devhelp.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # static library
5
6 Summary:        API documentation browser for GNOME
7 Summary(pl.UTF-8):      Przeglądarka dokumentacji API dla GNOME
8 Name:           devhelp
9 Version:        3.26.1
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/devhelp/3.26/%{name}-%{version}.tar.xz
14 # Source0-md5:  825da3043a238733f96b7929a5400fa8
15 Patch0:         %{name}-bookdir.patch
16 Patch1:         %{name}-use-python3.patch
17 URL:            https://wiki.gnome.org/Apps/Devhelp
18 BuildRequires:  autoconf >= 2.64
19 BuildRequires:  automake >= 1:1.14
20 BuildRequires:  gettext-tools >= 0.19.7
21 BuildRequires:  glib2-devel >= 1:2.38.0
22 BuildRequires:  gnome-common >= 2.24.0
23 BuildRequires:  gobject-introspection-devel >= 1.30.0
24 BuildRequires:  gtk+3-devel >= 3.22.0
25 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.25}
26 BuildRequires:  gtk-webkit4-devel >= 2.6.0
27 BuildRequires:  libtool >= 2:2.2
28 BuildRequires:  pkgconfig
29 BuildRequires:  python3 >= 1:3.3
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.311
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRequires:  zlib-devel
35 Requires(post,postun):  glib2 >= 1:2.38.0
36 Requires(post,postun):  gtk-update-icon-cache
37 Requires:       %{name}-libs = %{version}-%{release}
38 Requires:       hicolor-icon-theme
39 # sr@Latn vs. sr@latin
40 Conflicts:      glibc-misc < 6:2.7
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 API documentation browser for GNOME.
45
46 %description -l pl.UTF-8
47 Przeglądarka dokumentacji API dla GNOME.
48
49 %package libs
50 Summary:        Library to embed Devhelp in other applications
51 Summary(pl.UTF-8):      Biblioteka do osadzania Devhelp w innych aplikacjach
52 Group:          X11/Libraries
53 Requires:       glib2 >= 1:2.38.0
54 Requires:       gtk+3 >= 3.20.0
55 Requires:       gtk-webkit4 >= 2.6.0
56
57 %description libs
58 Library of Devhelp for embedding into other applications.
59
60 %description libs -l pl.UTF-8
61 Biblioteka Devhelp do osadzania w innych aplikacjach.
62
63 %package devel
64 Summary:        Headers for Devhelp library
65 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Devhelp
66 Group:          X11/Development/Libraries
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       glib2-devel >= 1:2.38.0
69 Requires:       gtk+3-devel >= 3.22.0
70 Requires:       gtk-webkit4-devel >= 2.6.0
71
72 %description devel
73 Headers for Devhelp library.
74
75 %description devel -l pl.UTF-8
76 Pliki nagłówkowe biblioteki Devhelp.
77
78 %package static
79 Summary:        Static Devhelp library
80 Summary(pl.UTF-8):      Statyczna biblioteka Devhelp
81 Group:          X11/Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83
84 %description static
85 Static version of Devhelp library.
86
87 %description static -l pl.UTF-8
88 Statyczna biblioteka Devhelp.
89
90 %package apidocs
91 Summary:        Devhelp API documetation
92 Summary(pl.UTF-8):      Dokumentacja API Devhelp
93 Group:          Documentation
94 Requires:       gtk-doc-common
95 %if "%{_rpmversion}" >= "5"
96 BuildArch:      noarch
97 %endif
98
99 %description apidocs
100 Devhelp API documetation.
101
102 %description apidocs -l pl.UTF-8
103 Dokumentacja API Devhelp.
104
105 %package -n gedit-plugin-devhelp
106 Summary:        Devhelp plugin for Gedit editor
107 Summary(pl.UTF-8):      Wtyczka devhelpa dla edytora Gedit
108 Group:          X11/Applications
109 Requires:       %{name} = %{version}-%{release}
110 # python3 based gedit
111 Requires:       gedit >= 3.8
112 Requires:       libpeas-loader-python3
113 Requires:       python3 >= 1:3.3
114 Requires:       python3-pygobject3 >= 3
115 Obsoletes:      gedit2-plugin-devhelp
116
117 %description -n gedit-plugin-devhelp
118 Plugin that allows to browse API documentation in Gedit.
119
120 %description -n gedit-plugin-devhelp -l pl.UTF-8
121 Wtyczka umożliwiająca przeglądanie dokumentacji API w edytorze Gedit.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127
128 %build
129 %{__libtoolize}
130 %{__aclocal} -I m4
131 %{__autoconf}
132 %{__autoheader}
133 %{__automake}
134 %configure \
135         %{__enable_disable apidocs gtk-doc} \
136         %{__enable_disable static_libs static} \
137         %{?with_apidocs:--with-html-dir=%{_gtkdocdir}} \
138         --disable-silent-rules
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/{books,references,specs}
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
149
150 %find_lang %{name}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post
156 %glib_compile_schemas
157 %update_icon_cache hicolor
158
159 %postun
160 %glib_compile_schemas
161 %update_icon_cache hicolor
162
163 %post   libs -p /sbin/ldconfig
164 %postun libs -p /sbin/ldconfig
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc AUTHORS NEWS README
169 %attr(755,root,root) %{_bindir}/devhelp
170 %{_datadir}/%{name}
171 %{_desktopdir}/org.gnome.Devhelp.desktop
172 %{_iconsdir}/hicolor/*x*/apps/devhelp.png
173 %{_iconsdir}/hicolor/symbolic/apps/devhelp-symbolic.svg
174 %{_datadir}/GConf/gsettings/devhelp.convert
175 %{_datadir}/glib-2.0/schemas/org.gnome.devhelp.gschema.xml
176 %{_datadir}/metainfo/org.gnome.Devhelp.appdata.xml
177 %{_datadir}/dbus-1/services/org.gnome.Devhelp.service
178 %{_mandir}/man1/devhelp.1*
179
180 %files libs
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libdevhelp-3.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libdevhelp-3.so.4
184 %{_libdir}/girepository-1.0/Devhelp-3.0.typelib
185
186 %files devel
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libdevhelp-3.so
189 %{_datadir}/gir-1.0/Devhelp-3.0.gir
190 %{_pkgconfigdir}/libdevhelp-3.0.pc
191 %{_includedir}/devhelp-3.0
192
193 %files static
194 %defattr(644,root,root,755)
195 %{_libdir}/libdevhelp-3.a
196
197 %if %{with apidocs}
198 %files apidocs
199 %defattr(644,root,root,755)
200 %{_gtkdocdir}/devhelp-3
201 %endif
202
203 %files -n gedit-plugin-devhelp
204 %defattr(644,root,root,755)
205 %{_libdir}/gedit/plugins/__pycache__
206 %{_libdir}/gedit/plugins/devhelp.plugin
207 %{_libdir}/gedit/plugins/devhelp.py
This page took 0.099171 seconds and 3 git commands to generate.