]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
raz jeszcze, bo zjadlem komentarz przy %clean :)
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(fr):    Entrées de /dev.
3 Summary(de):    /dev-Einträge
4 Summary(pl):    Pliki specjalne /dev/*
5 Summary(tr):    /dev dizini
6 Name:           dev
7 Version:        2.7.3
8 Release:        1
9 #######         From ftp.redhat.com/rawhide
10 Source:         %{name}-%{version}.tar.gz
11 Copyright:      public domain
12 Group:          Base
13 Buildroot:      /tmp/%{name}-%{version}-root
14 Autoreqprov:    no
15 Prereq:         shadow-utils
16
17 %description
18 Unix and unix like systems (including Linux) use file system entries
19 to represent devices attached to the machine. All of these entries
20 are in the /dev tree (though they don't have to be), and this package
21 contains the most commonly used /dev entries. These files are essential
22 for a system to function properly.
23
24 %description -l pl
25 Wszystkie systemy Unix, jak na przyk³ad Linux, u¿ywaj± plików do przedstawienia 
26 urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki znajduj± siê zwykle w 
27 katalogu /dev. Pakiet ten zawiera wiêkszo¶æ popularnych plików specjalnych, 
28 s± one jedn± z wa¿niejszych czê¶ci prawid³owo dzia³aj±cego systemu operacyjnego.
29
30 %description -l fr
31 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
32 représenter les périphériques reliés à la machine. Toutes ces entrées
33 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
34 contient les entrées /dev les plus courantes. Elles sont essentielles
35 pour qu'un système fonctionne correctement.
36
37 %description -l tr
38 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya baðlý
39 aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel dosyalarýn tümü
40 /dev dizin yapýsý altýndadýr. Bu paket en çok kullanýlan /dev dosyalarýný
41 içerir. Bu dosyalar, bir sistemin düzgün olarak iþleyebilmesi için temel
42 gereksinimlerdendir.
43
44 %description -l de
45 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
46 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge befinden
47 sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses Paket enthält
48 die üblichsten /dev-Einträge. Diese Dateien sind für das Funktionieren
49 eines Systems unbedingt erforderlich.
50
51 %prep
52 %setup -q -c -T
53 rm -rf $RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT
56 BUILD_DIR=`pwd`
57
58 #add group for floppy and console
59 /usr/sbin/groupadd -g 19 -r -f floppy >/dev/null
60 /usr/sbin/groupadd -g 20 -f -r console >/dev/null
61
62 # do some cleanup in build root
63 cd $RPM_BUILD_ROOT
64 tar xpSzf $RPM_SOURCE_DIR/%{name}-%{version}.tar.gz
65
66 # tar doesn't save some permissions unless the p option is used
67 # this code protects against dev package updaters forgetting to
68 # use the p option when unpacking the souce tarball.
69 for dev in dev/zero dev/null dev/tty dev/ttyp0 ; do
70   if [ ! $(ls -l $dev | awk '{print $1}') = crw-rw-rw- ] ; then
71     echo bad permissions on device $dev 1>&2
72     exit 1
73   fi
74 done
75
76 %ifarch sparc
77 # SPARC specific devices
78 ln -s sunmouse dev/mouse
79 mknod dev/fb0 c 29 0
80 mknod dev/fb1 c 29 32
81 mknod dev/kbd c 11 0
82 mknod dev/openprom c 10 139
83 ln -s fb0 dev/fb
84 chmod 666 dev/fb*
85
86 # remove devices that will *never* exist on a SPARC
87 rm -f dev/hd* dev/aztcd dev/mcd dev/sbpcd1 dev/cdu31a dev/sbpcd2 dev/scd3
88 rm -f dev/sjcd dev/cdu535 dev/sbpcd3 dev/sonycd dev/cm206cd dev/sbpcd
89 rm -f dev/gscd dev/sbpcd0 dev/atibm dev/inportbm dev/logibm dev/psaux
90
91 %endif
92
93 %ifarch m68k                                                                    
94 # m68k specific devices                                                         
95 mknod amigamouse c 10 4                                                         
96 mknod atarimouse c 10 5                                                         
97 mknod apollomouse c 10 7                                                        
98 ln -s amigamouse mouse                                                          
99 mknod fdhd0 b 2 4                                                               
100 mknod fdhd1 b 2 5                                                               
101 mknod fb0 c 29 0                                                                
102 mknod fb1 c 29 32                                                               
103 mknod fb0current c 29 0                                                         
104 mknod fb1current c 29 32                                                        
105 mknod kbd c 11 0                                                                
106 ln -s fb0 fb                                                                    
107 chmod 666 fb*                                                                   
108                                                                                 
109 # remove devices that will *never* exist on a m68k                              
110 rm -f hd* aztcd mcd sbpcd1 cdu31a sbpcd2 scd3                                   
111 rm -f sjcd cdu535 sbpcd3 sonycd cm206cd sbpcd                                   
112 rm -f gscd sbpcd0 atibm inportbm logibm psaux                                   
113                                                                                 
114 %endif
115
116 chmod 660 dev/lp*
117 chgrp daemon dev/lp*
118
119 cd dev
120
121 chgrp floppy fd?*
122
123 # framebuffer support
124 mknod fb0 b 29 0
125 mknod fb1 b 29 32
126 mknod fb2 b 29 64
127 mknod fb3 b 29 96
128 mknod fb4 b 29 128
129 mknod fb5 b 29 160
130 mknod fb6 b 29 192
131 mknod fb7 b 29 224
132
133 ln -s fb0 fb0current
134 ln -s fb1 fb1current
135 ln -s fb2 fb2current
136 ln -s fb3 fb3current
137 ln -s fb4 fb4current
138 ln -s fb5 fb5current
139 ln -s fb6 fb6current
140 ln -s fb7 fb7current
141
142 # watchdog support
143 mknod watchdog c 10 130 
144
145 # route 
146 mknod route c 36 0
147
148 %pre
149 /usr/sbin/groupadd -g 19 -r -f floppy
150 /usr/sbin/groupadd -g 20 -r -f console
151
152 %post
153 if [ -f /etc/fstab ] ; then
154   # add /dev/pts to fstab if fstab exists (install2 does it during install)
155   if grep 'devpts' /etc/fstab >/dev/null 2>&1 ; then : ; else
156     # note that we do not disallow comments; we wish to allow people
157     # to comment it out if they so desire.
158     TMP=$(mktemp /tmp/fstab.XXXXXX)
159     sed '/\/proc/a\
160 none                    /dev/pts                devpts  mode=0622       0 0
161         ' < /etc/fstab > $TMP && mv -f $TMP /etc/fstab || { echo "failed to add devpts filesystem to /etc/fstab" 1>&2 ; exit 1 ; }
162     rm -f $TMP
163   fi
164 fi
165
166 %postun
167
168 %clean 
169 rm -rf $RPM_BUILD_ROOT
170
171 %files 
172 %defattr(644,root,root,755)
173
174 %dir /dev/pts
175
176 #a#
177 %attr(664,root,root) /dev/atibm
178 %attr(662,root, sys) /dev/audio
179 %attr(662,root, sys) /dev/audio1
180 %attr(664,root,root) /dev/aztcd
181
182 #b#
183 %attr(664,root,root) /dev/bpcd
184
185 #c#
186 %attr(664,root,root) /dev/cdu31a
187 %attr(640,root,disk) /dev/cdu535
188 %attr(664,root,root) /dev/cm206cd
189 %attr(600,root,root) /dev/console
190 %attr(666,root,root) /dev/cui*
191 %attr(600,root,root) /dev/cum*
192
193 #d#
194 %attr(662,root,sys) /dev/dsp
195 %attr(662,root,sys) /dev/dsp1
196
197 #e#
198
199 #f#
200 %attr(644,root,  root) /dev/fb*
201 %attr(664,root,floppy) /dev/fd*
202 %attr(-,root,root) /dev/ftape
203 %attr(-,root,root) /dev/full
204
205 #g#
206 %attr(664,root,root) /dev/gscd
207
208 #h#
209 %attr(660,root,disk) /dev/hd*
210 %attr(660,root,disk) /dev/ht0
211
212 #i#
213 %attr(664,root,root) /dev/ida/*
214 %attr(664,root,root) /dev/inportbm
215 %attr(600,root,root) /dev/ippp*
216 %attr(600,root,root) /dev/isctl
217 %attr(600,root,root) /dev/isdnctrl*
218 %attr(444,root,root) /dev/isdninfo
219
220 #j#
221
222 #k#
223 %attr(640,root,kmem) /dev/kmem
224
225 #l#
226 #%attr(666,root,root) /dev/log
227 %attr(664,root,root) /dev/logibm
228 %attr(660,root,disk) /dev/loop*
229
230 %attr(660,root,daemon) /dev/lp*
231
232 #m#
233 %attr(640,root,disk) /dev/mcd
234 %attr(640,root,kmem) /dev/mem
235 %attr(666,root, sys) /dev/midi*
236 %attr(666,root, sys) /dev/mixer
237 %attr(666,root, sys) /dev/mixer1
238
239 #n#
240 %attr(660,root,root) /dev/nb*
241 %attr(660,root,disk) /dev/nht0
242 %attr(660,root,disk) /dev/nrft*
243 %attr(660,root,disk) /dev/nst*
244 %attr(666,root,root) /dev/null
245
246 %attr(-,root,root) /dev/nftape
247
248 #o#
249 %attr(664,root,root) /dev/optcd
250
251 #p#
252 %attr(640,root,daemon) /dev/par*
253
254 %attr(660,root,disk) /dev/pcd*
255 %attr(660,root,disk) /dev/pd*
256 %attr(660,root,disk) /dev/pf*
257
258 %attr(640,root,kmem) /dev/port
259 %attr(600,root,root) /dev/printer
260 %attr(664,root,root) /dev/psaux
261
262 %attr(660,root,disk) /dev/pt0
263 %attr(660,root,disk) /dev/pt1
264 %attr(660,root,disk) /dev/pt2
265 %attr(660,root,disk) /dev/pt3
266
267 %attr(666,root,tty) /dev/ptmx
268 %attr(666,root,tty) /dev/pty*
269
270 #r#
271 %attr(640,root,disk) /dev/ram
272 %attr(660,root,disk) /dev/ram0
273 %attr(660,root,disk) /dev/ram1*
274 %attr(660,root,disk) /dev/ram2
275 %attr(660,root,disk) /dev/ram3
276 %attr(660,root,disk) /dev/ram4
277 %attr(660,root,disk) /dev/ram5
278 %attr(660,root,disk) /dev/ram6
279 %attr(660,root,disk) /dev/ram7
280 %attr(660,root,disk) /dev/ram8
281 %attr(660,root,disk) /dev/ram9
282
283 %attr(-,root,root) /dev/ramdisk
284
285 %attr(644,root,root) /dev/random
286 %attr(660,root,disk) /dev/rft*
287 %attr(644,root,root) /dev/route
288 %attr(664,root,root) /dev/rtc
289 %attr(600,root,root) /dev/rd/*
290
291 #s#
292 %attr(640,root,disk) /dev/sbpc*
293
294 %attr(660,root,disk) /dev/scd*
295
296 %attr(660,root,disk) /dev/sda*
297 %attr(660,root,disk) /dev/sdb*
298 %attr(660,root,disk) /dev/sdc*
299 %attr(660,root,disk) /dev/sdd*
300 %attr(660,root,disk) /dev/sde*
301 %attr(660,root,disk) /dev/sdf*
302 %attr(660,root,disk) /dev/sdg*
303
304 %attr(664,root,sys) /dev/sequencer
305
306 %attr(600,root,sys) /dev/sg*
307
308 %attr(664,root,root) /dev/sjcd
309 %attr(666,root, sys) /dev/sndstat
310
311 %attr(640,root,disk) /dev/sonycd
312
313 %attr(660,root,disk) /dev/st*
314
315 %attr(664,root,root) /dev/sunmouse
316 %attr(600,root,root) /dev/systty
317
318 #t#
319 %attr(666,root,root) /dev/tty
320
321 %attr(600,root, tty) /dev/tty0
322 %attr(600,root, tty) /dev/tty1*
323 %attr(600,root, tty) /dev/tty2
324 %attr(600,root, tty) /dev/tty3
325 %attr(600,root, tty) /dev/tty4
326 %attr(600,root, tty) /dev/tty5
327 %attr(600,root, tty) /dev/tty6
328 %attr(600,root, tty) /dev/tty7
329 %attr(600,root, tty) /dev/tty8
330 %attr(600,root, tty) /dev/tty9
331
332 %attr(666,root,root) /dev/ttyI*
333
334 %attr(600,root,root) /dev/ttyM*
335
336 %attr(644,root,root) /dev/ttyS*
337
338 %attr(666,root, tty) /dev/ttya*
339 %attr(666,root, tty) /dev/ttyb*
340 %attr(666,root, tty) /dev/ttyc*
341 %attr(666,root, tty) /dev/ttyd*
342 %attr(666,root, tty) /dev/ttye*
343 %attr(666,root, tty) /dev/ttyp*
344 %attr(666,root, tty) /dev/ttyq*
345 %attr(666,root, tty) /dev/ttyr*
346 %attr(666,root, tty) /dev/ttys*
347 %attr(666,root, tty) /dev/ttyt*
348 %attr(666,root, tty) /dev/ttyu*
349 %attr(666,root, tty) /dev/ttyv*
350 %attr(666,root, tty) /dev/ttyw*
351 %attr(666,root, tty) /dev/ttyx*
352 %attr(666,root, tty) /dev/ttyy*
353 %attr(666,root, tty) /dev/ttyz*
354
355 #u#
356 %attr(644,root,root) /dev/urandom
357
358 #v#
359 %attr(620,root,tty) /dev/vcs*
360
361 #w#
362 %attr(600,root,root) /dev/watchdog
363
364 #x#
365 %attr(640,root,disk) /dev/xd*
366
367 #y#
368
369 #z#
370 %attr(666,root,root) /dev/zero
371
372 %changelog
373 * Mon Apr 26 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
374   [2.7.3-1]
375 - upgrade to 2.7.3,
376 - added pts update,
377 - added route, watchdog, framebuffer, console device,
378 - removed /dev/log, /dev/cua[0-3].
This page took 0.063586 seconds and 4 git commands to generate.