]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
- cosmetics
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(de):    /dev-Einträge
3 Summary(fr):    Entrées de /dev
4 Summary(pl):    Pliki specjalne /dev/*
5 Summary(tr):    /dev dizini
6 Name:           dev
7 Version:        2.9.0
8 Release:        13
9 License:        Public Domain
10 Group:          Base
11 Source0:        dev-list
12 PreReq:         setup >= 2.4.1-2
13 Provides:       devfs
14 AutoReqProv:    no
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Unix and unix like systems (including Linux) use file system entries
19 to represent devices attached to the machine. All of these entries are
20 in the /dev tree (though they don't have to be), and this package
21 contains the most commonly used /dev entries. These files are
22 essential for a system to function properly.
23
24 %description -l de
25 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
26 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge
27 befinden sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses
28 Paket enthält die üblichsten /dev-Einträge. Diese Dateien sind für das
29 Funktionieren eines Systems unbedingt erforderlich.
30
31 %description -l fr
32 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
33 représenter les périphériques reliés à la machine. Toutes ces entrées
34 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
35 contient les entrées /dev les plus courantes. Elles sont essentielles
36 pour qu'un système fonctionne correctement.
37
38 %description -l pl
39 Wszystkie systemy klasy unices, w tym Linux, u¿ywaj± plików do
40 przedstawiania urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki
41 znajduj± siê zwykle w katalogu /dev. Pakiet ten zawiera wiêkszo¶æ
42 popularnych plików specjalnych, s± one jedn± z wa¿niejszych czê¶ci
43 prawid³owo dzia³aj±cego systemu operacyjnego.
44
45 %description -l tr
46 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya
47 baðlý aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel
48 dosyalarýn tümü /dev dizin yapýsý altýndadýr. Bu paket en çok
49 kullanýlan /dev dosyalarýný içerir. Bu dosyalar, bir sistemin düzgün
50 olarak iþleyebilmesi için temel gereksinimlerdendir.
51
52 %prep
53 %setup -q -c -T
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT/dev/{ataraid,cciss,cdroms,cpu/{0,1,2,3,4,5,6,7}} \
58         $RPM_BUILD_ROOT/dev/{discs,i2o,ida,input,net,pts,raw,rd,usb,shm,snd,zap} \
59         $RPM_BUILD_ROOT/dev/{mapper,dri}
60
61 install %{SOURCE0} .
62
63 cd $RPM_BUILD_ROOT/dev
64 ln -sf adsp0 adsp
65 ln -sf amidi0 amidi
66 ln -sf audio0 audio
67 ln -sf dsp0 dsp
68 ln -sf fb0 fb
69 ln -sf rft0 ftape
70 ln -sf isdnctrl0 isdnctrl
71 ln -sf midi00 midi
72 ln -sf mixer0 mixer
73 ln -sf nrft0 nftape
74 ln -sf ram0 ramdisk
75
76 ln -sf em8300-0         em8300
77 ln -sf em8300_ma-0      em8300_ma
78 ln -sf em8300_mv-0      em8300_mv
79 ln -sf em8300_sp-0      em8300_sp
80 for i in `seq 0 31`; do
81         ln -sf fb$i fb${i}current
82 done
83 ln -sf /proc/self/fd fd
84 ln -sf fd/0 stdin
85 ln -sf fd/1 stdout
86 ln -sf fd/2 stderr
87 i=0;
88 for l in a b c d e f g h; do
89         ln -sf sg$l sg$i
90         i=$((i+1))
91 done
92 ln -sf radio0 radio
93 ln -sf music sequencer2
94 ln -sf vbi0 vbi
95 ln -sf video0 video
96 ln -sf vtx0 vtx
97
98 # prepared for SysVinit
99 mkfifo initctl
100
101 mkfifo lircm
102 mkfifo printer
103
104 # prepared for Log Daemon
105 mkfifo syslog
106
107 %ifarch m68k
108 ln -sf amigamouse mouse
109 %endif
110
111 %ifarch ppc
112 ln -sf adbmouse mouse
113 %endif
114
115 %ifarch sparc sparc64 sparcv9
116 ln -sf sunmouse mouse
117 %endif
118
119 # PLD-forklor:
120 ln -sf null drzewo
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files -f dev-list
126 %defattr(644,root,root,755)
127 %dir /dev/cpu
128 %dir /dev/cpu/0
129 %dir /dev/cpu/1
130 %dir /dev/cpu/2
131 %dir /dev/cpu/3
132 %dir /dev/cpu/4
133 %dir /dev/cpu/5
134 %dir /dev/cpu/6
135 %dir /dev/cpu/7
136 %dir /dev/ataraid
137 %dir /dev/cciss
138 %dir /dev/dri
139 %attr(750,root,disk) %dir /dev/cdroms
140 %attr(750,root,disk) %dir /dev/discs
141 %dir /dev/i2o
142 %dir /dev/ida
143 %dir /dev/input
144 %dir /dev/net
145 %dir /dev/pts
146 %dir /dev/raw
147 %dir /dev/rd
148 %dir /dev/usb
149 %dir /dev/mapper
150 %dir /dev/zap
151 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/adsp
152 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/amidi
153 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/audio
154 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/dsp
155 %config(noreplace) %verify(not link) %attr(660,root,video) /dev/fb
156 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ftape
157 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
158 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/midi
159 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/mixer
160 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/nftape
161 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
162 %attr(660,root,video) /dev/em8300*
163 %attr(660,root,video) /dev/fb[0-9]*current
164 /dev/fd
165 /dev/stdin
166 /dev/stdout
167 /dev/stderr
168 %attr(660,root,video) /dev/radio
169 %attr(660,root,audio) /dev/sequencer2
170 %attr(600,root,root) /dev/sg[0-7]
171 %dir /dev/shm
172 %dir /dev/snd
173 %attr(660,root,video) /dev/vbi
174 %attr(660,root,video) /dev/video
175 %attr(660,root,video) /dev/vtx
176 %attr(600,root,root) /dev/initctl
177 %attr(660,root,root) /dev/lircm
178 %attr(600,root,root) /dev/printer
179 %attr(666,root,root) /dev/syslog
180 %attr(666,root,root) /dev/drzewo
181
182 %dev(c,10,165) %attr(640,root,root) /dev/vmmon
183 %dev(c,119,10) %attr(640,root,root) /dev/vmnet0
184 %dev(c,119,10) %attr(640,root,root) /dev/vmnet1
185 %dev(c,119,10) %attr(640,root,root) /dev/vmnet2
186 %dev(c,119,10) %attr(640,root,root) /dev/vmnet3
187 %dev(c,119,10) %attr(640,root,root) /dev/vmnet4
188 %dev(c,119,10) %attr(640,root,root) /dev/vmnet5
189 %dev(c,119,10) %attr(640,root,root) /dev/vmnet6
190 %dev(c,119,10) %attr(640,root,root) /dev/vmnet7
191 %dev(c,119,10) %attr(640,root,root) /dev/vmnet8
192
193 %dev(c,10,240) %attr(600,root,root) /dev/mptctl
194
195 %dev(c,10,63) %attr(660,root,disk) /dev/mapper/control
196
197 %ifarch %{ix86}
198 %dev(c,10,184) %attr(666,root,root) /dev/cpu/microcode
199 %dev(c,10,181) %attr(666,root,root) /dev/toshiba
200 %dev(c,212,0) %attr(600,root,root) /dev/slamr0
201 %dev(c,213,0) %attr(600,root,root) /dev/slusb0
202 %dev(c,226,0) %attr(660,root,video) /dev/dri/card0
203 %dev(c,226,1) %attr(660,root,video) /dev/dri/card1
204 %dev(c,226,2) %attr(660,root,video) /dev/dri/card2
205 %dev(c,226,3) %attr(660,root,video) /dev/dri/card3
206 %dev(c,226,4) %attr(660,root,video) /dev/dri/card4
207 %dev(c,226,5) %attr(660,root,video) /dev/dri/card5
208 %dev(c,226,6) %attr(660,root,video) /dev/dri/card6
209 %dev(c,226,7) %attr(660,root,video) /dev/dri/card7
210 %endif
211
212 %ifarch m68k
213 %dev(b,2,4) %attr(660,root,floppy) /dev/fdhd0
214 %dev(b,2,5) %attr(660,root,floppy) /dev/fdhd1 
215 # XXX: which permissions???
216 %dev(c,10,4) %attr(664,root,root) /dev/amigamouse
217 %attr(664,root,root) /dev/mouse
218 %dev(c,10,5) %attr(664,root,root) /dev/atarimouse
219 %dev(c,10,7) %attr(664,root,root) /dev/apollomouse
220 %endif
221
222 %ifarch ppc
223 %dev(c,56,0) %attr(644,root,root) /dev/adb
224 %dev(c,10,10) %attr(644,root,root) /dev/adbmouse
225 %attr(644,root,root) /dev/mouse
226 %dev(c,10,154) %attr(644,root,root) /dev/pmu
227 %dev(c,10,198) %attr(644,root,root) /dev/sheep_net
228 %endif
229
230 %ifarch sparc sparc64 sparcv9
231 %dev(c,14,7) %attr(660,root,audio) /dev/audioctl
232 # XXX: which permissions ???
233 %dev(c,10,139) %attr(600,root,root) /dev/openprom
234 %dev(c,10,6) %attr(664,root,root) /dev/sunmouse
235 %attr(664,root,root) /dev/mouse
236 %endif
237
238 %ifarch m68k sparc sparc64 sparcv9
239 # XXX: which permissions???
240 %dev(c,11,00) %attr(600,root,root) /dev/kbd
241 %endif
242
243 %ifnarch m68k sparc sparc64 sparcv9
244 %dev(c,10,3) %attr(664,root,root) /dev/atibm
245 %dev(b,29,0) %attr(660,root,disk) /dev/aztcd
246 %dev(b,15,0) %attr(660,root,disk) /dev/cdu31a
247 %dev(b,24,0) %attr(660,root,disk) /dev/cdu535
248 %dev(b,32,0) %attr(660,root,disk) /dev/cm206cd
249 %dev(b,16,0) %attr(660,root,disk) /dev/gscd
250 %dev(c,10,2) %attr(664,root,root) /dev/inportbm
251 %dev(c,10,0) %attr(664,root,root) /dev/logibm
252 %dev(b,23,0) %attr(660,root,disk) /dev/mcd
253 %dev(c,10,1) %attr(664,root,root) /dev/psaux
254 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd
255 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd0
256 %dev(b,25,1) %attr(660,root,disk) /dev/sbpcd1
257 %dev(b,25,2) %attr(660,root,disk) /dev/sbpcd2
258 %dev(b,25,3) %attr(660,root,disk) /dev/sbpcd3
259 %dev(b,18,0) %attr(660,root,disk) /dev/sjcd
260 %dev(b,15,0) %attr(660,root,disk) /dev/sonycd
261 %endif
This page took 0.085401 seconds and 4 git commands to generate.