]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
- removed drzewo link,
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(de):    /dev-Einträge
3 Summary(fr):    Entrées de /dev
4 Summary(pl):    Pliki specjalne /dev/*
5 Summary(tr):    /dev dizini
6 Name:           dev
7 Version:        2.9.0
8 Release:        1
9 License:        Public Domain
10 Group:          Base
11 Source0:        dev-list.bz2
12 # Source0-md5:  4808891f6317383850ff826c31a1e797
13 PreReq:         setup >= 2.4.1-2
14 Provides:       devfs
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16 Autoreqprov:    no
17
18 %description
19 Unix and unix like systems (including Linux) use file system entries
20 to represent devices attached to the machine. All of these entries are
21 in the /dev tree (though they don't have to be), and this package
22 contains the most commonly used /dev entries. These files are
23 essential for a system to function properly.
24
25 %description -l de
26 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
27 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge
28 befinden sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses
29 Paket enthält die üblichsten /dev-Einträge. Diese Dateien sind für das
30 Funktionieren eines Systems unbedingt erforderlich.
31
32 %description -l fr
33 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
34 représenter les périphériques reliés à la machine. Toutes ces entrées
35 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
36 contient les entrées /dev les plus courantes. Elles sont essentielles
37 pour qu'un système fonctionne correctement.
38
39 %description -l pl
40 Wszystkie systemy klasy unices, w tym Linux, u¿ywaj± plików do
41 przedstawiania urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki
42 znajduj± siê zwykle w katalogu /dev. Pakiet ten zawiera wiêkszo¶æ
43 popularnych plików specjalnych, s± one jedn± z wa¿niejszych czê¶ci
44 prawid³owo dzia³aj±cego systemu operacyjnego.
45
46 %description -l tr
47 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya
48 baðlý aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel
49 dosyalarýn tümü /dev dizin yapýsý altýndadýr. Bu paket en çok
50 kullanýlan /dev dosyalarýný içerir. Bu dosyalar, bir sistemin düzgün
51 olarak iþleyebilmesi için temel gereksinimlerdendir.
52
53 %prep
54 %setup -q -c -T
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT/dev/{ataraid,cciss,cdroms,cpu/{0,1,2,3,4,5,6,7}} \
59         $RPM_BUILD_ROOT/dev/{discs,i2o,ida,input,net,pts,raw,rd,usb}
60
61 bunzip2 -dc %{SOURCE0} > dev-list
62
63 cd $RPM_BUILD_ROOT/dev
64 ln -sf adsp0 adsp
65 ln -sf amidi0 amidi
66 ln -sf audio0 audio
67 ln -sf dsp0 dsp
68 ln -sf fb0 fb
69 ln -sf rft0 ftape
70 ln -sf isdnctrl0 isdnctrl
71 ln -sf midi00 midi
72 ln -sf mixer0 mixer
73 ln -sf nrft0 nftape
74 ln -sf ram0 ramdisk
75
76 ln -sf em8300-0    em8300
77 ln -sf em8300_ma-0 em8300_ma
78 ln -sf em8300_mv-0 em8300_mv
79 ln -sf em8300_sp-0 em8300_sp
80 for i in 0 1 2 3 4 5 6 7; do
81         ln -sf fb$i fb${i}current
82 done
83 ln -sf /proc/self/fd fd
84 ln -sf fd/0 stdin
85 ln -sf fd/1 stdout
86 ln -sf fd/2 stderr
87 i=0;
88 for l in a b c d e f g h; do
89         ln -sf sg$l sg$i
90         i=$((i+1))
91 done
92 ln -sf radio0 radio
93 ln -sf music sequencer2
94 ln -sf /proc/asound/dev snd
95 ln -sf vbi0 vbi
96 ln -sf video0 video
97 ln -sf vtx0 vtx
98
99 # prepared for SysVinit
100 mknod initctl p
101
102 mknod lircm p
103 mknod printer p
104
105 # prepared for Log Daemon
106 mkfifo syslog
107
108 %ifarch m68k
109 ln -sf amigamouse mouse
110 %endif
111
112 %ifarch ppc
113 ln -sf adbmouse mouse
114 %endif
115
116 %ifarch sparc
117 ln -sf sunmouse mouse
118 %endif
119
120 %files -f dev-list
121 %defattr(644,root,root,755)
122 %dir /dev/cpu
123 %dir /dev/cpu/0
124 %dir /dev/cpu/1
125 %dir /dev/cpu/2
126 %dir /dev/cpu/3
127 %dir /dev/cpu/4
128 %dir /dev/cpu/5
129 %dir /dev/cpu/6
130 %dir /dev/cpu/7
131 %dir /dev/ataraid
132 %dir /dev/cciss
133 %attr(660,root,disk) %dir /dev/cdroms
134 %attr(660,root,disk) %dir /dev/discs
135 %dir /dev/i2o
136 %dir /dev/ida
137 %dir /dev/input
138 %dir /dev/net
139 %dir /dev/pts
140 %dir /dev/raw
141 %dir /dev/rd
142 %dir /dev/usb
143 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/adsp
144 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/amidi
145 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/audio
146 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/dsp
147 %config(noreplace) %verify(not link) %attr(664,root,video) /dev/fb
148 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ftape
149 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
150 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/midi
151 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/mixer
152 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/nftape
153 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
154 %attr(660,root,video) /dev/em8300*
155 %attr(664,root,video) /dev/fb[0-7]current
156 /dev/fd
157 /dev/stdin
158 /dev/stdout
159 /dev/stderr
160 %attr(660,root,video) /dev/radio
161 %attr(660,root,audio) /dev/sequencer2
162 %attr(600,root,root) /dev/sg[0-7]
163 /dev/snd
164 %attr(660,root,video) /dev/vbi
165 %attr(660,root,video) /dev/video
166 %attr(660,root,video) /dev/vtx
167 %attr(600,root,root) /dev/initctl
168 %attr(660,root,root) /dev/lircm
169 %attr(600,root,root) /dev/printer
170 %attr(666,root,root) /dev/syslog
171
172 %ifarch %{ix86}
173 %dev(c,10,184) %attr(666,root,root) /dev/cpu/microcode
174 %dev(c,10,181) %attr(666,root,root) /dev/toshiba
175 %endif
176
177 %ifarch m68k
178 %dev(b,2,4) %attr(660,root,floppy) /dev/fdhd0
179 %dev(b,2,5) %attr(660,root,floppy) /dev/fdhd1 
180 # XXX: which permissions???
181 %dev(c,10,4) %attr(664,root,root) /dev/amigamouse
182 %attr(664,root,root) /dev/mouse
183 %dev(c,10,5) %attr(664,root,root) /dev/atarimouse
184 %dev(c,10,7) %attr(664,root,root) /dev/apollomouse
185 %endif
186
187 %ifarch ppc
188 %dev(c,56,0) %attr(644,root,root) /dev/adb
189 %dev(c,10,10) %attr(644,root,root) /dev/adbmouse
190 %attr(644,root,root) /dev/mouse
191 %dev(c,10,154) %attr(644,root,root) /dev/pmu
192 %dev(c,10,198) %attr(644,root,root) /dev/sheep_net
193 %endif
194
195 %ifarch sparc
196 # XXX: which permissions ???
197 %dev(c,10,139) %attr(600,root,root) /dev/openprom
198 %dev(c,10,6) %attr(664,root,root) /dev/sunmouse
199 %attr(664,root,root) /dev/mouse
200 %endif
201
202 %ifarch m68k sparc
203 # XXX: which permissions???
204 %dev(c,11,00) %attr(600,root,root) /dev/kbd
205 %endif
206
207 %ifnarch m68k sparc
208 %dev(c,10,3) %attr(664,root,root) /dev/atibm
209 %dev(b,29,0) %attr(660,root,disk) /dev/aztcd
210 %dev(b,15,0) %attr(660,root,disk) /dev/cdu31a
211 %dev(b,24,0) %attr(660,root,disk) /dev/cdu535
212 %dev(b,32,0) %attr(660,root,disk) /dev/cm206cd
213 %dev(b,16,0) %attr(660,root,disk) /dev/gscd
214 %dev(c,10,2) %attr(664,root,root) /dev/inportbm
215 %dev(c,10,0) %attr(664,root,root) /dev/logibm
216 %dev(b,23,0) %attr(660,root,disk) /dev/mcd
217 %dev(c,10,1) %attr(664,root,root) /dev/psaux
218 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd
219 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd0
220 %dev(b,25,1) %attr(660,root,disk) /dev/sbpcd1
221 %dev(b,25,2) %attr(660,root,disk) /dev/sbpcd2
222 %dev(b,25,3) %attr(660,root,disk) /dev/sbpcd3
223 %dev(b,18,0) %attr(660,root,disk) /dev/sjcd
224 %dev(b,15,0) %attr(660,root,disk) /dev/sonycd
225 %endif
This page took 0.067696 seconds and 4 git commands to generate.