]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
commented out Prereq: Setup && Shadow
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(fr):    Entrées de /dev.
3 Summary(de):    /dev-Einträge
4 Summary(pl):    Pliki specjalne /dev/*
5 Summary(tr):    /dev dizini
6 Name:           dev
7 Version:        2.7.7
8 Release:        5
9 #######         From ftp.redhat.com/rawhide
10 Source:         %{name}-%{version}.tar.gz
11 Copyright:      public domain
12 Group:          Base
13 Group(pl):      Podstawowe
14 #BuildPrereq:   setup
15 # remove shadow if floppy and console group exist in setup
16 #BuildPrereq:   shadow
17 #Prereq:                setup
18 Buildroot:      /tmp/%{name}-%{version}-root
19 Autoreqprov:    no
20
21 %description
22 Unix and unix like systems (including Linux) use file system entries
23 to represent devices attached to the machine. All of these entries
24 are in the /dev tree (though they don't have to be), and this package
25 contains the most commonly used /dev entries. These files are essential
26 for a system to function properly.
27
28 %description -l pl
29 Wszystkie systemy Unix, jak na przyk³ad Linux, u¿ywaj± plików do przedstawienia 
30 urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki znajduj± siê zwykle w 
31 katalogu /dev. Pakiet ten zawiera wiêkszo¶æ popularnych plików specjalnych, 
32 s± one jedn± z wa¿niejszych czê¶ci prawid³owo dzia³aj±cego systemu operacyjnego.
33
34 %description -l fr
35 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
36 représenter les périphériques reliés à la machine. Toutes ces entrées
37 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
38 contient les entrées /dev les plus courantes. Elles sont essentielles
39 pour qu'un système fonctionne correctement.
40
41 %description -l tr
42 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya baðlý
43 aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel dosyalarýn tümü
44 /dev dizin yapýsý altýndadýr. Bu paket en çok kullanýlan /dev dosyalarýný
45 içerir. Bu dosyalar, bir sistemin düzgün olarak iþleyebilmesi için temel
46 gereksinimlerdendir.
47
48 %description -l de
49 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
50 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge befinden
51 sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses Paket enthält
52 die üblichsten /dev-Einträge. Diese Dateien sind für das Funktionieren
53 eines Systems unbedingt erforderlich.
54
55 %prep
56 %setup -q -c -T
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT
62
63 #add group for floppy and console
64 # if setup contains this group then remove next 4 lines 
65 #grep '^floppy:' /etc/group  >/dev/null \
66 #       || groupadd -g 19 -r -f floppy >/dev/null
67 #grep '^console:' /etc/group >/dev/null \
68 #       || groupadd -g 20 -f -r console >/dev/null
69
70 # do some cleanup in build root
71 cd $RPM_BUILD_ROOT
72 tar xpSzf $RPM_SOURCE_DIR/%{name}-%{version}.tar.gz
73
74 cd dev
75
76 # tar doesn't save some permissions unless the p option is used
77 # this code protects against dev package updaters forgetting to
78 # use the p option when unpacking the souce tarball.
79 for dev in zero null tty ttyp0 ; do
80   if [ ! $(ls -l $dev | awk '{print $1}') = crw-rw-rw- ] ; then
81     echo bad permissions on device $dev 1>&2
82     exit 1
83   fi
84 done
85
86 %ifarch sparc
87 # SPARC specific devices
88 ln -s sunmouse mouse
89 mknod kbd c 11 0
90 mknod openprom c 10 139
91 chmod 666 fb*
92
93 # remove devices that will *never* exist on a SPARC
94 rm -f hd* aztcd mcd sbpcd1 cdu31a sbpcd2 scd3
95 rm -f sjcd cdu535 sbpcd3 sonycd cm206cd sbpcd
96 rm -f gscd sbpcd0 atibm inportbm logibm psaux
97
98 %endif
99
100 %ifarch m68k                                                                    
101 # m68k specific devices                                                         
102 mknod amigamouse c 10 4                                                         
103 mknod atarimouse c 10 5                                                         
104 mknod apollomouse c 10 7                                                        
105 ln -s amigamouse mouse                                                          
106 mknod fdhd0 b 2 4                                                               
107 mknod fdhd1 b 2 5                                                               
108 mknod kbd c 11 0                                                                
109 chmod 666 fb*                                                                   
110                                                                                 
111 # remove devices that will *never* exist on a m68k                              
112 rm -f hd* aztcd mcd sbpcd1 cdu31a sbpcd2 scd3                                   
113 rm -f sjcd cdu535 sbpcd3 sonycd cm206cd sbpcd                                   
114 rm -f gscd sbpcd0 atibm inportbm logibm psaux                                   
115                                                                                 
116 %endif
117
118 # Coda support 
119 mknod cfs0 c 67 0
120
121
122 ln -s fb0 fb0current
123 ln -s fb1 fb1current
124 ln -s fb2 fb2current
125 ln -s fb3 fb3current
126 ln -s fb4 fb4current
127 ln -s fb5 fb5current
128 ln -s fb6 fb6current
129 ln -s fb7 fb7current
130
131 # watchdog support
132 mknod watchdog c 10 130 
133
134 # route 
135 mknod route c 36 0
136
137 #ALSA support
138 rm -f mixer*
139 mknod mixer0 c 14 0
140 mknod mixer1 c 14 16
141 mknod mixer2 c 14 32
142 mknod mixer3 c 14 48
143 ln -s mixer0 mixer
144
145 ln -s midi00 midi
146
147 rm -f dsp*
148 mknod dsp0 c 14 3
149 mknod dsp1 c 14 19
150 mknod dsp2 c 14 35
151 mknod dsp3 c 14 51
152 ln -s dsp0 dsp
153
154 rm -f audio*
155 mknod audio0 c 14 4
156 mknod audio1 c 14 20
157 mknod audio2 c 14 36
158 mknod audio3 c 14 52
159 ln -s audio0 audio
160
161 mknod adsp0 c 14 12
162 mknod adsp1 c 14 28
163 mknod adsp2 c 14 44
164 mknod adsp3 c 14 60
165 ln -s adsp0 adsp
166
167 mknod dmfm0 c 14 10
168 mknod dmfm1 c 14 26
169 mknod dmfm2 c 14 42
170 mknod dmfm3 c 14 58
171
172 mknod dmmidi0 c 14 9
173 mknod dmmidi1 c 14 25
174 mknod dmmidi2 c 14 41
175 mknod dmmidi3 c 14 57
176
177 mknod music c 14 8
178
179 mknod admmidi0 c 14 14
180 mknod admmidi1 c 14 30 
181 mknod admmidi2 c 14 46
182 mknod admmidi3 c 14 62
183
184 mknod amidi0 c 14 13
185 mknod amidi1 c 14 29
186 mknod amidi2 c 14 45
187 mknod amidi3 c 14 61
188 ln -s amidi0 amidi
189
190 ln -s music sequencer2
191
192 #temporary
193 install -d $RPM_BUILD_ROOT/proc/asound
194 touch $RPM_BUILD_ROOT/proc/asound/snd
195
196 ln -s ../proc/asound/snd snd
197
198 # prepared for SysVinit
199 mknod initctl p
200
201 #prepared for Log Daemon
202 mkfifo --mode=666 syslog
203
204 %pre
205 # if setup contains groups floppy and console this mayby obsoletes
206 #%{_sbindir}/groupadd -g 19 -r -f floppy
207 #%{_sbindir}/groupadd -g 20 -r -f console
208
209 %post
210 if [ -f /etc/fstab ] ; then
211   # add /dev/pts to fstab if fstab exists (install2 does it during install)
212   if grep 'devpts' /etc/fstab >/dev/null 2>&1 ; then : ; else
213     # note that we do not disallow comments; we wish to allow people
214     # to comment it out if they so desire.
215     TMP=$(mktemp /tmp/fstab.XXXXXX)
216     sed '/\/proc/a\
217 pts                    /dev/pts                devpts  mode=0600       0 0
218         ' < /etc/fstab > $TMP && mv -f $TMP /etc/fstab || { echo "failed to add devpts filesystem to /etc/fstab" 1>&2 ; exit 1 ; }
219     rm -f $TMP
220   fi
221 fi
222
223 %clean 
224 rm -rf $RPM_BUILD_ROOT
225
226 %files 
227 %defattr(644,root,root,755)
228
229 #a#
230 %attr(662,root, sys) /dev/admmidi*
231
232 %config(noreplace) %verify(not link) %attr(666,root, sys) /dev/adsp
233 %attr(662,root, sys) /dev/adsp?*
234
235 %config(noreplace) %verify(not link) %attr(662,root,root) /dev/amidi
236 %attr(662,root,root) /dev/amidi?*
237
238 %attr(664,root,root) /dev/atibm
239
240 %config(noreplace) %verify(not link) %attr(662,root, sys) /dev/audio
241 %attr(662,root, sys) /dev/audio?*
242
243 %attr(664,root,root) /dev/aztcd
244
245
246 #b#
247 %attr(664,root,root) /dev/bpcd
248
249 #c#
250 %attr(600,root,root)    /dev/capi*
251 %attr(664,root,root)    /dev/cdu31a
252 %attr(640,root,disk)    /dev/cdu535
253 %attr(600,root,root)    /dev/cfs0
254 %attr(664,root,root)    /dev/cm206cd
255 %attr(660,root,console) /dev/console
256 %attr(664,root,root)    /dev/cui*
257 %attr(600,root,root)    /dev/cum*
258
259 #d#
260 %attr(600,root,root) /dev/dcbri*
261 %attr(660,root, sys) /dev/dcxx*
262 %attr(662,root, sys) /dev/dmfm*
263 %attr(662,root, sys) /dev/dmmidi*
264 %config(noreplace) %verify(not link) %attr(662,root, sys) /dev/dsp
265 %attr(662,root, sys) /dev/dsp?*
266
267 #e#
268 %attr(600,root,root) /dev/enskip
269
270 #f#
271 %config(noreplace) %verify(not link) %attr(644,root,root)   /dev/fb
272 %attr(644,root,root)   /dev/fb?*
273 %attr(664,root,floppy) /dev/fd*
274 %config(noreplace) %verify(not link) %attr(666,root,root) /dev/ftape
275 %attr(644,root,root)   /dev/full
276
277 #g#
278 %attr(664,root,root) /dev/gscd
279
280 #h#
281 %attr(660,root,disk) /dev/hd*
282 %attr(660,root,disk) /dev/ht0
283
284 #i#
285 %attr(600,root,root) /dev/i2c*
286 %dir /dev/ida
287 %attr(660,root,disk) /dev/ida/*
288 %attr(600,root,root) /dev/initctl
289 %attr(664,root,root) /dev/inportbm
290 %attr(600,root,root) /dev/ipauth
291 %attr(600,root,root) /dev/ipl
292 %attr(600,root,root) /dev/ipnat
293 %attr(600,root,root) /dev/ippp*
294 %attr(660,root, sys) /dev/iscc*
295 %attr(600,root,root) /dev/isctl
296 %attr(600,root,root) /dev/isdn?
297 %attr(600,root,root) /dev/isdn??
298 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
299 %attr(600,root,root) /dev/isdnctrl?*
300 %attr(444,root,root) /dev/isdninfo
301
302 #j#
303 %attr(660,root, sys) /dev/js*
304
305 #k#
306 %attr(640,root,kmem) /dev/kmem
307
308 #l#
309 %attr(666,root,root) /dev/log
310 %attr(664,root,root) /dev/logibm
311 %attr(660,root,disk) /dev/loop*
312
313 %attr(660,root,daemon) /dev/lp*
314
315 #m#
316 %attr(640,root,disk) /dev/mcd
317 %attr(640,root,kmem) /dev/mem
318 %config(noreplace) %verify(not link) %attr(662,root,sys) /dev/midi
319 %attr(662,root, sys) /dev/midi?*
320 %config(noreplace) %verify(not link) %attr(662,root,sys) /dev/mixer
321 %attr(662,root, sys) /dev/mixer?*
322 %attr(660,root, sys) /dev/mmetfgrab
323 %attr(600,root,root) /dev/mpu401*
324 %attr(662,root, sys) /dev/music
325
326 #n#
327 %attr(660,root,disk) /dev/nb*
328 %config(noreplace) %verify(not link) %attr(666,root,root) /dev/nftape
329 %attr(660,root,disk) /dev/nht*
330 %attr(660,root,disk) /dev/nqft*
331 %attr(660,root,disk) /dev/nrawqft*
332 %attr(660,root,disk) /dev/nrft*
333 %attr(660,root,disk) /dev/nst*
334 %attr(660,root,disk) /dev/ntpqic*
335 %attr(666,root,root) /dev/null
336 %attr(660,root,disk) /dev/nzqft*
337
338 #o#
339 %attr(664,root,root) /dev/optcd
340
341 #p#
342 %attr(640,root,daemon) /dev/par?
343 %attr(660,root,daemon) /dev/parport*
344
345 %attr(660,root,disk) /dev/pcd*
346 %attr(660,root,disk) /dev/pd*
347 %attr(660,root,disk) /dev/pf*
348 %attr(600,root,root) /dev/pg*
349
350 %attr(640,root,kmem) /dev/port
351 %attr(600,root,root) /dev/printer
352 %attr(664,root,root) /dev/psaux
353
354 %attr(660,root,disk) /dev/pt0
355 %attr(660,root,disk) /dev/pt1
356 %attr(660,root,disk) /dev/pt2
357 %attr(660,root,disk) /dev/pt3
358
359 %attr(666,root, tty) /dev/ptmx
360 %attr(666,root, tty) /dev/pty*
361 %dir /dev/pts
362
363 #r#
364 %attr(640,root,disk) /dev/ram
365 %attr(660,root,disk) /dev/ram0
366 %attr(660,root,disk) /dev/ram1*
367 %attr(660,root,disk) /dev/ram2
368 %attr(660,root,disk) /dev/ram3
369 %attr(660,root,disk) /dev/ram4
370 %attr(660,root,disk) /dev/ram5
371 %attr(660,root,disk) /dev/ram6
372 %attr(660,root,disk) /dev/ram7
373 %attr(660,root,disk) /dev/ram8
374 %attr(660,root,disk) /dev/ram9
375
376 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
377
378 %attr(644,root,root) /dev/random
379 %attr(660,root,disk) /dev/rawqft*
380 %attr(660,root,disk) /dev/rft*
381 %attr(660,root, sys) /dev/rmidi*
382 %attr(660,root,disk) /dev/rmt*
383 %attr(644,root,root) /dev/route
384 %attr(664,root,root) /dev/rtc
385 %dir /dev/rd
386 %attr(660,root,disk) /dev/rd/*
387
388 #s#
389 %attr(640,root,disk) /dev/sbpc*
390 %attr(660,root,disk) /dev/scd*
391 %attr(660,root,disk) /dev/sd*
392
393 %attr(662,root,sys)  /dev/sequencer
394 %attr(662,root,sys)  /dev/sequencer2
395
396 %attr(600,root,root) /dev/sg*
397 %attr(664,root,root) /dev/sjcd
398 %attr(600,root,root) /dev/smtpe*
399
400 %attr(444,root,root) /dev/snd
401 %attr(666,root,root) /dev/sndstat
402
403 %attr(640,root,disk) /dev/sonycd
404
405 %attr(600,root,root) /dev/srnd*
406
407 %attr(660,root,disk) /dev/st?
408 %attr(600,root,root) /dev/staliomem*
409 %attr(666,root,root) /dev/std*
410
411 %attr(664,root,root) /dev/sunmouse
412 %attr(666,root,root) /dev/syslog
413 %attr(600,root,root) /dev/systty
414
415 #t#
416 %attr(660,root,disk) /dev/tape*
417 %attr(600,root,root) /dev/tlk*
418 %attr(660,root,disk) /dev/tpqic*
419
420 %attr(666,root,root) /dev/tty
421
422 %attr(600,root, tty) /dev/tty0
423 %attr(600,root, tty) /dev/tty1*
424 %attr(600,root, tty) /dev/tty2
425 %attr(600,root, tty) /dev/tty3
426 %attr(600,root, tty) /dev/tty4
427 %attr(600,root, tty) /dev/tty5
428 %attr(600,root, tty) /dev/tty6
429 %attr(600,root, tty) /dev/tty7
430 %attr(600,root, tty) /dev/tty8
431 %attr(600,root, tty) /dev/tty9
432
433 %attr(600,root,root) /dev/ttyC*
434 %attr(600,root,root) /dev/ttyD*
435 %attr(600,root,root) /dev/ttyE*
436 %attr(600,root,root) /dev/ttyI*
437 %attr(600,root,root) /dev/ttyM*
438 %attr(600,root,root) /dev/ttyP*
439 %attr(600,root,root) /dev/ttyR*
440
441 %attr(644,root,root) /dev/ttyS*
442
443 %attr(666,root, tty) /dev/ttya*
444 %attr(666,root, tty) /dev/ttyb*
445 %attr(666,root, tty) /dev/ttyc*
446 %attr(666,root, tty) /dev/ttyd*
447 %attr(666,root, tty) /dev/ttye*
448 %attr(666,root, tty) /dev/ttyp*
449 %attr(666,root, tty) /dev/ttyq*
450 %attr(666,root, tty) /dev/ttyr*
451 %attr(666,root, tty) /dev/ttys*
452 %attr(666,root, tty) /dev/ttyt*
453 %attr(666,root, tty) /dev/ttyu*
454 %attr(666,root, tty) /dev/ttyv*
455 %attr(666,root, tty) /dev/ttyw*
456 %attr(666,root, tty) /dev/ttyx*
457 %attr(666,root, tty) /dev/ttyy*
458 %attr(666,root, tty) /dev/ttyz*
459
460 #u#
461 %attr(644,root,root) /dev/urandom
462
463 #v#
464 %attr(620,root,tty) /dev/vcs*
465
466 #w#
467 %attr(600,root,root) /dev/watchdog
468 %attr(660,root, sys) /dev/wvisfgrab
469
470 #x#
471 %attr(660,root,disk) /dev/xd*
472
473 #y#
474
475 #z#
476 %attr(666,root,root) /dev/zero
477 %attr(660,root,disk) /dev/zqft*
478
479 %changelog
480 * Thu May 20 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
481 - again /dev/log in this package ... 
482
483 * Thu Apr 29 1999 Artur Wiget <wiget@pld.org.pl>
484   [2.7.7-2]
485 - upgrade to 2.7.7  
486 - removed creating already created devices
487 - added more devices in %%files
488
489 * Mon Apr 27 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
490   [2.7.3-2]
491 - added /dev/initctl,
492 - added pts device to /etc/fstab,
493 - added /dev/syslog.
494
495 * Mon Apr 26 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
496   [2.7.3-1]
497 - upgrade to 2.7.3,
498 - removed /dev/log, /dev/cua[0-3].
499
500 * Tue Apr 20 1999 Artur Frysiak <wiget@pld.org.pl>
501   [2.5.9-3]
502 - compiled on rpm 3
503 - fixed framebuffer support
504 - added coda support
505
506 * Sat Dec 12 1998 Sergiusz Paw³owicz <ser@hyperreal.art.pl>
507   [2.5.9-1d]
508 - added polish translation to spec (regards to PLD Team),
509 - added handles to Unix98 pty support,
510 - added handles to framebuffer support,
511 - revised spec file, adding group 'floppy' removed.
512 - removed initctl -- SysVinit provides it.
513 - start at RH spec file.
This page took 0.063471 seconds and 4 git commands to generate.