]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
- /dev/fb* readable only for video group; relese 4
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(de):    /dev-Einträge
3 Summary(fr):    Entrées de /dev
4 Summary(pl):    Pliki specjalne /dev/*
5 Summary(tr):    /dev dizini
6 Name:           dev
7 Version:        2.9.0
8 Release:        4
9 License:        Public Domain
10 Group:          Base
11 Source0:        dev-list
12 PreReq:         setup >= 2.4.1-2
13 Provides:       devfs
14 AutoReqProv:    no
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Unix and unix like systems (including Linux) use file system entries
19 to represent devices attached to the machine. All of these entries are
20 in the /dev tree (though they don't have to be), and this package
21 contains the most commonly used /dev entries. These files are
22 essential for a system to function properly.
23
24 %description -l de
25 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
26 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge
27 befinden sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses
28 Paket enthält die üblichsten /dev-Einträge. Diese Dateien sind für das
29 Funktionieren eines Systems unbedingt erforderlich.
30
31 %description -l fr
32 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
33 représenter les périphériques reliés à la machine. Toutes ces entrées
34 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
35 contient les entrées /dev les plus courantes. Elles sont essentielles
36 pour qu'un système fonctionne correctement.
37
38 %description -l pl
39 Wszystkie systemy klasy unices, w tym Linux, u¿ywaj± plików do
40 przedstawiania urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki
41 znajduj± siê zwykle w katalogu /dev. Pakiet ten zawiera wiêkszo¶æ
42 popularnych plików specjalnych, s± one jedn± z wa¿niejszych czê¶ci
43 prawid³owo dzia³aj±cego systemu operacyjnego.
44
45 %description -l tr
46 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya
47 baðlý aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel
48 dosyalarýn tümü /dev dizin yapýsý altýndadýr. Bu paket en çok
49 kullanýlan /dev dosyalarýný içerir. Bu dosyalar, bir sistemin düzgün
50 olarak iþleyebilmesi için temel gereksinimlerdendir.
51
52 %prep
53 %setup -q -c -T
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT/dev/{ataraid,cciss,cdroms,cpu/{0,1,2,3,4,5,6,7}} \
58         $RPM_BUILD_ROOT/dev/{discs,i2o,ida,input,net,pts,raw,rd,usb,snd}
59
60 install %{SOURCE0} .
61
62 cd $RPM_BUILD_ROOT/dev
63 ln -sf adsp0 adsp
64 ln -sf amidi0 amidi
65 ln -sf audio0 audio
66 ln -sf dsp0 dsp
67 ln -sf fb0 fb
68 ln -sf rft0 ftape
69 ln -sf isdnctrl0 isdnctrl
70 ln -sf midi00 midi
71 ln -sf mixer0 mixer
72 ln -sf nrft0 nftape
73 ln -sf ram0 ramdisk
74
75 ln -sf em8300-0    em8300
76 ln -sf em8300_ma-0 em8300_ma
77 ln -sf em8300_mv-0 em8300_mv
78 ln -sf em8300_sp-0 em8300_sp
79 for i in `seq 0 31`; do
80         ln -sf fb$i fb${i}current
81 done
82 ln -sf /proc/self/fd fd
83 ln -sf fd/0 stdin
84 ln -sf fd/1 stdout
85 ln -sf fd/2 stderr
86 i=0;
87 for l in a b c d e f g h; do
88         ln -sf sg$l sg$i
89         i=$((i+1))
90 done
91 ln -sf radio0 radio
92 ln -sf music sequencer2
93 ln -sf vbi0 vbi
94 ln -sf video0 video
95 ln -sf vtx0 vtx
96
97 # prepared for SysVinit
98 mkfifo initctl
99
100 mkfifo lircm
101 mkfifo printer
102
103 # prepared for Log Daemon
104 mkfifo syslog
105
106 %ifarch m68k
107 ln -sf amigamouse mouse
108 %endif
109
110 %ifarch ppc
111 ln -sf adbmouse mouse
112 %endif
113
114 %ifarch sparc
115 ln -sf sunmouse mouse
116 %endif
117
118 # PLD-forklor:
119 ln -sf null drzewo
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f dev-list
125 %defattr(644,root,root,755)
126 %dir /dev/cpu
127 %dir /dev/cpu/0
128 %dir /dev/cpu/1
129 %dir /dev/cpu/2
130 %dir /dev/cpu/3
131 %dir /dev/cpu/4
132 %dir /dev/cpu/5
133 %dir /dev/cpu/6
134 %dir /dev/cpu/7
135 %dir /dev/ataraid
136 %dir /dev/cciss
137 %attr(660,root,disk) %dir /dev/cdroms
138 %attr(660,root,disk) %dir /dev/discs
139 %dir /dev/i2o
140 %dir /dev/ida
141 %dir /dev/input
142 %dir /dev/net
143 %dir /dev/pts
144 %dir /dev/raw
145 %dir /dev/rd
146 %dir /dev/usb
147 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/adsp
148 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/amidi
149 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/audio
150 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/dsp
151 %config(noreplace) %verify(not link) %attr(660,root,video) /dev/fb
152 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ftape
153 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
154 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/midi
155 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/mixer
156 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/nftape
157 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
158 %attr(660,root,video) /dev/em8300*
159 %attr(660,root,video) /dev/fb[0-9]*current
160 /dev/fd
161 /dev/stdin
162 /dev/stdout
163 /dev/stderr
164 %attr(660,root,video) /dev/radio
165 %attr(660,root,audio) /dev/sequencer2
166 %attr(600,root,root) /dev/sg[0-7]
167 %dir /dev/snd
168 %attr(660,root,video) /dev/vbi
169 %attr(660,root,video) /dev/video
170 %attr(660,root,video) /dev/vtx
171 %attr(600,root,root) /dev/initctl
172 %attr(660,root,root) /dev/lircm
173 %attr(600,root,root) /dev/printer
174 %attr(666,root,root) /dev/syslog
175 %attr(666,root,root) /dev/drzewo
176
177 %ifarch %{ix86}
178 %dev(c,10,184) %attr(666,root,root) /dev/cpu/microcode
179 %dev(c,10,181) %attr(666,root,root) /dev/toshiba
180 %endif
181
182 %ifarch m68k
183 %dev(b,2,4) %attr(660,root,floppy) /dev/fdhd0
184 %dev(b,2,5) %attr(660,root,floppy) /dev/fdhd1 
185 # XXX: which permissions???
186 %dev(c,10,4) %attr(664,root,root) /dev/amigamouse
187 %attr(664,root,root) /dev/mouse
188 %dev(c,10,5) %attr(664,root,root) /dev/atarimouse
189 %dev(c,10,7) %attr(664,root,root) /dev/apollomouse
190 %endif
191
192 %ifarch ppc
193 %dev(c,56,0) %attr(644,root,root) /dev/adb
194 %dev(c,10,10) %attr(644,root,root) /dev/adbmouse
195 %attr(644,root,root) /dev/mouse
196 %dev(c,10,154) %attr(644,root,root) /dev/pmu
197 %dev(c,10,198) %attr(644,root,root) /dev/sheep_net
198 %endif
199
200 %ifarch sparc
201 # XXX: which permissions ???
202 %dev(c,10,139) %attr(600,root,root) /dev/openprom
203 %dev(c,10,6) %attr(664,root,root) /dev/sunmouse
204 %attr(664,root,root) /dev/mouse
205 %endif
206
207 %ifarch m68k sparc
208 # XXX: which permissions???
209 %dev(c,11,00) %attr(600,root,root) /dev/kbd
210 %endif
211
212 %ifnarch m68k sparc
213 %dev(c,10,3) %attr(664,root,root) /dev/atibm
214 %dev(b,29,0) %attr(660,root,disk) /dev/aztcd
215 %dev(b,15,0) %attr(660,root,disk) /dev/cdu31a
216 %dev(b,24,0) %attr(660,root,disk) /dev/cdu535
217 %dev(b,32,0) %attr(660,root,disk) /dev/cm206cd
218 %dev(b,16,0) %attr(660,root,disk) /dev/gscd
219 %dev(c,10,2) %attr(664,root,root) /dev/inportbm
220 %dev(c,10,0) %attr(664,root,root) /dev/logibm
221 %dev(b,23,0) %attr(660,root,disk) /dev/mcd
222 %dev(c,10,1) %attr(664,root,root) /dev/psaux
223 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd
224 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd0
225 %dev(b,25,1) %attr(660,root,disk) /dev/sbpcd1
226 %dev(b,25,2) %attr(660,root,disk) /dev/sbpcd2
227 %dev(b,25,3) %attr(660,root,disk) /dev/sbpcd3
228 %dev(b,18,0) %attr(660,root,disk) /dev/sjcd
229 %dev(b,15,0) %attr(660,root,disk) /dev/sonycd
230 %endif
This page took 0.054238 seconds and 4 git commands to generate.