]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
s-/usr/sbin-%{_sbindir}-
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(fr):    Entrées de /dev.
3 Summary(de):    /dev-Einträge
4 Summary(pl):    Pliki specjalne /dev/*
5 Summary(tr):    /dev dizini
6 Name:           dev
7 Version:        2.7.7
8 Release:        2
9 #######         From ftp.redhat.com/rawhide
10 Source:         %{name}-%{version}.tar.gz
11 Copyright:      public domain
12 Group:          Base
13 BuildPrereq:    setup
14 # remove shadow if floppy and console group exist in setup
15 BuildPrereq:    shadow
16 Prereq:         setup
17 Buildroot:      /tmp/%{name}-%{version}-root
18 Autoreqprov:    no
19
20 %description
21 Unix and unix like systems (including Linux) use file system entries
22 to represent devices attached to the machine. All of these entries
23 are in the /dev tree (though they don't have to be), and this package
24 contains the most commonly used /dev entries. These files are essential
25 for a system to function properly.
26
27 %description -l pl
28 Wszystkie systemy Unix, jak na przyk³ad Linux, u¿ywaj± plików do przedstawienia 
29 urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki znajduj± siê zwykle w 
30 katalogu /dev. Pakiet ten zawiera wiêkszo¶æ popularnych plików specjalnych, 
31 s± one jedn± z wa¿niejszych czê¶ci prawid³owo dzia³aj±cego systemu operacyjnego.
32
33 %description -l fr
34 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
35 représenter les périphériques reliés à la machine. Toutes ces entrées
36 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
37 contient les entrées /dev les plus courantes. Elles sont essentielles
38 pour qu'un système fonctionne correctement.
39
40 %description -l tr
41 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya baðlý
42 aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel dosyalarýn tümü
43 /dev dizin yapýsý altýndadýr. Bu paket en çok kullanýlan /dev dosyalarýný
44 içerir. Bu dosyalar, bir sistemin düzgün olarak iþleyebilmesi için temel
45 gereksinimlerdendir.
46
47 %description -l de
48 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
49 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge befinden
50 sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses Paket enthält
51 die üblichsten /dev-Einträge. Diese Dateien sind für das Funktionieren
52 eines Systems unbedingt erforderlich.
53
54 %prep
55 %setup -q -c -T
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 install -d $RPM_BUILD_ROOT
61
62 #add group for floppy and console
63 # if setup contains this group then remove next 4 lines 
64 grep '^floppy:' /etc/group  >/dev/null \
65         || groupadd -g 19 -r -f floppy >/dev/null
66 grep '^console:' /etc/group >/dev/null \
67         || groupadd -g 20 -f -r console >/dev/null
68
69 # do some cleanup in build root
70 cd $RPM_BUILD_ROOT
71 tar xpSzf $RPM_SOURCE_DIR/%{name}-%{version}.tar.gz
72
73 cd dev
74
75 # tar doesn't save some permissions unless the p option is used
76 # this code protects against dev package updaters forgetting to
77 # use the p option when unpacking the souce tarball.
78 for dev in zero null tty ttyp0 ; do
79   if [ ! $(ls -l $dev | awk '{print $1}') = crw-rw-rw- ] ; then
80     echo bad permissions on device $dev 1>&2
81     exit 1
82   fi
83 done
84
85 %ifarch sparc
86 # SPARC specific devices
87 ln -s sunmouse mouse
88 mknod kbd c 11 0
89 mknod openprom c 10 139
90 chmod 666 fb*
91
92 # remove devices that will *never* exist on a SPARC
93 rm -f hd* aztcd mcd sbpcd1 cdu31a sbpcd2 scd3
94 rm -f sjcd cdu535 sbpcd3 sonycd cm206cd sbpcd
95 rm -f gscd sbpcd0 atibm inportbm logibm psaux
96
97 %endif
98
99 %ifarch m68k                                                                    
100 # m68k specific devices                                                         
101 mknod amigamouse c 10 4                                                         
102 mknod atarimouse c 10 5                                                         
103 mknod apollomouse c 10 7                                                        
104 ln -s amigamouse mouse                                                          
105 mknod fdhd0 b 2 4                                                               
106 mknod fdhd1 b 2 5                                                               
107 mknod kbd c 11 0                                                                
108 chmod 666 fb*                                                                   
109                                                                                 
110 # remove devices that will *never* exist on a m68k                              
111 rm -f hd* aztcd mcd sbpcd1 cdu31a sbpcd2 scd3                                   
112 rm -f sjcd cdu535 sbpcd3 sonycd cm206cd sbpcd                                   
113 rm -f gscd sbpcd0 atibm inportbm logibm psaux                                   
114                                                                                 
115 %endif
116
117 # Coda support 
118 mknod cfs0 c 67 0
119
120
121 ln -s fb0 fb0current
122 ln -s fb1 fb1current
123 ln -s fb2 fb2current
124 ln -s fb3 fb3current
125 ln -s fb4 fb4current
126 ln -s fb5 fb5current
127 ln -s fb6 fb6current
128 ln -s fb7 fb7current
129
130 # watchdog support
131 mknod watchdog c 10 130 
132
133 # route 
134 mknod route c 36 0
135
136 #ALSA support
137 rm -f mixer*
138 mknod mixer0 c 14 0
139 mknod mixer1 c 14 16
140 mknod mixer2 c 14 32
141 mknod mixer3 c 14 48
142 ln -s mixer0 mixer
143
144 ln -s midi00 midi
145
146 rm -f dsp*
147 mknod dsp0 c 14 3
148 mknod dsp1 c 14 19
149 mknod dsp2 c 14 35
150 mknod dsp3 c 14 51
151 ln -s dsp0 dsp
152
153 rm -f audio*
154 mknod audio0 c 14 4
155 mknod audio1 c 14 20
156 mknod audio2 c 14 36
157 mknod audio3 c 14 52
158 ln -s audio0 audio
159
160 mknod adsp0 c 14 12
161 mknod adsp1 c 14 28
162 mknod adsp2 c 14 44
163 mknod adsp3 c 14 60
164 ln -s adsp0 adsp
165
166 mknod dmfm0 c 14 10
167 mknod dmfm1 c 14 26
168 mknod dmfm2 c 14 42
169 mknod dmfm3 c 14 58
170
171 mknod dmmidi0 c 14 9
172 mknod dmmidi1 c 14 25
173 mknod dmmidi2 c 14 41
174 mknod dmmidi3 c 14 57
175
176 mknod music c 14 8
177
178 mknod admmidi0 c 14 14
179 mknod admmidi1 c 14 30 
180 mknod admmidi2 c 14 46
181 mknod admmidi3 c 14 62
182
183 mknod amidi0 c 14 13
184 mknod amidi1 c 14 29
185 mknod amidi2 c 14 45
186 mknod amidi3 c 14 61
187 ln -s amidi0 amidi
188
189 ln -s music sequencer2
190
191 #temporary
192 install -d $RPM_BUILD_ROOT/proc/asound
193 touch $RPM_BUILD_ROOT/proc/asound/snd
194
195 ln -s ../proc/asound/snd snd
196
197 # prepared for SysVinit
198 mknod initctl p
199
200 #prepared for Log Daemon
201 mkfifo --mode=666 syslog
202
203 %pre
204 # if setup contains groups floppy and console this mayby obsoletes
205 %{_sbindir}/groupadd -g 19 -r -f floppy
206 %{_sbindir}/groupadd -g 20 -r -f console
207
208 %post
209 if [ -f /etc/fstab ] ; then
210   # add /dev/pts to fstab if fstab exists (install2 does it during install)
211   if grep 'devpts' /etc/fstab >/dev/null 2>&1 ; then : ; else
212     # note that we do not disallow comments; we wish to allow people
213     # to comment it out if they so desire.
214     TMP=$(mktemp /tmp/fstab.XXXXXX)
215     sed '/\/proc/a\
216 none                    /dev/pts                devpts  mode=0622       0 0
217         ' < /etc/fstab > $TMP && mv -f $TMP /etc/fstab || { echo "failed to add devpts filesystem to /etc/fstab" 1>&2 ; exit 1 ; }
218     rm -f $TMP
219   fi
220 fi
221
222 %clean 
223 rm -rf $RPM_BUILD_ROOT
224
225 %files 
226 %defattr(644,root,root,755)
227
228 #a#
229 %attr(662,root, sys) /dev/admmidi*
230
231 %config(noreplace) %verify(not link) %attr(666,root, sys) /dev/adsp
232 %attr(662,root, sys) /dev/adsp?*
233
234 %config(noreplace) %verify(not link) %attr(662,root,root) /dev/amidi
235 %attr(662,root,root) /dev/amidi?*
236
237 %attr(664,root,root) /dev/atibm
238
239 %config(noreplace) %verify(not link) %attr(662,root, sys) /dev/audio
240 %attr(662,root, sys) /dev/audio?*
241
242 %attr(664,root,root) /dev/aztcd
243
244
245 #b#
246 %attr(664,root,root) /dev/bpcd
247
248 #c#
249 %attr(600,root,root)    /dev/capi*
250 %attr(664,root,root)    /dev/cdu31a
251 %attr(640,root,disk)    /dev/cdu535
252 %attr(600,root,root)    /dev/cfs0
253 %attr(664,root,root)    /dev/cm206cd
254 %attr(660,root,console) /dev/console
255 %attr(664,root,root)    /dev/cui*
256 %attr(600,root,root)    /dev/cum*
257
258 #d#
259 %attr(600,root,root) /dev/dcbri*
260 %attr(660,root, sys) /dev/dcxx*
261 %attr(662,root, sys) /dev/dmfm*
262 %attr(662,root, sys) /dev/dmmidi*
263 %config(noreplace) %verify(not link) %attr(662,root, sys) /dev/dsp
264 %attr(662,root, sys) /dev/dsp?*
265
266 #e#
267 %attr(600,root,root) /dev/enskip
268
269 #f#
270 %config(noreplace) %verify(not link) %attr(644,root,root)   /dev/fb
271 %attr(644,root,root)   /dev/fb?*
272 %attr(664,root,floppy) /dev/fd*
273 %config(noreplace) %verify(not link) %attr(666,root,root) /dev/ftape
274 %attr(644,root,root)   /dev/full
275
276 #g#
277 %attr(664,root,root) /dev/gscd
278
279 #h#
280 %attr(660,root,disk) /dev/hd*
281 %attr(660,root,disk) /dev/ht0
282
283 #i#
284 %attr(600,root,root) /dev/i2c*
285 %dir /dev/ida
286 %attr(660,root,disk) /dev/ida/*
287 %attr(600,root,root) /dev/initctl
288 %attr(664,root,root) /dev/inportbm
289 %attr(600,root,root) /dev/ipauth
290 %attr(600,root,root) /dev/ipl
291 %attr(600,root,root) /dev/ipnat
292 %attr(600,root,root) /dev/ippp*
293 %attr(660,root, sys) /dev/iscc*
294 %attr(600,root,root) /dev/isctl
295 %attr(600,root,root) /dev/isdn?
296 %attr(600,root,root) /dev/isdn??
297 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
298 %attr(600,root,root) /dev/isdnctrl?*
299 %attr(444,root,root) /dev/isdninfo
300
301 #j#
302 %attr(660,root, sys) /dev/js*
303
304 #k#
305 %attr(640,root,kmem) /dev/kmem
306
307 #l#
308 #%attr(666,root,root) /dev/log
309 %attr(664,root,root) /dev/logibm
310 %attr(660,root,disk) /dev/loop*
311
312 %attr(660,root,daemon) /dev/lp*
313
314 #m#
315 %attr(640,root,disk) /dev/mcd
316 %attr(640,root,kmem) /dev/mem
317 %config(noreplace) %verify(not link) %attr(662,root,sys) /dev/midi
318 %attr(662,root, sys) /dev/midi?*
319 %config(noreplace) %verify(not link) %attr(662,root,sys) /dev/mixer
320 %attr(662,root, sys) /dev/mixer?*
321 %attr(660,root, sys) /dev/mmetfgrab
322 %attr(600,root,root) /dev/mpu401*
323 %attr(662,root, sys) /dev/music
324
325 #n#
326 %attr(660,root,disk) /dev/nb*
327 %config(noreplace) %verify(not link) %attr(666,root,root) /dev/nftape
328 %attr(660,root,disk) /dev/nht*
329 %attr(660,root,disk) /dev/nqft*
330 %attr(660,root,disk) /dev/nrawqft*
331 %attr(660,root,disk) /dev/nrft*
332 %attr(660,root,disk) /dev/nst*
333 %attr(660,root,disk) /dev/ntpqic*
334 %attr(666,root,root) /dev/null
335 %attr(660,root,disk) /dev/nzqft*
336
337 #o#
338 %attr(664,root,root) /dev/optcd
339
340 #p#
341 %attr(640,root,daemon) /dev/par?
342 %attr(660,root,daemon) /dev/parport*
343
344 %attr(660,root,disk) /dev/pcd*
345 %attr(660,root,disk) /dev/pd*
346 %attr(660,root,disk) /dev/pf*
347 %attr(600,root,root) /dev/pg*
348
349 %attr(640,root,kmem) /dev/port
350 %attr(600,root,root) /dev/printer
351 %attr(664,root,root) /dev/psaux
352
353 %attr(660,root,disk) /dev/pt0
354 %attr(660,root,disk) /dev/pt1
355 %attr(660,root,disk) /dev/pt2
356 %attr(660,root,disk) /dev/pt3
357
358 %attr(666,root, tty) /dev/ptmx
359 %attr(666,root, tty) /dev/pty*
360 %dir /dev/pts
361
362 #r#
363 %attr(640,root,disk) /dev/ram
364 %attr(660,root,disk) /dev/ram0
365 %attr(660,root,disk) /dev/ram1*
366 %attr(660,root,disk) /dev/ram2
367 %attr(660,root,disk) /dev/ram3
368 %attr(660,root,disk) /dev/ram4
369 %attr(660,root,disk) /dev/ram5
370 %attr(660,root,disk) /dev/ram6
371 %attr(660,root,disk) /dev/ram7
372 %attr(660,root,disk) /dev/ram8
373 %attr(660,root,disk) /dev/ram9
374
375 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
376
377 %attr(644,root,root) /dev/random
378 %attr(660,root,disk) /dev/rawqft*
379 %attr(660,root,disk) /dev/rft*
380 %attr(660,root, sys) /dev/rmidi*
381 %attr(660,root,disk) /dev/rmt*
382 %attr(644,root,root) /dev/route
383 %attr(664,root,root) /dev/rtc
384 %dir /dev/rd
385 %attr(660,root,disk) /dev/rd/*
386
387 #s#
388 %attr(640,root,disk) /dev/sbpc*
389 %attr(660,root,disk) /dev/scd*
390 %attr(660,root,disk) /dev/sd*
391
392 %attr(662,root,sys)  /dev/sequencer
393 %attr(662,root,sys)  /dev/sequencer2
394
395 %attr(600,root,root) /dev/sg*
396 %attr(664,root,root) /dev/sjcd
397 %attr(600,root,root) /dev/smtpe*
398
399 %attr(444,root,root) /dev/snd
400 %attr(666,root,root) /dev/sndstat
401
402 %attr(640,root,disk) /dev/sonycd
403
404 %attr(600,root,root) /dev/srnd*
405
406 %attr(660,root,disk) /dev/st?
407 %attr(600,root,root) /dev/staliomem*
408 %attr(666,root,root) /dev/std*
409
410 %attr(664,root,root) /dev/sunmouse
411 %attr(666,root,root) /dev/syslog
412 %attr(600,root,root) /dev/systty
413
414 #t#
415 %attr(660,root,disk) /dev/tape*
416 %attr(600,root,root) /dev/tlk*
417 %attr(660,root,disk) /dev/tpqic*
418
419 %attr(666,root,root) /dev/tty
420
421 %attr(600,root, tty) /dev/tty0
422 %attr(600,root, tty) /dev/tty1*
423 %attr(600,root, tty) /dev/tty2
424 %attr(600,root, tty) /dev/tty3
425 %attr(600,root, tty) /dev/tty4
426 %attr(600,root, tty) /dev/tty5
427 %attr(600,root, tty) /dev/tty6
428 %attr(600,root, tty) /dev/tty7
429 %attr(600,root, tty) /dev/tty8
430 %attr(600,root, tty) /dev/tty9
431
432 %attr(600,root,root) /dev/ttyC*
433 %attr(600,root,root) /dev/ttyD*
434 %attr(600,root,root) /dev/ttyE*
435 %attr(600,root,root) /dev/ttyI*
436 %attr(600,root,root) /dev/ttyM*
437 %attr(600,root,root) /dev/ttyP*
438 %attr(600,root,root) /dev/ttyR*
439
440 %attr(644,root,root) /dev/ttyS*
441
442 %attr(666,root, tty) /dev/ttya*
443 %attr(666,root, tty) /dev/ttyb*
444 %attr(666,root, tty) /dev/ttyc*
445 %attr(666,root, tty) /dev/ttyd*
446 %attr(666,root, tty) /dev/ttye*
447 %attr(666,root, tty) /dev/ttyp*
448 %attr(666,root, tty) /dev/ttyq*
449 %attr(666,root, tty) /dev/ttyr*
450 %attr(666,root, tty) /dev/ttys*
451 %attr(666,root, tty) /dev/ttyt*
452 %attr(666,root, tty) /dev/ttyu*
453 %attr(666,root, tty) /dev/ttyv*
454 %attr(666,root, tty) /dev/ttyw*
455 %attr(666,root, tty) /dev/ttyx*
456 %attr(666,root, tty) /dev/ttyy*
457 %attr(666,root, tty) /dev/ttyz*
458
459 #u#
460 %attr(644,root,root) /dev/urandom
461
462 #v#
463 %attr(620,root,tty) /dev/vcs*
464
465 #w#
466 %attr(600,root,root) /dev/watchdog
467 %attr(660,root, sys) /dev/wvisfgrab
468
469 #x#
470 %attr(660,root,disk) /dev/xd*
471
472 #y#
473
474 #z#
475 %attr(666,root,root) /dev/zero
476 %attr(660,root,disk) /dev/zqft*
477
478 %changelog
479 * Thu Apr 29 1999 Artur Wiget <wiget@pld.org.pl>
480   [2.7.7-2]
481 - upgrade to 2.7.7  
482 - removed creating already created devices
483 - added more devices in %%files
484
485 * Mon Apr 27 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
486   [2.7.3-2]
487 - added /dev/initctl,
488 - added pts device to /etc/fstab,
489 - added /dev/syslog.
490
491 * Mon Apr 26 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
492   [2.7.3-1]
493 - upgrade to 2.7.3,
494 - removed /dev/log, /dev/cua[0-3].
495
496 * Tue Apr 20 1999 Artur Frysiak <wiget@pld.org.pl>
497   [2.5.9-3]
498 - compiled on rpm 3
499 - fixed framebuffer support
500 - added coda support
501
502 * Sat Dec 12 1998 Sergiusz Paw³owicz <ser@hyperreal.art.pl>
503   [2.5.9-1d]
504 - added polish translation to spec (regards to PLD Team),
505 - added handles to Unix98 pty support,
506 - added handles to framebuffer support,
507 - revised spec file, adding group 'floppy' removed.
508 - removed initctl -- SysVinit provides it.
509 - start at RH spec file.
This page took 0.066595 seconds and 4 git commands to generate.