]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
- Release 5.
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(de.UTF-8):      /dev-Einträge
3 Summary(fr.UTF-8):      Entrées de /dev
4 Summary(pl.UTF-8):      Pliki specjalne /dev/*
5 Summary(tr.UTF-8):      /dev dizini
6 Name:           dev
7 Version:        3.4
8 Release:        5
9 License:        Public Domain
10 Group:          Base
11 Source0:        %{name}-list
12 Requires:       setup >= 2.6.1-1
13 Provides:       devfs
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Unix and Unix-like systems (including Linux) use file system entries
18 to represent devices attached to the machine. All of these entries are
19 in the /dev tree (though they don't have to be), and this package
20 contains the most commonly used /dev entries. These files are
21 essential for a system to function properly.
22
23 %description -l de.UTF-8
24 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
25 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge
26 befinden sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses
27 Paket enthält die üblichsten /dev-Einträge. Diese Dateien sind für das
28 Funktionieren eines Systems unbedingt erforderlich.
29
30 %description -l fr.UTF-8
31 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
32 représenter les périphériques reliés à la machine. Toutes ces entrées
33 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
34 contient les entrées /dev les plus courantes. Elles sont essentielles
35 pour qu'un système fonctionne correctement.
36
37 %description -l pl.UTF-8
38 Wszystkie systemy klasy unices, w tym Linux, używają plików do
39 przedstawiania urządzeń podłączonych do komputera. Wszystkie te pliki
40 znajdują się zwykle w katalogu /dev. Pakiet ten zawiera większość
41 popularnych plików specjalnych, są one jedną z ważniejszych części
42 prawidłowo działającego systemu operacyjnego.
43
44 %description -l tr.UTF-8
45 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya
46 bağlı aygıtları göstermek için özel dosyalar kullanırlar. Bu özel
47 dosyaların tümü /dev dizin yapısı altındadır. Bu paket en çok
48 kullanılan /dev dosyalarını içerir. Bu dosyalar, bir sistemin düzgün
49 olarak işleyebilmesi için temel gereksinimlerdendir.
50
51 %prep
52 %setup -q -c -T
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT/dev/{ataraid,cciss,cdemu,cdroms,cpu/{0,1,2,3,4,5,6,7},cpuset} \
57         $RPM_BUILD_ROOT/dev/{discs,dri,etherd,i2o,ida,input,mapper,net,pts,raw,rd,usb,shm,snd,zap}
58
59 install %{SOURCE0} .
60
61 cd $RPM_BUILD_ROOT/dev
62 ln -sf adsp0 adsp
63 ln -sf amidi0 amidi
64 ln -sf audio0 audio
65 ln -sf dsp0 dsp
66 ln -sf fb0 fb
67 ln -sf rft0 ftape
68 ln -sf isdnctrl0 isdnctrl
69 ln -sf midi00 midi
70 ln -sf mixer0 mixer
71 ln -sf nrft0 nftape
72 ln -sf ram0 ramdisk
73
74 ln -sf em8300-0         em8300
75 ln -sf em8300_ma-0      em8300_ma
76 ln -sf em8300_mv-0      em8300_mv
77 ln -sf em8300_sp-0      em8300_sp
78 for i in `seq 0 31`; do
79         ln -sf fb$i fb${i}current
80 done
81 ln -sf /proc/self/fd fd
82 ln -sf fd/0 stdin
83 ln -sf fd/1 stdout
84 ln -sf fd/2 stderr
85 i=0;
86 for l in a b c d e f g h; do
87         ln -sf sg$l sg$i
88         i=$((i+1))
89 done
90 ln -sf radio0 radio
91 ln -sf music sequencer2
92 ln -sf vbi0 vbi
93 ln -sf video0 video
94 ln -sf vtx0 vtx
95
96 # prepared for SysVinit
97 mkfifo initctl
98
99 mkfifo lircm
100 mkfifo printer
101
102 # prepared for Log Daemon
103 mkfifo syslog
104
105 %ifarch m68k
106 ln -sf amigamouse mouse
107 %endif
108
109 %ifarch ppc
110 ln -sf adbmouse mouse
111 %endif
112
113 %ifarch sparc sparc64 sparcv9
114 ln -sf sunmouse mouse
115 %endif
116
117 # PLD-forklor:
118 ln -sf null drzewo
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files -f dev-list
124 %defattr(644,root,root,755)
125 %dir /dev/ataraid
126 %dir /dev/cciss
127 %dir /dev/cdemu
128 %dir /dev/cpu
129 %dir /dev/cpu/0
130 %dir /dev/cpu/1
131 %dir /dev/cpu/2
132 %dir /dev/cpu/3
133 %dir /dev/cpu/4
134 %dir /dev/cpu/5
135 %dir /dev/cpu/6
136 %dir /dev/cpu/7
137 %dir /dev/cpuset
138 %dir /dev/dri
139 %attr(750,root,disk) %dir /dev/cdroms
140 %attr(750,root,disk) %dir /dev/discs
141 %dir /dev/etherd
142 %dir /dev/i2o
143 %dir /dev/ida
144 %dir /dev/input
145 %dir /dev/mapper
146 %dir /dev/net
147 %dir /dev/pts
148 %dir /dev/raw
149 %dir /dev/rd
150 %dir /dev/usb
151 %dir /dev/zap
152 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/adsp
153 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/amidi
154 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/audio
155 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/dsp
156 %config(noreplace) %verify(not link) %attr(660,root,video) /dev/fb
157 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ftape
158 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
159 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/midi
160 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/mixer
161 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/nftape
162 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
163 %attr(660,root,video) /dev/em8300*
164 %attr(660,root,video) /dev/fb[0-9]*current
165 /dev/fd
166 /dev/stdin
167 /dev/stdout
168 /dev/stderr
169 %attr(660,root,video) /dev/radio
170 %attr(660,root,audio) /dev/sequencer2
171 %attr(600,root,root) /dev/sg[0-7]
172 %attr(666,root,root) %dir /dev/shm
173 %dir /dev/snd
174 %attr(660,root,video) /dev/vbi
175 %attr(660,root,video) /dev/video
176 %attr(660,root,video) /dev/vtx
177 %attr(600,root,root) /dev/initctl
178 %attr(660,root,root) /dev/lircm
179 %attr(600,root,root) /dev/printer
180 %attr(666,root,root) /dev/syslog
181 %attr(666,root,root) /dev/drzewo
182
183 %ifarch %{ix86}
184 %dev(c,10,181) %attr(666,root,root) /dev/toshiba
185 %dev(c,212,0) %attr(600,root,root) /dev/slamr0
186 %dev(c,213,0) %attr(600,root,root) /dev/slusb0
187 %dev(c,226,0) %attr(660,root,video) /dev/dri/card0
188 %dev(c,226,1) %attr(660,root,video) /dev/dri/card1
189 %dev(c,226,2) %attr(660,root,video) /dev/dri/card2
190 %dev(c,226,3) %attr(660,root,video) /dev/dri/card3
191 %dev(c,226,4) %attr(660,root,video) /dev/dri/card4
192 %dev(c,226,5) %attr(660,root,video) /dev/dri/card5
193 %dev(c,226,6) %attr(660,root,video) /dev/dri/card6
194 %dev(c,226,7) %attr(660,root,video) /dev/dri/card7
195 %endif
196
197 %ifarch %{ix86} %{x8664}
198 %dev(c,10,227) %attr(600,root,root) /dev/mcelog
199 %dev(c,10,184) %attr(666,root,root) /dev/cpu/microcode
200 %endif
201
202 %ifarch m68k
203 %dev(b,2,4) %attr(660,root,floppy) /dev/fdhd0
204 %dev(b,2,5) %attr(660,root,floppy) /dev/fdhd1
205 # XXX: which permissions???
206 %dev(c,10,4) %attr(664,root,root) /dev/amigamouse
207 %attr(664,root,root) /dev/mouse
208 %dev(c,10,5) %attr(664,root,root) /dev/atarimouse
209 %dev(c,10,7) %attr(664,root,root) /dev/apollomouse
210 %endif
211
212 %ifarch ppc
213 %dev(c,56,0) /dev/adb
214 %dev(c,10,10) /dev/adbmouse
215 /dev/mouse
216 %dev(c,10,154) /dev/pmu
217 %dev(c,10,198) /dev/sheep_net
218 %endif
219
220 %ifarch sparc sparc64 sparcv9
221 %dev(c,14,7) %attr(660,root,audio) /dev/audioctl
222 # XXX: which permissions ???
223 %dev(c,10,139) %attr(600,root,root) /dev/openprom
224 %dev(c,10,6) %attr(664,root,root) /dev/sunmouse
225 %attr(664,root,root) /dev/mouse
226 %endif
227
228 %ifarch m68k sparc sparc64 sparcv9
229 # XXX: which permissions???
230 %dev(c,11,00) %attr(600,root,root) /dev/kbd
231 %endif
232
233 %ifnarch m68k sparc sparc64 sparcv9
234 %dev(c,10,3) %attr(664,root,root) /dev/atibm
235 %dev(b,29,0) %attr(660,root,disk) /dev/aztcd
236 %dev(b,15,0) %attr(660,root,disk) /dev/cdu31a
237 %dev(b,24,0) %attr(660,root,disk) /dev/cdu535
238 %dev(b,32,0) %attr(660,root,disk) /dev/cm206cd
239 %dev(b,16,0) %attr(660,root,disk) /dev/gscd
240 %dev(c,10,2) %attr(664,root,root) /dev/inportbm
241 %dev(c,10,0) %attr(664,root,root) /dev/logibm
242 %dev(b,23,0) %attr(660,root,disk) /dev/mcd
243 %dev(c,10,1) %attr(664,root,root) /dev/psaux
244 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd
245 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd0
246 %dev(b,25,1) %attr(660,root,disk) /dev/sbpcd1
247 %dev(b,25,2) %attr(660,root,disk) /dev/sbpcd2
248 %dev(b,25,3) %attr(660,root,disk) /dev/sbpcd3
249 %dev(b,18,0) %attr(660,root,disk) /dev/sjcd
250 %dev(b,15,0) %attr(660,root,disk) /dev/sonycd
251 %endif
This page took 0.042234 seconds and 4 git commands to generate.