]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
- added /dev/kmsg, rel. 9
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(de.UTF-8):      /dev-Einträge
3 Summary(fr.UTF-8):      Entrées de /dev
4 Summary(pl.UTF-8):      Pliki specjalne /dev/*
5 Summary(tr.UTF-8):      /dev dizini
6 Name:           dev
7 Version:        3.4
8 Release:        9
9 License:        Public Domain
10 Group:          Base
11 Source0:        %{name}-list
12 Requires:       setup >= 2.6.1-1
13 Provides:       devfs
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Unix and Unix-like systems (including Linux) use file system entries
18 to represent devices attached to the machine. All of these entries are
19 in the /dev tree (though they don't have to be), and this package
20 contains the most commonly used /dev entries. These files are
21 essential for a system to function properly.
22
23 %description -l de.UTF-8
24 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
25 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge
26 befinden sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses
27 Paket enthält die üblichsten /dev-Einträge. Diese Dateien sind für das
28 Funktionieren eines Systems unbedingt erforderlich.
29
30 %description -l fr.UTF-8
31 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
32 représenter les périphériques reliés à la machine. Toutes ces entrées
33 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
34 contient les entrées /dev les plus courantes. Elles sont essentielles
35 pour qu'un système fonctionne correctement.
36
37 %description -l pl.UTF-8
38 Wszystkie systemy klasy unices, w tym Linux, używają plików do
39 przedstawiania urządzeń podłączonych do komputera. Wszystkie te pliki
40 znajdują się zwykle w katalogu /dev. Pakiet ten zawiera większość
41 popularnych plików specjalnych, są one jedną z ważniejszych części
42 prawidłowo działającego systemu operacyjnego.
43
44 %description -l tr.UTF-8
45 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya
46 bağlı aygıtları göstermek için özel dosyalar kullanırlar. Bu özel
47 dosyaların tümü /dev dizin yapısı altındadır. Bu paket en çok
48 kullanılan /dev dosyalarını içerir. Bu dosyalar, bir sistemin düzgün
49 olarak işleyebilmesi için temel gereksinimlerdendir.
50
51 %prep
52 %setup -q -c -T
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT/dev/{ataraid,cciss,cdemu,cdroms,cpu/{0,1,2,3,4,5,6,7},cgroup,cpuset} \
57         $RPM_BUILD_ROOT/dev/{discs,dri,etherd,i2o,ida,input,mapper,net,pts,raw,rd,usb,shm,snd,zap}
58
59 install %{SOURCE0} .
60
61 cd $RPM_BUILD_ROOT/dev
62 ln -sf adsp0 adsp
63 ln -sf amidi0 amidi
64 ln -sf audio0 audio
65 ln -sf dsp0 dsp
66 ln -sf fb0 fb
67 ln -sf rft0 ftape
68 ln -sf isdnctrl0 isdnctrl
69 ln -sf midi00 midi
70 ln -sf mixer0 mixer
71 ln -sf nrft0 nftape
72 ln -sf ram0 ramdisk
73
74 ln -sf em8300-0         em8300
75 ln -sf em8300_ma-0      em8300_ma
76 ln -sf em8300_mv-0      em8300_mv
77 ln -sf em8300_sp-0      em8300_sp
78 for i in `seq 0 31`; do
79         ln -sf fb$i fb${i}current
80 done
81 ln -sf /proc/self/fd fd
82 ln -sf fd/0 stdin
83 ln -sf fd/1 stdout
84 ln -sf fd/2 stderr
85 i=0;
86 for l in a b c d e f g h; do
87         ln -sf sg$l sg$i
88         i=$((i+1))
89 done
90 ln -sf radio0 radio
91 ln -sf music sequencer2
92 ln -sf vbi0 vbi
93 ln -sf video0 video
94 ln -sf vtx0 vtx
95
96 # prepared for SysVinit
97 mkfifo initctl
98
99 mkfifo lircm
100 mkfifo printer
101
102 # prepared for Log Daemon
103 mkfifo syslog
104
105 %ifarch m68k
106 ln -sf amigamouse mouse
107 %endif
108
109 %ifarch ppc
110 ln -sf adbmouse mouse
111 %endif
112
113 %ifarch sparc sparc64 sparcv9
114 ln -sf sunmouse mouse
115 %endif
116
117 # PLD-forklor:
118 ln -sf null drzewo
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files -f dev-list
124 %defattr(644,root,root,755)
125 %dir /dev/ataraid
126 %dir /dev/cciss
127 %dir /dev/cdemu
128 %dir /dev/cgroup
129 %dir /dev/cpu
130 %dir /dev/cpu/0
131 %dir /dev/cpu/1
132 %dir /dev/cpu/2
133 %dir /dev/cpu/3
134 %dir /dev/cpu/4
135 %dir /dev/cpu/5
136 %dir /dev/cpu/6
137 %dir /dev/cpu/7
138 %dir /dev/cpuset
139 %dir /dev/dri
140 %attr(750,root,disk) %dir /dev/cdroms
141 %attr(750,root,disk) %dir /dev/discs
142 %dir /dev/etherd
143 %dir /dev/i2o
144 %dir /dev/ida
145 %dir /dev/input
146 %dir /dev/mapper
147 %dir /dev/net
148 %dir /dev/pts
149 %dir /dev/raw
150 %dir /dev/rd
151 %dir /dev/usb
152 %dir /dev/zap
153 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/adsp
154 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/amidi
155 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/audio
156 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/dsp
157 %config(noreplace) %verify(not link) %attr(660,root,video) /dev/fb
158 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ftape
159 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
160 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/midi
161 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/mixer
162 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/nftape
163 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
164 %attr(660,root,video) /dev/em8300*
165 %attr(660,root,video) /dev/fb[0-9]*current
166 /dev/fd
167 /dev/stdin
168 /dev/stdout
169 /dev/stderr
170 %attr(660,root,video) /dev/radio
171 %attr(660,root,audio) /dev/sequencer2
172 %attr(600,root,root) /dev/sg[0-7]
173 %attr(1777,root,root) %dir /dev/shm
174 %dir /dev/snd
175 %attr(660,root,video) /dev/vbi
176 %attr(660,root,video) /dev/video
177 %attr(660,root,video) /dev/vtx
178 %attr(600,root,root) /dev/initctl
179 %attr(660,root,root) /dev/lircm
180 %attr(600,root,root) /dev/printer
181 %attr(666,root,root) /dev/syslog
182 %attr(666,root,root) /dev/drzewo
183
184 %ifarch %{ix86}
185 %dev(c,10,181) %attr(666,root,root) /dev/toshiba
186 %dev(c,212,0) %attr(600,root,root) /dev/slamr0
187 %dev(c,213,0) %attr(600,root,root) /dev/slusb0
188 %dev(c,226,0) %attr(660,root,video) /dev/dri/card0
189 %dev(c,226,1) %attr(660,root,video) /dev/dri/card1
190 %dev(c,226,2) %attr(660,root,video) /dev/dri/card2
191 %dev(c,226,3) %attr(660,root,video) /dev/dri/card3
192 %dev(c,226,4) %attr(660,root,video) /dev/dri/card4
193 %dev(c,226,5) %attr(660,root,video) /dev/dri/card5
194 %dev(c,226,6) %attr(660,root,video) /dev/dri/card6
195 %dev(c,226,7) %attr(660,root,video) /dev/dri/card7
196 %endif
197
198 %ifarch %{ix86} %{x8664}
199 %dev(c,10,227) %attr(600,root,root) /dev/mcelog
200 %dev(c,10,184) %attr(666,root,root) /dev/cpu/microcode
201 %endif
202
203 %ifarch m68k
204 %dev(b,2,4) %attr(660,root,floppy) /dev/fdhd0
205 %dev(b,2,5) %attr(660,root,floppy) /dev/fdhd1
206 # XXX: which permissions???
207 %dev(c,10,4) %attr(664,root,root) /dev/amigamouse
208 %attr(664,root,root) /dev/mouse
209 %dev(c,10,5) %attr(664,root,root) /dev/atarimouse
210 %dev(c,10,7) %attr(664,root,root) /dev/apollomouse
211 %endif
212
213 %ifarch ppc
214 %dev(c,56,0) /dev/adb
215 %dev(c,10,10) /dev/adbmouse
216 /dev/mouse
217 %dev(c,10,154) /dev/pmu
218 %dev(c,10,198) /dev/sheep_net
219 %endif
220
221 %ifarch sparc sparc64 sparcv9
222 %dev(c,14,7) %attr(660,root,audio) /dev/audioctl
223 # XXX: which permissions ???
224 %dev(c,10,139) %attr(600,root,root) /dev/openprom
225 %dev(c,10,6) %attr(664,root,root) /dev/sunmouse
226 %attr(664,root,root) /dev/mouse
227 %endif
228
229 %ifarch m68k sparc sparc64 sparcv9
230 # XXX: which permissions???
231 %dev(c,11,00) %attr(600,root,root) /dev/kbd
232 %endif
233
234 %ifnarch m68k sparc sparc64 sparcv9
235 %dev(c,10,3) %attr(664,root,root) /dev/atibm
236 %dev(b,29,0) %attr(660,root,disk) /dev/aztcd
237 %dev(b,15,0) %attr(660,root,disk) /dev/cdu31a
238 %dev(b,24,0) %attr(660,root,disk) /dev/cdu535
239 %dev(b,32,0) %attr(660,root,disk) /dev/cm206cd
240 %dev(b,16,0) %attr(660,root,disk) /dev/gscd
241 %dev(c,10,2) %attr(664,root,root) /dev/inportbm
242 %dev(c,10,0) %attr(664,root,root) /dev/logibm
243 %dev(b,23,0) %attr(660,root,disk) /dev/mcd
244 %dev(c,10,1) %attr(664,root,root) /dev/psaux
245 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd
246 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd0
247 %dev(b,25,1) %attr(660,root,disk) /dev/sbpcd1
248 %dev(b,25,2) %attr(660,root,disk) /dev/sbpcd2
249 %dev(b,25,3) %attr(660,root,disk) /dev/sbpcd3
250 %dev(b,18,0) %attr(660,root,disk) /dev/sjcd
251 %dev(b,15,0) %attr(660,root,disk) /dev/sonycd
252 %endif
This page took 0.077467 seconds and 3 git commands to generate.