]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
- added vroot devices
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(de):    /dev-Einträge
3 Summary(fr):    Entrées de /dev
4 Summary(pl):    Pliki specjalne /dev/*
5 Summary(tr):    /dev dizini
6 Name:           dev
7 Version:        2.9.0
8 Release:        23
9 License:        Public Domain
10 Group:          Base
11 Source0:        %{name}-list
12 PreReq:         setup >= 2.4.8
13 Provides:       devfs
14 AutoReqProv:    no
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Unix and unix like systems (including Linux) use file system entries
19 to represent devices attached to the machine. All of these entries are
20 in the /dev tree (though they don't have to be), and this package
21 contains the most commonly used /dev entries. These files are
22 essential for a system to function properly.
23
24 %description -l de
25 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
26 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge
27 befinden sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses
28 Paket enthält die üblichsten /dev-Einträge. Diese Dateien sind für das
29 Funktionieren eines Systems unbedingt erforderlich.
30
31 %description -l fr
32 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
33 représenter les périphériques reliés à la machine. Toutes ces entrées
34 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
35 contient les entrées /dev les plus courantes. Elles sont essentielles
36 pour qu'un système fonctionne correctement.
37
38 %description -l pl
39 Wszystkie systemy klasy unices, w tym Linux, u¿ywaj± plików do
40 przedstawiania urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki
41 znajduj± siê zwykle w katalogu /dev. Pakiet ten zawiera wiêkszo¶æ
42 popularnych plików specjalnych, s± one jedn± z wa¿niejszych czê¶ci
43 prawid³owo dzia³aj±cego systemu operacyjnego.
44
45 %description -l tr
46 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya
47 baðlý aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel
48 dosyalarýn tümü /dev dizin yapýsý altýndadýr. Bu paket en çok
49 kullanýlan /dev dosyalarýný içerir. Bu dosyalar, bir sistemin düzgün
50 olarak iþleyebilmesi için temel gereksinimlerdendir.
51
52 %prep
53 %setup -q -c -T
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT/dev/{ataraid,cciss,cdroms,cpu/{0,1,2,3,4,5,6,7}} \
58         $RPM_BUILD_ROOT/dev/{discs,i2o,ida,input,net,pts,raw,rd,usb,shm,snd,zap} \
59         $RPM_BUILD_ROOT/dev/{mapper,dri,cdemu,cpuset}
60
61 install %{SOURCE0} .
62
63 cd $RPM_BUILD_ROOT/dev
64 ln -sf adsp0 adsp
65 ln -sf amidi0 amidi
66 ln -sf audio0 audio
67 ln -sf dsp0 dsp
68 ln -sf fb0 fb
69 ln -sf rft0 ftape
70 ln -sf isdnctrl0 isdnctrl
71 ln -sf midi00 midi
72 ln -sf mixer0 mixer
73 ln -sf nrft0 nftape
74 ln -sf ram0 ramdisk
75
76 ln -sf em8300-0         em8300
77 ln -sf em8300_ma-0      em8300_ma
78 ln -sf em8300_mv-0      em8300_mv
79 ln -sf em8300_sp-0      em8300_sp
80 for i in `seq 0 31`; do
81         ln -sf fb$i fb${i}current
82 done
83 ln -sf /proc/self/fd fd
84 ln -sf fd/0 stdin
85 ln -sf fd/1 stdout
86 ln -sf fd/2 stderr
87 i=0;
88 for l in a b c d e f g h; do
89         ln -sf sg$l sg$i
90         i=$((i+1))
91 done
92 ln -sf radio0 radio
93 ln -sf music sequencer2
94 ln -sf vbi0 vbi
95 ln -sf video0 video
96 ln -sf vtx0 vtx
97
98 # prepared for SysVinit
99 mkfifo initctl
100
101 mkfifo lircm
102 mkfifo printer
103
104 # prepared for Log Daemon
105 mkfifo syslog
106
107 %ifarch m68k
108 ln -sf amigamouse mouse
109 %endif
110
111 %ifarch ppc
112 ln -sf adbmouse mouse
113 %endif
114
115 %ifarch sparc sparc64 sparcv9
116 ln -sf sunmouse mouse
117 %endif
118
119 # PLD-forklor:
120 ln -sf null drzewo
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files -f dev-list
126 %defattr(644,root,root,755)
127 %dir /dev/cpu
128 %dir /dev/cpu/0
129 %dir /dev/cpu/1
130 %dir /dev/cpu/2
131 %dir /dev/cpu/3
132 %dir /dev/cpu/4
133 %dir /dev/cpu/5
134 %dir /dev/cpu/6
135 %dir /dev/cpu/7
136 %dir /dev/cpuset
137 %dir /dev/ataraid
138 %dir /dev/cciss
139 %dir /dev/dri
140 %attr(750,root,disk) %dir /dev/cdroms
141 %attr(750,root,disk) %dir /dev/discs
142 %dir /dev/i2o
143 %dir /dev/ida
144 %dir /dev/input
145 %dir /dev/net
146 %dir /dev/pts
147 %dir /dev/raw
148 %dir /dev/rd
149 %dir /dev/usb
150 %dir /dev/mapper
151 %dir /dev/zap
152 %dir /dev/cdemu
153 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/adsp
154 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/amidi
155 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/audio
156 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/dsp
157 %config(noreplace) %verify(not link) %attr(660,root,video) /dev/fb
158 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ftape
159 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
160 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/midi
161 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/mixer
162 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/nftape
163 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
164 %attr(660,root,video) /dev/em8300*
165 %attr(660,root,video) /dev/fb[0-9]*current
166 /dev/fd
167 /dev/stdin
168 /dev/stdout
169 /dev/stderr
170 %attr(660,root,video) /dev/radio
171 %attr(660,root,audio) /dev/sequencer2
172 %attr(600,root,root) /dev/sg[0-7]
173 %dir /dev/shm
174 %dir /dev/snd
175 %attr(660,root,video) /dev/vbi
176 %attr(660,root,video) /dev/video
177 %attr(660,root,video) /dev/vtx
178 %attr(600,root,root) /dev/initctl
179 %attr(660,root,root) /dev/lircm
180 %attr(600,root,root) /dev/printer
181 %attr(666,root,root) /dev/syslog
182 %attr(666,root,root) /dev/drzewo
183
184 %ifarch %{ix86}
185 %dev(c,10,184) %attr(666,root,root) /dev/cpu/microcode
186 %dev(c,10,181) %attr(666,root,root) /dev/toshiba
187 %dev(c,212,0) %attr(600,root,root) /dev/slamr0
188 %dev(c,213,0) %attr(600,root,root) /dev/slusb0
189 %dev(c,226,0) %attr(660,root,video) /dev/dri/card0
190 %dev(c,226,1) %attr(660,root,video) /dev/dri/card1
191 %dev(c,226,2) %attr(660,root,video) /dev/dri/card2
192 %dev(c,226,3) %attr(660,root,video) /dev/dri/card3
193 %dev(c,226,4) %attr(660,root,video) /dev/dri/card4
194 %dev(c,226,5) %attr(660,root,video) /dev/dri/card5
195 %dev(c,226,6) %attr(660,root,video) /dev/dri/card6
196 %dev(c,226,7) %attr(660,root,video) /dev/dri/card7
197 %endif
198
199 %ifarch %{ix86} %{x8664}
200 %dev(c,10,227) %attr(600,root,root) /dev/mcelog
201 %endif
202
203 %ifarch m68k
204 %dev(b,2,4) %attr(660,root,floppy) /dev/fdhd0
205 %dev(b,2,5) %attr(660,root,floppy) /dev/fdhd1
206 # XXX: which permissions???
207 %dev(c,10,4) %attr(664,root,root) /dev/amigamouse
208 %attr(664,root,root) /dev/mouse
209 %dev(c,10,5) %attr(664,root,root) /dev/atarimouse
210 %dev(c,10,7) %attr(664,root,root) /dev/apollomouse
211 %endif
212
213 %ifarch ppc
214 %dev(c,56,0) %attr(644,root,root) /dev/adb
215 %dev(c,10,10) %attr(644,root,root) /dev/adbmouse
216 %attr(644,root,root) /dev/mouse
217 %dev(c,10,154) %attr(644,root,root) /dev/pmu
218 %dev(c,10,198) %attr(644,root,root) /dev/sheep_net
219 %endif
220
221 %ifarch sparc sparc64 sparcv9
222 %dev(c,14,7) %attr(660,root,audio) /dev/audioctl
223 # XXX: which permissions ???
224 %dev(c,10,139) %attr(600,root,root) /dev/openprom
225 %dev(c,10,6) %attr(664,root,root) /dev/sunmouse
226 %attr(664,root,root) /dev/mouse
227 %endif
228
229 %ifarch m68k sparc sparc64 sparcv9
230 # XXX: which permissions???
231 %dev(c,11,00) %attr(600,root,root) /dev/kbd
232 %endif
233
234 %ifnarch m68k sparc sparc64 sparcv9
235 %dev(c,10,3) %attr(664,root,root) /dev/atibm
236 %dev(b,29,0) %attr(660,root,disk) /dev/aztcd
237 %dev(b,15,0) %attr(660,root,disk) /dev/cdu31a
238 %dev(b,24,0) %attr(660,root,disk) /dev/cdu535
239 %dev(b,32,0) %attr(660,root,disk) /dev/cm206cd
240 %dev(b,16,0) %attr(660,root,disk) /dev/gscd
241 %dev(c,10,2) %attr(664,root,root) /dev/inportbm
242 %dev(c,10,0) %attr(664,root,root) /dev/logibm
243 %dev(b,23,0) %attr(660,root,disk) /dev/mcd
244 %dev(c,10,1) %attr(664,root,root) /dev/psaux
245 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd
246 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd0
247 %dev(b,25,1) %attr(660,root,disk) /dev/sbpcd1
248 %dev(b,25,2) %attr(660,root,disk) /dev/sbpcd2
249 %dev(b,25,3) %attr(660,root,disk) /dev/sbpcd3
250 %dev(b,18,0) %attr(660,root,disk) /dev/sjcd
251 %dev(b,15,0) %attr(660,root,disk) /dev/sonycd
252 %endif
This page took 0.042943 seconds and 3 git commands to generate.