]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
- added few missing devices from pre-%%dev spec to dev-list, release 2
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(de):    /dev-Einträge
3 Summary(fr):    Entrées de /dev
4 Summary(pl):    Pliki specjalne /dev/*
5 Summary(tr):    /dev dizini
6 Name:           dev
7 Version:        2.9.0
8 Release:        2
9 License:        Public Domain
10 Group:          Base
11 Source0:        dev-list
12 PreReq:         setup >= 2.4.1-2
13 Provides:       devfs
14 AutoReqProv:    no
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Unix and unix like systems (including Linux) use file system entries
19 to represent devices attached to the machine. All of these entries are
20 in the /dev tree (though they don't have to be), and this package
21 contains the most commonly used /dev entries. These files are
22 essential for a system to function properly.
23
24 %description -l de
25 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
26 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge
27 befinden sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses
28 Paket enthält die üblichsten /dev-Einträge. Diese Dateien sind für das
29 Funktionieren eines Systems unbedingt erforderlich.
30
31 %description -l fr
32 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
33 représenter les périphériques reliés à la machine. Toutes ces entrées
34 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
35 contient les entrées /dev les plus courantes. Elles sont essentielles
36 pour qu'un système fonctionne correctement.
37
38 %description -l pl
39 Wszystkie systemy klasy unices, w tym Linux, u¿ywaj± plików do
40 przedstawiania urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki
41 znajduj± siê zwykle w katalogu /dev. Pakiet ten zawiera wiêkszo¶æ
42 popularnych plików specjalnych, s± one jedn± z wa¿niejszych czê¶ci
43 prawid³owo dzia³aj±cego systemu operacyjnego.
44
45 %description -l tr
46 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya
47 baðlý aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel
48 dosyalarýn tümü /dev dizin yapýsý altýndadýr. Bu paket en çok
49 kullanýlan /dev dosyalarýný içerir. Bu dosyalar, bir sistemin düzgün
50 olarak iþleyebilmesi için temel gereksinimlerdendir.
51
52 %prep
53 %setup -q -c -T
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT/dev/{ataraid,cciss,cdroms,cpu/{0,1,2,3,4,5,6,7}} \
58         $RPM_BUILD_ROOT/dev/{discs,i2o,ida,input,net,pts,raw,rd,usb}
59
60 install %{SOURCE0} .
61
62 cd $RPM_BUILD_ROOT/dev
63 ln -sf adsp0 adsp
64 ln -sf amidi0 amidi
65 ln -sf audio0 audio
66 ln -sf dsp0 dsp
67 ln -sf fb0 fb
68 ln -sf rft0 ftape
69 ln -sf isdnctrl0 isdnctrl
70 ln -sf midi00 midi
71 ln -sf mixer0 mixer
72 ln -sf nrft0 nftape
73 ln -sf ram0 ramdisk
74
75 ln -sf em8300-0    em8300
76 ln -sf em8300_ma-0 em8300_ma
77 ln -sf em8300_mv-0 em8300_mv
78 ln -sf em8300_sp-0 em8300_sp
79 for i in `seq 0 31`; do
80         ln -sf fb$i fb${i}current
81 done
82 ln -sf /proc/self/fd fd
83 ln -sf fd/0 stdin
84 ln -sf fd/1 stdout
85 ln -sf fd/2 stderr
86 i=0;
87 for l in a b c d e f g h; do
88         ln -sf sg$l sg$i
89         i=$((i+1))
90 done
91 ln -sf radio0 radio
92 ln -sf music sequencer2
93 ln -sf /proc/asound/dev snd
94 ln -sf vbi0 vbi
95 ln -sf video0 video
96 ln -sf vtx0 vtx
97
98 # prepared for SysVinit
99 mkfifo initctl
100
101 mkfifo lircm
102 mkfifo printer
103
104 # prepared for Log Daemon
105 mkfifo syslog
106
107 %ifarch m68k
108 ln -sf amigamouse mouse
109 %endif
110
111 %ifarch ppc
112 ln -sf adbmouse mouse
113 %endif
114
115 %ifarch sparc
116 ln -sf sunmouse mouse
117 %endif
118
119 # PLD-forklor:
120 ln -sf null drzewo
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files -f dev-list
126 %defattr(644,root,root,755)
127 %dir /dev/cpu
128 %dir /dev/cpu/0
129 %dir /dev/cpu/1
130 %dir /dev/cpu/2
131 %dir /dev/cpu/3
132 %dir /dev/cpu/4
133 %dir /dev/cpu/5
134 %dir /dev/cpu/6
135 %dir /dev/cpu/7
136 %dir /dev/ataraid
137 %dir /dev/cciss
138 %attr(660,root,disk) %dir /dev/cdroms
139 %attr(660,root,disk) %dir /dev/discs
140 %dir /dev/i2o
141 %dir /dev/ida
142 %dir /dev/input
143 %dir /dev/net
144 %dir /dev/pts
145 %dir /dev/raw
146 %dir /dev/rd
147 %dir /dev/usb
148 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/adsp
149 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/amidi
150 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/audio
151 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/dsp
152 %config(noreplace) %verify(not link) %attr(664,root,video) /dev/fb
153 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ftape
154 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
155 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/midi
156 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/mixer
157 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/nftape
158 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
159 %attr(660,root,video) /dev/em8300*
160 %attr(664,root,video) /dev/fb[0-9]*current
161 /dev/fd
162 /dev/stdin
163 /dev/stdout
164 /dev/stderr
165 %attr(660,root,video) /dev/radio
166 %attr(660,root,audio) /dev/sequencer2
167 %attr(600,root,root) /dev/sg[0-7]
168 /dev/snd
169 %attr(660,root,video) /dev/vbi
170 %attr(660,root,video) /dev/video
171 %attr(660,root,video) /dev/vtx
172 %attr(600,root,root) /dev/initctl
173 %attr(660,root,root) /dev/lircm
174 %attr(600,root,root) /dev/printer
175 %attr(666,root,root) /dev/syslog
176 %attr(666,root,root) /dev/drzewo
177
178 %ifarch %{ix86}
179 %dev(c,10,184) %attr(666,root,root) /dev/cpu/microcode
180 %dev(c,10,181) %attr(666,root,root) /dev/toshiba
181 %endif
182
183 %ifarch m68k
184 %dev(b,2,4) %attr(660,root,floppy) /dev/fdhd0
185 %dev(b,2,5) %attr(660,root,floppy) /dev/fdhd1 
186 # XXX: which permissions???
187 %dev(c,10,4) %attr(664,root,root) /dev/amigamouse
188 %attr(664,root,root) /dev/mouse
189 %dev(c,10,5) %attr(664,root,root) /dev/atarimouse
190 %dev(c,10,7) %attr(664,root,root) /dev/apollomouse
191 %endif
192
193 %ifarch ppc
194 %dev(c,56,0) %attr(644,root,root) /dev/adb
195 %dev(c,10,10) %attr(644,root,root) /dev/adbmouse
196 %attr(644,root,root) /dev/mouse
197 %dev(c,10,154) %attr(644,root,root) /dev/pmu
198 %dev(c,10,198) %attr(644,root,root) /dev/sheep_net
199 %endif
200
201 %ifarch sparc
202 # XXX: which permissions ???
203 %dev(c,10,139) %attr(600,root,root) /dev/openprom
204 %dev(c,10,6) %attr(664,root,root) /dev/sunmouse
205 %attr(664,root,root) /dev/mouse
206 %endif
207
208 %ifarch m68k sparc
209 # XXX: which permissions???
210 %dev(c,11,00) %attr(600,root,root) /dev/kbd
211 %endif
212
213 %ifnarch m68k sparc
214 %dev(c,10,3) %attr(664,root,root) /dev/atibm
215 %dev(b,29,0) %attr(660,root,disk) /dev/aztcd
216 %dev(b,15,0) %attr(660,root,disk) /dev/cdu31a
217 %dev(b,24,0) %attr(660,root,disk) /dev/cdu535
218 %dev(b,32,0) %attr(660,root,disk) /dev/cm206cd
219 %dev(b,16,0) %attr(660,root,disk) /dev/gscd
220 %dev(c,10,2) %attr(664,root,root) /dev/inportbm
221 %dev(c,10,0) %attr(664,root,root) /dev/logibm
222 %dev(b,23,0) %attr(660,root,disk) /dev/mcd
223 %dev(c,10,1) %attr(664,root,root) /dev/psaux
224 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd
225 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd0
226 %dev(b,25,1) %attr(660,root,disk) /dev/sbpcd1
227 %dev(b,25,2) %attr(660,root,disk) /dev/sbpcd2
228 %dev(b,25,3) %attr(660,root,disk) /dev/sbpcd3
229 %dev(b,18,0) %attr(660,root,disk) /dev/sjcd
230 %dev(b,15,0) %attr(660,root,disk) /dev/sonycd
231 %endif
This page took 0.054326 seconds and 3 git commands to generate.