]> git.pld-linux.org Git - packages/dev.git/blame_incremental - dev.spec
- R: setup 2.4.12 rel 2
[packages/dev.git] / dev.spec
... / ...
CommitLineData
1Summary: /dev entries
2Summary(de.UTF-8): /dev-Einträge
3Summary(fr.UTF-8): Entrées de /dev
4Summary(pl.UTF-8): Pliki specjalne /dev/*
5Summary(tr.UTF-8): /dev dizini
6Name: dev
7Version: 2.9.0
8Release: 32
9License: Public Domain
10Group: Base
11Source0: %{name}-list
12AutoReqProv: no
13Requires: setup >= 2.4.12-2
14Provides: devfs
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18Unix and Unix-like systems (including Linux) use file system entries
19to represent devices attached to the machine. All of these entries are
20in the /dev tree (though they don't have to be), and this package
21contains the most commonly used /dev entries. These files are
22essential for a system to function properly.
23
24%description -l de.UTF-8
25Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
26Einträge zum Darstellen angeschlossener Geräte. Diese Einträge
27befinden sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses
28Paket enthält die üblichsten /dev-Einträge. Diese Dateien sind für das
29Funktionieren eines Systems unbedingt erforderlich.
30
31%description -l fr.UTF-8
32Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
33représenter les périphériques reliés à la machine. Toutes ces entrées
34sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
35contient les entrées /dev les plus courantes. Elles sont essentielles
36pour qu'un système fonctionne correctement.
37
38%description -l pl.UTF-8
39Wszystkie systemy klasy unices, w tym Linux, używają plików do
40przedstawiania urządzeń podłączonych do komputera. Wszystkie te pliki
41znajdują się zwykle w katalogu /dev. Pakiet ten zawiera większość
42popularnych plików specjalnych, są one jedną z ważniejszych części
43prawidłowo działającego systemu operacyjnego.
44
45%description -l tr.UTF-8
46Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya
47bağlı aygıtları göstermek için özel dosyalar kullanırlar. Bu özel
48dosyaların tümü /dev dizin yapısı altındadır. Bu paket en çok
49kullanılan /dev dosyalarını içerir. Bu dosyalar, bir sistemin düzgün
50olarak işleyebilmesi için temel gereksinimlerdendir.
51
52%prep
53%setup -q -c -T
54
55%install
56rm -rf $RPM_BUILD_ROOT
57install -d $RPM_BUILD_ROOT/dev/{ataraid,cciss,cdemu,cdroms,cpu/{0,1,2,3,4,5,6,7},cpuset} \
58 $RPM_BUILD_ROOT/dev/{discs,dri,etherd,i2o,ida,input,mapper,net,pts,raw,rd,usb,shm,snd,zap}
59
60install %{SOURCE0} .
61
62cd $RPM_BUILD_ROOT/dev
63ln -sf adsp0 adsp
64ln -sf amidi0 amidi
65ln -sf audio0 audio
66ln -sf dsp0 dsp
67ln -sf fb0 fb
68ln -sf rft0 ftape
69ln -sf isdnctrl0 isdnctrl
70ln -sf midi00 midi
71ln -sf mixer0 mixer
72ln -sf nrft0 nftape
73ln -sf ram0 ramdisk
74
75ln -sf em8300-0 em8300
76ln -sf em8300_ma-0 em8300_ma
77ln -sf em8300_mv-0 em8300_mv
78ln -sf em8300_sp-0 em8300_sp
79for i in `seq 0 31`; do
80 ln -sf fb$i fb${i}current
81done
82ln -sf /proc/self/fd fd
83ln -sf fd/0 stdin
84ln -sf fd/1 stdout
85ln -sf fd/2 stderr
86i=0;
87for l in a b c d e f g h; do
88 ln -sf sg$l sg$i
89 i=$((i+1))
90done
91ln -sf radio0 radio
92ln -sf music sequencer2
93ln -sf vbi0 vbi
94ln -sf video0 video
95ln -sf vtx0 vtx
96
97# prepared for SysVinit
98mkfifo initctl
99
100mkfifo lircm
101mkfifo printer
102
103# prepared for Log Daemon
104mkfifo syslog
105
106%ifarch m68k
107ln -sf amigamouse mouse
108%endif
109
110%ifarch ppc
111ln -sf adbmouse mouse
112%endif
113
114%ifarch sparc sparc64 sparcv9
115ln -sf sunmouse mouse
116%endif
117
118# PLD-forklor:
119ln -sf null drzewo
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%files -f dev-list
125%defattr(644,root,root,755)
126%dir /dev/ataraid
127%dir /dev/cciss
128%dir /dev/cdemu
129%dir /dev/cpu
130%dir /dev/cpu/0
131%dir /dev/cpu/1
132%dir /dev/cpu/2
133%dir /dev/cpu/3
134%dir /dev/cpu/4
135%dir /dev/cpu/5
136%dir /dev/cpu/6
137%dir /dev/cpu/7
138%dir /dev/cpuset
139%dir /dev/dri
140%attr(750,root,disk) %dir /dev/cdroms
141%attr(750,root,disk) %dir /dev/discs
142%dir /dev/etherd
143%dir /dev/i2o
144%dir /dev/ida
145%dir /dev/input
146%dir /dev/mapper
147%dir /dev/net
148%dir /dev/pts
149%dir /dev/raw
150%dir /dev/rd
151%dir /dev/usb
152%dir /dev/zap
153%config(noreplace) %verify(not link) %attr(660,root,audio) /dev/adsp
154%config(noreplace) %verify(not link) %attr(660,root,audio) /dev/amidi
155%config(noreplace) %verify(not link) %attr(660,root,audio) /dev/audio
156%config(noreplace) %verify(not link) %attr(660,root,audio) /dev/dsp
157%config(noreplace) %verify(not link) %attr(660,root,video) /dev/fb
158%config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ftape
159%config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
160%config(noreplace) %verify(not link) %attr(660,root,audio) /dev/midi
161%config(noreplace) %verify(not link) %attr(660,root,audio) /dev/mixer
162%config(noreplace) %verify(not link) %attr(660,root,disk) /dev/nftape
163%config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
164%attr(660,root,video) /dev/em8300*
165%attr(660,root,video) /dev/fb[0-9]*current
166/dev/fd
167/dev/stdin
168/dev/stdout
169/dev/stderr
170%attr(660,root,video) /dev/radio
171%attr(660,root,audio) /dev/sequencer2
172%attr(600,root,root) /dev/sg[0-7]
173%dir /dev/shm
174%dir /dev/snd
175%attr(660,root,video) /dev/vbi
176%attr(660,root,video) /dev/video
177%attr(660,root,video) /dev/vtx
178%attr(600,root,root) /dev/initctl
179%attr(660,root,root) /dev/lircm
180%attr(600,root,root) /dev/printer
181%attr(666,root,root) /dev/syslog
182%attr(666,root,root) /dev/drzewo
183
184%ifarch %{ix86}
185%dev(c,10,181) %attr(666,root,root) /dev/toshiba
186%dev(c,212,0) %attr(600,root,root) /dev/slamr0
187%dev(c,213,0) %attr(600,root,root) /dev/slusb0
188%dev(c,226,0) %attr(660,root,video) /dev/dri/card0
189%dev(c,226,1) %attr(660,root,video) /dev/dri/card1
190%dev(c,226,2) %attr(660,root,video) /dev/dri/card2
191%dev(c,226,3) %attr(660,root,video) /dev/dri/card3
192%dev(c,226,4) %attr(660,root,video) /dev/dri/card4
193%dev(c,226,5) %attr(660,root,video) /dev/dri/card5
194%dev(c,226,6) %attr(660,root,video) /dev/dri/card6
195%dev(c,226,7) %attr(660,root,video) /dev/dri/card7
196%endif
197
198%ifarch %{ix86} %{x8664}
199%dev(c,10,227) %attr(600,root,root) /dev/mcelog
200%dev(c,10,184) %attr(666,root,root) /dev/cpu/microcode
201%endif
202
203%ifarch m68k
204%dev(b,2,4) %attr(660,root,floppy) /dev/fdhd0
205%dev(b,2,5) %attr(660,root,floppy) /dev/fdhd1
206# XXX: which permissions???
207%dev(c,10,4) %attr(664,root,root) /dev/amigamouse
208%attr(664,root,root) /dev/mouse
209%dev(c,10,5) %attr(664,root,root) /dev/atarimouse
210%dev(c,10,7) %attr(664,root,root) /dev/apollomouse
211%endif
212
213%ifarch ppc
214%dev(c,56,0) /dev/adb
215%dev(c,10,10) /dev/adbmouse
216/dev/mouse
217%dev(c,10,154) /dev/pmu
218%dev(c,10,198) /dev/sheep_net
219%endif
220
221%ifarch sparc sparc64 sparcv9
222%dev(c,14,7) %attr(660,root,audio) /dev/audioctl
223# XXX: which permissions ???
224%dev(c,10,139) %attr(600,root,root) /dev/openprom
225%dev(c,10,6) %attr(664,root,root) /dev/sunmouse
226%attr(664,root,root) /dev/mouse
227%endif
228
229%ifarch m68k sparc sparc64 sparcv9
230# XXX: which permissions???
231%dev(c,11,00) %attr(600,root,root) /dev/kbd
232%endif
233
234%ifnarch m68k sparc sparc64 sparcv9
235%dev(c,10,3) %attr(664,root,root) /dev/atibm
236%dev(b,29,0) %attr(660,root,disk) /dev/aztcd
237%dev(b,15,0) %attr(660,root,disk) /dev/cdu31a
238%dev(b,24,0) %attr(660,root,disk) /dev/cdu535
239%dev(b,32,0) %attr(660,root,disk) /dev/cm206cd
240%dev(b,16,0) %attr(660,root,disk) /dev/gscd
241%dev(c,10,2) %attr(664,root,root) /dev/inportbm
242%dev(c,10,0) %attr(664,root,root) /dev/logibm
243%dev(b,23,0) %attr(660,root,disk) /dev/mcd
244%dev(c,10,1) %attr(664,root,root) /dev/psaux
245%dev(b,25,0) %attr(660,root,disk) /dev/sbpcd
246%dev(b,25,0) %attr(660,root,disk) /dev/sbpcd0
247%dev(b,25,1) %attr(660,root,disk) /dev/sbpcd1
248%dev(b,25,2) %attr(660,root,disk) /dev/sbpcd2
249%dev(b,25,3) %attr(660,root,disk) /dev/sbpcd3
250%dev(b,18,0) %attr(660,root,disk) /dev/sjcd
251%dev(b,15,0) %attr(660,root,disk) /dev/sonycd
252%endif
This page took 0.114916 seconds and 4 git commands to generate.