]> git.pld-linux.org Git - packages/detect.git/commitdiff
- store small patches in decompressed files
authorKacper Kornet <draenog@pld-linux.org>
Sat, 12 Nov 2011 02:45:11 +0000 (02:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- move detect-po.patch.bz2 to distfiles

Changed files:
    detect-0.9.72-alpha.patch -> 1.1
    detect-0.9.72-cpu-detect-ppc.patch -> 1.1
    detect-ia64-io-h.patch -> 1.1
    detect-kver-ppc.patch -> 1.1
    detect-ppc.patch -> 1.1
    detect-ppc2.patch -> 1.1
    detect-sound.patch -> 1.1
    detect.spec -> 1.17

detect-0.9.72-alpha.patch [new file with mode: 0644]
detect-0.9.72-cpu-detect-ppc.patch [new file with mode: 0644]
detect-ia64-io-h.patch [new file with mode: 0644]
detect-kver-ppc.patch [new file with mode: 0644]
detect-ppc.patch [new file with mode: 0644]
detect-ppc2.patch [new file with mode: 0644]
detect-sound.patch [new file with mode: 0644]
detect.spec

diff --git a/detect-0.9.72-alpha.patch b/detect-0.9.72-alpha.patch
new file mode 100644 (file)
index 0000000..c0f574b
--- /dev/null
@@ -0,0 +1,15 @@
+diff -ur detect/src/SuperProbe/Utils.c detect.new/src/SuperProbe/Utils.c
+--- detect/src/SuperProbe/Utils.c      Fri Aug 11 10:07:52 2000
++++ detect.new/src/SuperProbe/Utils.c  Thu Jan 17 06:44:35 2002
+@@ -28,6 +28,11 @@
+ /* $XConsortium: Utils.c /main/7 1996/02/21 17:13:00 kaleb $ */
++typedef unsigned char u8;
++typedef unsigned short u16;
++typedef unsigned int u32;
++typedef unsigned long u64;
++
+ #include "Probe.h"
+ #if !defined(__PPC__) && !defined(__alpha__)
+ #include "AsmMacros.h"
diff --git a/detect-0.9.72-cpu-detect-ppc.patch b/detect-0.9.72-cpu-detect-ppc.patch
new file mode 100644 (file)
index 0000000..90b5c6c
--- /dev/null
@@ -0,0 +1,14 @@
+--- detect/src/cpu.c.ppc       Mon Mar  4 19:39:18 2002
++++ detect/src/cpu.c   Mon Mar  4 19:41:43 2002
+@@ -44,10 +44,8 @@
+     printf(_("\nProbing CPU...\n"));
+   while(getline(&line, &len, cpuinfo) >= 0){
+-#if defined(__alpha__)
++#if defined(__alpha__) || defined(__powerpc__)
+     if(strstr(line, "cpu      ")){
+-#elif defined(__PPC__)
+-    if(strstr(line, "processor")) {
+ #else /*ix86 or __powerpc__ */
+     if(strstr(line, "vendor_id")){
+ #endif
diff --git a/detect-ia64-io-h.patch b/detect-ia64-io-h.patch
new file mode 100644 (file)
index 0000000..e9c2fb3
--- /dev/null
@@ -0,0 +1,22 @@
+diff -urN detect-old/src/SuperProbe/AsmMacros.h detect/src/SuperProbe/AsmMacros.h
+--- detect-old/src/SuperProbe/AsmMacros.h      Tue Mar 27 08:15:39 2001
++++ detect/src/SuperProbe/AsmMacros.h  Tue Mar 27 08:17:38 2001
+@@ -60,13 +60,17 @@
+ /* $XFree86: xc/programs/Xserver/hw/xfree86/SuperProbe/AsmMacros.h,v 3.10.2.1 1999/06/17 16:23:57 hohndel Exp $ */
+ #if defined(__GNUC__)
+-#if defined(linux) && (defined(__alpha__) || defined(__powerpc__))
++#if defined(linux) && (defined(__alpha__) || defined(__powerpc__) || defined(__ia64__))
++#ifdef __ia64__
++#include <sys/io.h>
++#else /* !__ia64__ */
+ #define inb _inb
+ #define inw _inw
+ #define inl _inl
+ #define outb(p,v) _outb((v),(p))
+ #define outw(p,v) _outw((v),(p))
+ #define outl(p,v) _outl((v),(p))
++#endif /* !__ia64__ */
+ #else
+ #if defined(__sparc__)
+ #ifndef ASI_PL
diff --git a/detect-kver-ppc.patch b/detect-kver-ppc.patch
new file mode 100644 (file)
index 0000000..761d5f0
--- /dev/null
@@ -0,0 +1,14 @@
+--- detect/src/SuperProbe/Utils.c      Fri Aug 11 10:07:52 2000
++++ detect-patched/src/SuperProbe/Utils.c      Thu May 10 19:29:34 2001
+@@ -32,6 +32,11 @@
+ #if !defined(__PPC__) && !defined(__alpha__)
+ #include "AsmMacros.h"
+ #else
++/* io.h in 2.4 kernel does not define anything without this - PPC */
++#include <linux/version.h>
++#if !(LINUX_VERSION_CODE < KERNEL_VERSION(2,4,0))
++#define __KERNEL__
++#endif
+ #include <asm/io.h>
+ unsigned long isa_io_base;
+ #endif
diff --git a/detect-ppc.patch b/detect-ppc.patch
new file mode 100644 (file)
index 0000000..0ede8e2
--- /dev/null
@@ -0,0 +1,35 @@
+--- /src/ethernet.c    Wed Aug 16 09:56:50 2000
++++ /src/ethernet.c.ppc        Thu Jan 25 15:16:28 2001
+@@ -178,7 +178,7 @@
+       result->next = (struct ethernet_info *)NULL;
+       result->vendor = "Apple";
+-      result->id = 0;
++      result->board_id = 0;
+       result->bus = UNKNOWN_BUS;
+       file = my_malloc(sizeof(folder) * strlen(folder) + 15);
+
+--- /src/scsi.c        Wed Aug 16 09:56:50 2000
++++ /src/scsi.c.ppc    Thu Jan 25 15:16:50 2001
+@@ -171,7 +171,7 @@
+       result->next = (struct scsintf_info *)NULL;
+       result->vendor = "Apple";
+-      result->id = 0;
++      result->board_id = 0;
+       result->bus = UNKNOWN_BUS;
+       file = my_malloc(sizeof(folder) * strlen(folder) + 15);
+
+--- /src/SuperProbe/AsmMacros.h        Fri Jul 28 05:20:15 2000
++++ /src/SuperProbe/AsmMacros.h.ppc    Thu Jan 25 16:10:28 2001
+@@ -60,7 +60,7 @@
+ /* $XFree86: xc/programs/Xserver/hw/xfree86/SuperProbe/AsmMacros.h,v 3.10.2.1 1999/06/17 16:23:57 hohndel Exp $ */
+ #if defined(__GNUC__)
+-#if defined(linux) && defined(__alpha__)
++#if defined(linux) && (defined(__alpha__) || defined(__powerpc__))
+ #define inb _inb
+ #define inw _inw
+ #define inl _inl
diff --git a/detect-ppc2.patch b/detect-ppc2.patch
new file mode 100644 (file)
index 0000000..372dfa0
--- /dev/null
@@ -0,0 +1,22 @@
+--- ./src/scsi.c       Thu Feb  1 14:56:31 2001
++++ ./src/scsi.c.ppc   Thu Feb  1 15:03:43 2001
+@@ -171,7 +171,7 @@
+       result->next = (struct scsintf_info *)NULL;
+       result->vendor = "Apple";
+-      result->board_id = 0;
++      result->long_id = 0;
+       result->bus = UNKNOWN_BUS;
+       file = my_malloc(sizeof(folder) * strlen(folder) + 15);
+--- ./src/ethernet.c   Thu Feb  1 14:56:31 2001
++++ ./src/ethernet.c.ppc       Thu Feb  1 15:04:26 2001
+@@ -178,7 +178,7 @@
+       result->next = (struct ethernet_info *)NULL;
+       result->vendor = "Apple";
+-      result->board_id = 0;
++      result->long_id = 0;
+       result->bus = UNKNOWN_BUS;
+       file = my_malloc(sizeof(folder) * strlen(folder) + 15);
diff --git a/detect-sound.patch b/detect-sound.patch
new file mode 100644 (file)
index 0000000..bfc6cc2
--- /dev/null
@@ -0,0 +1,75 @@
+Only in detect-new/src: .deps
+diff -ur detect/src/CVS/Entries detect-new/src/CVS/Entries
+--- detect/src/CVS/Entries     Thu Aug 31 09:11:11 2000
++++ detect-new/src/CVS/Entries Mon Sep 11 12:13:32 2000
+@@ -4,13 +4,10 @@
+ /bus.c/1.5/Mon Jul 24 22:27:20 2000//
+ /calls.c/1.5/Fri Aug 11 10:43:05 2000//
+ /cdrom.c/1.21/Mon Aug 14 10:12:00 2000//
+-/conv.c/1.36/Wed Aug 16 13:39:55 2000//
+ /cpu.c/1.29/Fri Aug 11 14:02:46 2000//
+ /detect.c/1.14/Mon Jun 19 12:51:03 2000//
+-/detect.h/1.114/Wed Aug 30 16:15:03 2000//
+ /disk.c/1.27/Wed Aug 30 16:15:03 2000//
+ /ethernet.c/1.34/Wed Aug 16 13:56:50 2000//
+-/floppy.c/1.29/Fri Aug 11 10:43:05 2000//
+ /ide.c/1.27/Wed Aug 30 16:15:03 2000//
+ /isa.c/1.61/Wed Aug 30 13:50:04 2000//
+ /isdn.c/1.3/Wed Aug 16 13:56:50 2000//
+@@ -39,8 +36,11 @@
+ /usb.h/1.1/Mon Jul 24 10:56:56 2000//
+ /utils.c/1.32/Fri Jul 14 14:56:37 2000//
+ /utils.h/1.19/Thu Aug 10 15:24:38 2000//
+-/video.c/1.26/Wed Aug 16 13:56:50 2000//
+ /webcam.c/1.3/Wed Aug 16 13:56:50 2000//
+ D/SuperProbe////
+ D/lst////
+ D/pcmcia////
++/conv.c/1.37/Sun Sep 10 20:34:31 2000//
++/detect.h/1.115/Sun Sep 10 20:34:31 2000//
++/floppy.c/1.30/Sun Sep 10 20:34:31 2000//
++/video.c/1.26/Mon Sep 11 10:13:31 2000//
+diff -ur detect/src/CVS/Root detect-new/src/CVS/Root
+--- detect/src/CVS/Root        Thu Aug 31 09:09:37 2000
++++ detect-new/src/CVS/Root    Mon Sep  4 11:56:49 2000
+@@ -1 +1 @@
+-:pserver:anoncvs@mandrakesoft.com:/home/cvs/harddrake
++:pserver:adussart@mandrakesoft.com:/home/cvs/harddrake
+Only in detect-new/src: Makefile
+Only in detect-new/src: Makefile.in
+diff -ur detect/src/conv.c detect-new/src/conv.c
+--- detect/src/conv.c  Wed Aug 16 15:39:55 2000
++++ detect-new/src/conv.c      Tue Sep 12 11:45:04 2000
+@@ -270,6 +270,8 @@
+   if(strstr(str, "HAS_DREAM")) options += HAS_DREAM;
+   if(strstr(str, "HAS_MAD16")) options += HAS_MAD16;
+   if(strstr(str, "IS_SERIAL")) options += IS_SERIAL;
++  if(strstr(str, "IS_MPU401")) options += IS_MPU401;
++  if(strstr(str, "IS_OPL3")) options += IS_OPL3;
+   if(strstr(str, s_unknown)) options = 0;
+   return options;
+ }/*endfunc str2options*/
+@@ -306,6 +308,10 @@
+     sprintf(str, "%s:%s", str, "HAS_MAD16");
+   if(options & IS_SERIAL)
+     sprintf(str, "%s:%s", str, "IS_SERIAL");
++  if(options & IS_MPU401)
++      sprintf(str, "%s:%s", str, "IS_MPU401");
++  if(options & IS_OPL3)
++      sprintf(str, "%s:%s", str, "IS_OPL3");
+   if(strlen(str)<1){
+     sprintf(str, "[]");
+   }else{
+diff -ur detect/src/detect.h detect-new/src/detect.h
+--- detect/src/detect.h        Wed Aug 30 18:15:03 2000
++++ detect-new/src/detect.h    Sun Sep 10 22:34:31 2000
+@@ -64,6 +64,9 @@
+ #define IS_SERIAL      (1<<14)  /* indicate SERIAL device             */
++#define       IS_MPU401          (1<<15)      /*if sound device is mpu401 in fact*/
++#define       IS_OPL3            (1<<16)      /*              '                 is opl3       '          */
++
+ /* Modprobe version to be used */
+ #define DETECT_MODPROBE_MAJOR 2
+ #define DETECT_MODPROBE_MINOR 3
index 20444ca83c03c9ef1aa00a850e0355051ecb25e9..bd23dd6374cedc2bcf6161cbeb911c30f15e4b8e 100644 (file)
@@ -7,14 +7,15 @@ License:      GPL
 Group:         Applications/System
 Source0:       ftp://ftp.linux-mandrake.com/pub/harddrake/SOURCES/%{name}-%{version}.tar.bz2
 # Source0-md5: 0e001355ad217ce907c5ce95673ab4a4
-Patch0:                %{name}-sound.patch.bz2
+Patch0:                %{name}-sound.patch
 Patch1:                %{name}-po.patch.bz2
-Patch2:                %{name}-ppc.patch.bz2
-Patch3:                %{name}-ppc2.patch.bz2
-Patch4:                %{name}-ia64-io-h.patch.bz2
-Patch5:                %{name}-kver-ppc.patch.bz2
-Patch6:                %{name}-0.9.72-alpha.patch.bz2
-Patch7:                %{name}-0.9.72-cpu-detect-ppc.patch.bz2
+# Patch1-md5:  b01b0b1f10895628ab0f40daa855d2e9
+Patch2:                %{name}-ppc.patch
+Patch3:                %{name}-ppc2.patch
+Patch4:                %{name}-ia64-io-h.patch
+Patch5:                %{name}-kver-ppc.patch
+Patch6:                %{name}-0.9.72-alpha.patch
+Patch7:                %{name}-0.9.72-cpu-detect-ppc.patch
 Patch8:                %{name}-acam.patch
 URL:           http://www.linux-mandrake.com/harddrake/
 BuildRequires: autoconf
This page took 0.078775 seconds and 4 git commands to generate.