]> git.pld-linux.org Git - packages/demarc.git/blame - demarc.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/demarc.git] / demarc.spec
CommitLineData
ece2866a
ER
1# TODO
2# - integrate pld webapps framework
09abfc3c
AM
3%define ver 1.05
4%define subver RC1
5Summary: Network monitoring program
47ba4d14 6Summary(pl.UTF-8): Program do monitorowania sieci
09abfc3c
AM
7Name: demarc
8Version: %{ver}.%{subver}
d57978aa 9Release: 4
349f96ed 10License: http://www.demarc.org/license/ (Free for non-commercial use)
09abfc3c 11Group: Networking
349f96ed 12Source0: http://www.demarc.org/downloads/demarc-105/%{name}-%{ver}-%{subver}.tar.gz
85d00b83 13# Source0-md5: adf1550b8e7a4936c4b37ac214704f27
09abfc3c
AM
14Source1: %{name}-apache.conf
15Source2: %{name}.init
48965869 16Source3: %{name}.cron
09abfc3c 17Patch0: %{name}-config.patch
349f96ed 18Patch1: %{name}-whois-fix.patch
09abfc3c 19URL: http://www.demarc.org/
d57978aa 20BuildRequires: perl-Apache-DBI
09abfc3c
AM
21BuildRequires: perl-CGI
22BuildRequires: perl-DBI
09abfc3c 23BuildRequires: perl-Digest-MD5
d57978aa 24BuildRequires: perl-Msql-Mysql-modules
25BuildRequires: perl-devel >= 1:5.6
26BuildRequires: rpm-perlprov >= 4.1-13
ea1a0c4b 27BuildRequires: rpmbuild(macros) >= 1.228
0e9bdc22 28Requires(post,preun): /sbin/chkconfig
ece2866a 29Requires: crondaemon
155879fb
ER
30Requires: rc-scripts
31Requires: webserver = apache
09abfc3c
AM
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
09abfc3c
AM
35%define _bindir %{_sbindir}
36
37%description
38DEMARC is an all-inclusive network monitoring program that allows you
39to monitor an entire network of servers from one powerful web
40interface.
41
42Instead of having one program perform file integrity checks, another
43program monitoring the connectivity and health of your network, and
44yet another monitoring your network for intrusion detection attempts,
45DEMARC combines all three services into one powerful client/server
46program. Not only can you monitor the status of the different machines
47in your network, but you can also respond to changes in your network
48all from one centralized location.
49
0e51d86f
JR
50%description -l pl.UTF-8
51DEMARC to kompletny system monitorowania sieci pozwalający monitorować
52całą sieć serwerów z jednego interfejsu WWW.
09abfc3c 53
0e51d86f
JR
54Zamiast posiadać jeden program sprawdzający integralność plików, inny
55program monitorujący połączenia i stan Twojej sieci, i jeszcze jeden
56program monitorujący sieć w celach detekcji intruzów wystarczy DEMARC
57łączący w sobie te trzy usługi w jednym programie klient/serwer. Nie
58tylko możesz monitorować stan różnych maszyn w Twojej sieci ale także
59możesz reagować na zmiany z jednej centralnej lokalizacji.
09abfc3c
AM
60
61%package client
349f96ed 62Summary: Network monitoring program - client
47ba4d14 63Summary(pl.UTF-8): Program do monitorowania sieci - klient
349f96ed 64Group: Networking
b4d6e872 65Requires: snort(mysql) >= 1.8.1
09abfc3c
AM
66
67%description client
68DEMARC is an all-inclusive network monitoring program that allows you
69to monitor an entire network of servers from one powerful web
70interface.
71
349f96ed
JB
72This is client program which should be installed on all monitored
73servers.
09abfc3c 74
0e51d86f
JR
75%description client -l pl.UTF-8
76DEMARC to kompletny system monitorowania sieci pozwalający monitorować
77całą sieć serwerów z jednego interfejsu WWW.
09abfc3c 78
0e51d86f 79To jest program kliencki, który powinien być zainstalowany na
349f96ed 80wszystkich monitorowanych serwerach.
09abfc3c
AM
81
82%prep
83%setup -q -n %{name}-%{ver}-%{subver}
84%patch0 -p1
349f96ed 85%patch1 -p1
09abfc3c
AM
86
87%install
88rm -rf $RPM_BUILD_ROOT
bcbf829e
PG
89install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,demarcd,httpd} \
90 $RPM_BUILD_ROOT{%{_sbindir},%{_datadir}/demarc/{images,cgi}} \
91 $RPM_BUILD_ROOT%{_var}/lib/demarcd
09abfc3c 92
ece2866a
ER
93cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/%{name}.conf
94install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/demarcd
95cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}
96install -p bin/demarcd $RPM_BUILD_ROOT%{_sbindir}
97cp -p conf/* $RPM_BUILD_ROOT%{_sysconfdir}/demarcd
98cp -a cgi images $RPM_BUILD_ROOT%{_datadir}/demarc
99cp -p install/{c*,d*,p*} $RPM_BUILD_ROOT%{_datadir}/demarc
09abfc3c 100
09abfc3c
AM
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post
349f96ed 105echo 'Remember to add "Include demarc.conf" to httpd.conf.'
09abfc3c
AM
106
107%post client
108if [ "$1" = "1" ] ; then
109 touch /var/log/demarcd && chmod 750 /var/log/demarcd
110fi
111/sbin/chkconfig --add demarcd
ea1a0c4b
ER
112%service demarcd restart
113%banner -e -o %{name} <<EOF
114
115Run "%{_sbindir}/demarcd -I" to install new snort sensor and then
116run "service demarcd start" to start demarcd daemon.
09abfc3c 117
ea1a0c4b
ER
118Note that in most cases there is no need to start "snort" as
119separate daemon, so turn it off using "chkconfig snort off".
120EOF
09abfc3c
AM
121
122%preun client
123if [ "$1" = "0" ] ; then
ea1a0c4b 124 %service demarcd stop
09abfc3c
AM
125 /sbin/chkconfig --del demarcd
126fi
127
128%files
129%defattr(644,root,root,755)
72d59f4d 130%doc install/{CHAN*,INS*,LIC*}
09abfc3c
AM
131%dir %{_datadir}/demarc
132%{_datadir}/demarc/create_mysql_demarc
133%{_datadir}/demarc/db_patch_queries
134%attr(755,root,root) %{_datadir}/demarc/*.pl
135
136%dir %{_datadir}/demarc/cgi
137%{_datadir}/demarc/cgi/StaticServices.pm
138%attr(640,root,http) %{_datadir}/demarc/cgi/DEMARC_config.pm
139%attr(755,root,root) %{_datadir}/demarc/cgi/demarc
140
141%dir %{_datadir}/demarc/cgi/templates
142%{_datadir}/demarc/cgi/templates/*
143
144%dir %{_datadir}/demarc/images
145%{_datadir}/demarc/images/*
146
b4d6e872 147%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/demarc.conf
09abfc3c
AM
148
149%files client
150%defattr(644,root,root,755)
151%attr(754,root,root) /etc/rc.d/init.d/demarcd
152%attr(755,root,root) %{_sbindir}/demarcd
155879fb
ER
153%attr(750,root,root) %dir %{_sysconfdir}/demarcd
154%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/demarcd/*.conf
155%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/demarcd/*.cmds
eec3ead5 156%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
860c2122 157%attr(750,root,root) %{_var}/lib/demarcd
This page took 0.044693 seconds and 4 git commands to generate.