]> git.pld-linux.org Git - packages/deltarpm.git/blob - deltarpm.spec
- updated to 3.6.3
[packages/deltarpm.git] / deltarpm.spec
1 #
2 # Conditional build:
3 %bcond_without  python3 # CPython3 module
4 #
5 Summary:        Create deltas between rpms
6 Summary(pl.UTF-8):      Generowanie różnic między pakietami rpm
7 Name:           deltarpm
8 Version:        3.6.1
9 Release:        2
10 License:        BSD
11 Group:          Base
12 #Source0Download: https://github.com/rpm-software-management/deltarpm/releases
13 Source0:        https://github.com/rpm-software-management/deltarpm/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  c48086229bdfcf5af890f104231180c6
15 Patch0:         %{name}-3.4-no-skip-doc.patch
16 Patch1:         %{name}-3.4-pld.patch
17 Patch2:         %{name}-rpm5.patch
18 Patch3:         python-install.patch
19 URL:            https://github.com/rpm-software-management/deltarpm
20 BuildRequires:  bzip2-devel
21 BuildRequires:  popt-devel
22 BuildRequires:  python-devel >= 2
23 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
24 BuildRequires:  rpm-devel
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.507
27 BuildRequires:  xz-devel
28 BuildRequires:  zlib-static
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A deltarpm contains the difference between an old and a new version of
33 a rpm, which makes it possible to recreate the new rpm from the
34 deltarpm and the old one. You don't have to have a copy of the old
35 rpm, deltarpms can also work with installed rpms.
36
37 %description -l pl.UTF-8
38 Deltarpm zawiera różnice pomiędzy starą i nową wersją pakietu RPM,
39 pozwalając na stworzenie nowej wersji na podstawie delty i starej
40 wersji. Nie jest konieczne posiadanie kopii starego pakietu RPM,
41 deltarpm obsługuje także już zainstalowane pakiety.
42
43 %package -n drpmsync
44 Summary:        Sync a file tree with deltarpms
45 Summary(pl.UTF-8):      Synchronizacja drzewa plików deltarpm
46 Group:          Base
47 Requires:       %{name} = %{version}-%{release}
48 Suggests:       deltaiso
49
50 %description -n drpmsync
51 This package contains a tool to sync a file tree with deltarpms.
52
53 %description -n drpmsync -l pl.UTF-8
54 Ten pakiet zawiera narzędzie do synchronizacji drzewa plików deltarpm.
55
56 %package -n deltaiso
57 Summary:        Create deltas between isos containing rpms
58 Summary(pl.UTF-8):      Tworzenie różnic między obrazami ISO zawierającymi pakiety RPM
59 Group:          Base
60 Requires:       %{name} = %{version}-%{release}
61
62 %description -n deltaiso
63 This package contains tools for creating and using deltaisos, a
64 difference between an old and a new iso containing rpms.
65
66 %description -n deltaiso -l pl.UTF-8
67 Ten pakiet zawiera narzędzia do tworzenia i wykorzystywania plików
68 deltaiso - różnic między starymi a nowymi obrazami ISO zawierającymi
69 pakiety RPM.
70
71 %package -n python-deltarpm
72 Summary:        Python 2 bindings for deltarpm
73 Summary(pl.UTF-8):      Wiązania Pythona 2 do deltarpm
74 Group:          Libraries/Python
75 # does not require base package
76
77 %description -n python-deltarpm
78 This package contains Python 2 bindings for deltarpm.
79
80 %description -n python-deltarpm -l pl.UTF-8
81 Ten pakiet zawiera wiązania Pythona 2 do deltarpm.
82
83 %package -n python3-deltarpm
84 Summary:        Python 3 bindings for deltarpm
85 Summary(pl.UTF-8):      Wiązania Pythona 3 do deltarpm
86 Group:          Libraries/Python
87 # does not require base package
88
89 %description -n python3-deltarpm
90 This package contains Python 3 bindings for deltarpm.
91
92 %description -n python3-deltarpm -l pl.UTF-8
93 Ten pakiet zawiera wiązania Pythona 3 do deltarpm.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100 %patch3 -p1
101
102 %if %{without python3}
103 %{__sed} -i -e 's/python3//' Makefile
104 %endif
105
106 %build
107 %{__make} \
108         CC="%{__cc}" \
109         CFLAGS="%{rpmcflags} -I/usr/include/rpm" \
110         bindir=%{_bindir} \
111         libdir=%{_libdir} \
112         mandir=%{_mandir} \
113         prefix=%{_prefix} \
114         zlibbundled='' \
115         zlibldflags='-lz' \
116         zlibcppflags=''
117
118 %{__make} python \
119         CC="%{__cc}" \
120         CFLAGS="%{rpmcflags}" \
121         bindir=%{_bindir} \
122         libdir=%{_libdir} \
123         mandir=%{_mandir} \
124         prefix=%{_prefix} \
125         zlibbundled='' \
126         zlibldflags='-lz' \
127         zlibcppflags=''
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
135 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
136 %py_postclean
137 %if %{with python3}
138 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
139 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
140 %endif
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %files
146 %defattr(644,root,root,755)
147 %doc LICENSE.BSD README
148 %attr(755,root,root) %{_bindir}/applydeltarpm
149 %attr(755,root,root) %{_bindir}/combinedeltarpm
150 %attr(755,root,root) %{_bindir}/makedeltarpm
151 %attr(755,root,root) %{_bindir}/rpmdumpheader
152 %{_mandir}/man8/applydeltarpm.8*
153 %{_mandir}/man8/combinedeltarpm.8*
154 %{_mandir}/man8/makedeltarpm.8*
155
156 %files -n deltaiso
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/applydeltaiso
159 %attr(755,root,root) %{_bindir}/fragiso
160 %attr(755,root,root) %{_bindir}/makedeltaiso
161 %{_mandir}/man8/applydeltaiso.8*
162 %{_mandir}/man8/fragiso.8*
163 %{_mandir}/man8/makedeltaiso.8*
164
165 %files -n drpmsync
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/drpmsync
168 %{_mandir}/man8/drpmsync.8*
169
170 %files -n python-deltarpm
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{py_sitedir}/_deltarpmmodule.so
173 %{py_sitedir}/deltarpm.py[co]
174
175 %if %{with python3}
176 %files -n python3-deltarpm
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{py3_sitedir}/_deltarpmmodule.so
179 %{py3_sitedir}/deltarpm.py
180 %{py3_sitedir}/__pycache__/deltarpm.cpython-*.py[co]
181 %endif
This page took 0.070598 seconds and 3 git commands to generate.