]> git.pld-linux.org Git - packages/deltarpm.git/blame - deltarpm.spec
- updated to 3.6.3
[packages/deltarpm.git] / deltarpm.spec
CommitLineData
41f890d2
JB
1#
2# Conditional build:
3%bcond_without python3 # CPython3 module
e7e1b7f8 4%bcond_with rpm5 # build with rpm5
41f890d2 5#
ec871032 6Summary: Create deltas between rpms
29b147f7 7Summary(pl.UTF-8): Generowanie różnic między pakietami rpm
ec871032 8Name: deltarpm
174529b5
JB
9Version: 3.6.3
10Release: 1
ec871032
JS
11License: BSD
12Group: Base
174529b5 13#Source0Download: https://github.com/rpm-software-management/deltarpm/tags
41f890d2 14Source0: https://github.com/rpm-software-management/deltarpm/archive/%{version}/%{name}-%{version}.tar.gz
174529b5 15# Source0-md5: 8788682eaa329e467f00f096ced03051
e9ebb178
BZ
16Patch0: %{name}-3.4-no-skip-doc.patch
17Patch1: %{name}-3.4-pld.patch
0db6ec97 18Patch2: %{name}-rpm5.patch
9705b153 19Patch3: python-install.patch
41f890d2 20URL: https://github.com/rpm-software-management/deltarpm
29b147f7 21BuildRequires: bzip2-devel
17c4044f 22BuildRequires: popt-devel
41f890d2
JB
23BuildRequires: python-devel >= 2
24%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
29b147f7 25BuildRequires: rpm-devel
17c4044f 26BuildRequires: rpm-pythonprov
41f890d2 27BuildRequires: rpmbuild(macros) >= 1.507
17c4044f 28BuildRequires: xz-devel
e9ebb178 29BuildRequires: zlib-static
29b147f7 30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
ec871032
JS
31
32%description
33A deltarpm contains the difference between an old and a new version of
34a rpm, which makes it possible to recreate the new rpm from the
35deltarpm and the old one. You don't have to have a copy of the old
36rpm, deltarpms can also work with installed rpms.
37
29b147f7 38%description -l pl.UTF-8
c9a3fd60 39Deltarpm zawiera różnice pomiędzy starą i nową wersją pakietu RPM,
5b29bdd5 40pozwalając na stworzenie nowej wersji na podstawie delty i starej
c9a3fd60 41wersji. Nie jest konieczne posiadanie kopii starego pakietu RPM,
5b29bdd5 42deltarpm obsługuje także już zainstalowane pakiety.
29b147f7 43
17c4044f
ER
44%package -n drpmsync
45Summary: Sync a file tree with deltarpms
c9a3fd60 46Summary(pl.UTF-8): Synchronizacja drzewa plików deltarpm
17c4044f
ER
47Group: Base
48Requires: %{name} = %{version}-%{release}
9f363761 49Suggests: deltaiso
17c4044f
ER
50
51%description -n drpmsync
52This package contains a tool to sync a file tree with deltarpms.
53
c9a3fd60
JB
54%description -n drpmsync -l pl.UTF-8
55Ten pakiet zawiera narzędzie do synchronizacji drzewa plików deltarpm.
56
17c4044f
ER
57%package -n deltaiso
58Summary: Create deltas between isos containing rpms
c9a3fd60 59Summary(pl.UTF-8): Tworzenie różnic między obrazami ISO zawierającymi pakiety RPM
17c4044f
ER
60Group: Base
61Requires: %{name} = %{version}-%{release}
62
63%description -n deltaiso
c9a3fd60 64This package contains tools for creating and using deltaisos, a
17c4044f
ER
65difference between an old and a new iso containing rpms.
66
c9a3fd60
JB
67%description -n deltaiso -l pl.UTF-8
68Ten pakiet zawiera narzędzia do tworzenia i wykorzystywania plików
69deltaiso - różnic między starymi a nowymi obrazami ISO zawierającymi
70pakiety RPM.
71
17c4044f 72%package -n python-deltarpm
41f890d2
JB
73Summary: Python 2 bindings for deltarpm
74Summary(pl.UTF-8): Wiązania Pythona 2 do deltarpm
75Group: Libraries/Python
8ac71a9c 76# does not require base package
17c4044f
ER
77
78%description -n python-deltarpm
41f890d2 79This package contains Python 2 bindings for deltarpm.
c9a3fd60
JB
80
81%description -n python-deltarpm -l pl.UTF-8
41f890d2
JB
82Ten pakiet zawiera wiązania Pythona 2 do deltarpm.
83
84%package -n python3-deltarpm
85Summary: Python 3 bindings for deltarpm
86Summary(pl.UTF-8): Wiązania Pythona 3 do deltarpm
87Group: Libraries/Python
88# does not require base package
89
90%description -n python3-deltarpm
91This package contains Python 3 bindings for deltarpm.
92
93%description -n python3-deltarpm -l pl.UTF-8
94Ten pakiet zawiera wiązania Pythona 3 do deltarpm.
17c4044f 95
ec871032 96%prep
803d1305 97%setup -q
e9ebb178 98%patch0 -p1
29b147f7 99%patch1 -p1
e7e1b7f8 100%{?with_rpm5:%patch2 -p1}
9705b153 101%patch3 -p1
ec871032 102
41f890d2 103%if %{without python3}
17c4044f 104%{__sed} -i -e 's/python3//' Makefile
41f890d2 105%endif
17c4044f 106
ec871032 107%build
c9a3fd60
JB
108%{__make} \
109 CC="%{__cc}" \
b685f159 110 CFLAGS="%{rpmcflags} -I/usr/include/rpm -D_GNU_SOURCE" \
c9a3fd60
JB
111 bindir=%{_bindir} \
112 libdir=%{_libdir} \
113 mandir=%{_mandir} \
114 prefix=%{_prefix} \
115 zlibbundled='' \
116 zlibldflags='-lz' \
117 zlibcppflags=''
118
119%{__make} python \
120 CC="%{__cc}" \
121 CFLAGS="%{rpmcflags}" \
122 bindir=%{_bindir} \
123 libdir=%{_libdir} \
124 mandir=%{_mandir} \
125 prefix=%{_prefix} \
126 zlibbundled='' \
127 zlibldflags='-lz' \
128 zlibcppflags=''
ec871032
JS
129
130%install
131rm -rf $RPM_BUILD_ROOT
132%{__make} install \
133 DESTDIR=$RPM_BUILD_ROOT
134
17c4044f
ER
135%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
136%py_comp $RPM_BUILD_ROOT%{py_sitedir}
137%py_postclean
41f890d2
JB
138%if %{with python3}
139%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
140%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
141%endif
17c4044f 142
ec871032
JS
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%files
147%defattr(644,root,root,755)
148%doc LICENSE.BSD README
17c4044f
ER
149%attr(755,root,root) %{_bindir}/applydeltarpm
150%attr(755,root,root) %{_bindir}/combinedeltarpm
151%attr(755,root,root) %{_bindir}/makedeltarpm
152%attr(755,root,root) %{_bindir}/rpmdumpheader
153%{_mandir}/man8/applydeltarpm.8*
154%{_mandir}/man8/combinedeltarpm.8*
155%{_mandir}/man8/makedeltarpm.8*
156
157%files -n deltaiso
158%defattr(644,root,root,755)
159%attr(755,root,root) %{_bindir}/applydeltaiso
160%attr(755,root,root) %{_bindir}/fragiso
161%attr(755,root,root) %{_bindir}/makedeltaiso
c9a3fd60 162%{_mandir}/man8/applydeltaiso.8*
803d1305 163%{_mandir}/man8/fragiso.8*
c9a3fd60 164%{_mandir}/man8/makedeltaiso.8*
17c4044f
ER
165
166%files -n drpmsync
167%defattr(644,root,root,755)
168%attr(755,root,root) %{_bindir}/drpmsync
c9a3fd60 169%{_mandir}/man8/drpmsync.8*
17c4044f
ER
170
171%files -n python-deltarpm
172%defattr(644,root,root,755)
173%attr(755,root,root) %{py_sitedir}/_deltarpmmodule.so
174%{py_sitedir}/deltarpm.py[co]
41f890d2
JB
175
176%if %{with python3}
177%files -n python3-deltarpm
178%defattr(644,root,root,755)
179%attr(755,root,root) %{py3_sitedir}/_deltarpmmodule.so
180%{py3_sitedir}/deltarpm.py
181%{py3_sitedir}/__pycache__/deltarpm.cpython-*.py[co]
182%endif
This page took 0.111066 seconds and 4 git commands to generate.