]> git.pld-linux.org Git - packages/delta.git/blame - delta.spec
up to 0.7.1
[packages/delta.git] / delta.spec
CommitLineData
d037b48c 1%define crates_ver 0.7.1
4a2626ba 2
92a8f118
JP
3Summary: A viewer for git and diff output
4Name: delta
d037b48c 5Version: 0.7.1
92a8f118
JP
6Release: 1
7License: MIT
8Group: Applications
9Source0: https://github.com/dandavison/delta/archive/%{version}/%{name}-%{version}.tar.gz
d037b48c 10# Source0-md5: a606fdeaf7c689aba27da79b13362f89
f2b5808f 11# ./create-crates.sh
4a2626ba 12Source1: %{name}-crates-%{crates_ver}.tar.xz
d037b48c 13# Source1-md5: 88f9be8b3bf03d2651690a010cc27766
92a8f118
JP
14URL: https://github.com/dandavison/delta
15BuildRequires: cargo
16BuildRequires: rust
c42db62c
JP
17BuildRequires: tar >= 1:1.22
18BuildRequires: xz
92a8f118
JP
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22Delta aims to make studying diffs both efficient and enjoyable: it
23allows you to make extensive changes to the layout and styling of
24diffs, as well as allowing you to stay arbitrarily close to the
25default git/diff output, changing just the aspects that you want to
26change.
27
28Delta's main features are:
29
30- Language syntax highlighting with color themes
31- Within-line highlights based on a Levenshtein edit inference
32 algorithm
33- Style (foreground color, background color, font attributes) can be
34 configured independently for more than 20 different sections of the
35 diff
36- Stylable box/line decorations to draw attention to commit, file and
37 hunk header sections.
38- Line numbering (`-n`)
39- `--diff-highlight` and `--diff-so-fancy` emulation modes
40- Code can be copied directly from the diff (`-/+` markers are removed
41 by default).
42- `n` and `N` keybindings to move between files in large diffs, and
43 between diffs in `log -p` views (`--navigate`) A viewer for git and
44 diff output.
45
46%prep
4a2626ba
JP
47%setup -q -a1
48
49%{__mv} delta-%{crates_ver}/* .
50sed -i -e 's/@@VERSION@@/%{version}/' Cargo.lock
92a8f118
JP
51
52# use our offline registry
53export CARGO_HOME="$(pwd)/.cargo"
54
55mkdir -p "$CARGO_HOME"
56cat >.cargo/config <<EOF
57[source.crates-io]
58registry = 'https://github.com/rust-lang/crates.io-index'
59replace-with = 'vendored-sources'
60
61[source.vendored-sources]
62directory = '$PWD/vendor'
63EOF
64
65%build
66export CARGO_HOME="$(pwd)/.cargo"
67
68cargo -v build --release --frozen
69
70%install
71rm -rf $RPM_BUILD_ROOT
72export CARGO_HOME="$(pwd)/.cargo"
73
74cargo -v install --frozen --root $RPM_BUILD_ROOT%{_prefix} --path $PWD
75%{__rm} $RPM_BUILD_ROOT%{_prefix}/.crates*
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(644,root,root,755)
82%doc README.md
83%attr(755,root,root) %{_bindir}/delta
This page took 0.037714 seconds and 4 git commands to generate.