]> git.pld-linux.org Git - packages/deja-dup.git/commitdiff
Update to 34.3 master auto/th/deja-dup-34.3-1
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Sun, 16 Apr 2017 09:52:24 +0000 (11:52 +0200)
committerMarcin Banasiak <marcin.banasiak@gmail.com>
Sun, 16 Apr 2017 09:52:24 +0000 (11:52 +0200)
- added -vala-036.patch to fix build with new vala

deja-dup-vala-036.patch [new file with mode: 0644]
deja-dup.spec

diff --git a/deja-dup-vala-036.patch b/deja-dup-vala-036.patch
new file mode 100644 (file)
index 0000000..6cb28b3
--- /dev/null
@@ -0,0 +1,28 @@
+--- deja-dup-34.3/deja-dup/widgets/ConfigList.vala.newvala     2017-04-16 11:46:42.353133440 +0200
++++ deja-dup-34.3/deja-dup/widgets/ConfigList.vala     2017-04-16 11:46:47.219574579 +0200
+@@ -333,7 +333,7 @@ public class ConfigList : ConfigWidget
+     model.row_deleted.disconnect(write_to_config);
+     foreach (Gtk.TreeIter iter in iters) {
+-      (model as Gtk.ListStore).remove(iter);
++      (model as Gtk.ListStore).remove(ref iter);
+     }
+     model.row_deleted.connect(write_to_config);
+--- deja-dup-34.3/deja-dup/widgets/ConfigLocation.vala.newvala 2017-04-16 11:47:07.522907908 +0200
++++ deja-dup-34.3/deja-dup/widgets/ConfigLocation.vala 2017-04-16 11:47:33.649997561 +0200
+@@ -397,12 +397,12 @@ public class ConfigLocation : ConfigWidg
+     if (uuid == saved_uuid)
+       return;
+-    store.remove(iter);
++    store.remove(ref iter);
+     if (--num_volumes == 0) {
+       Gtk.TreeIter sep_iter;
+       if (store.get_iter_from_string(out sep_iter, index_vol_sep.to_string())) {
+-        store.remove(sep_iter);
++        store.remove(ref sep_iter);
+         index_vol_sep = -2;
+       }
+     }
index 8a4feb7699cd50fd99f85e52b8e3d21b3e48583d..7c5f9d2f213f6ff916253041f903568ddd383728 100644 (file)
@@ -1,13 +1,14 @@
 Summary:       Backup tool
 Summary(pl.UTF-8):     NarzÄ™dzie do wykonywania kopii zapasowych
 Name:          deja-dup
-Version:       34.2
+Version:       34.3
 Release:       1
 License:       GPL v3
 Group:         X11/Applications
-Source0:       http://launchpad.net/deja-dup/34/34.2/+download/%{name}-%{version}.tar.xz
-# Source0-md5: 1b9bf984b2d163b6b5854f23a3e0eef9
+Source0:       http://launchpad.net/deja-dup/34/34.3/+download/%{name}-%{version}.tar.xz
+# Source0-md5: a6f153573ed929aa7c0af60077873eff
 Patch0:                s3_multiprocessing.patch
+Patch1:                %{name}-vala-036.patch
 URL:           http://launchpad.net/deja-dup
 BuildRequires: PackageKit-devel
 BuildRequires: cmake
@@ -28,7 +29,7 @@ BuildRequires:        perl-Locale-gettext
 BuildRequires: pkgconfig >= 1:0.24
 BuildRequires: rpmbuild(find_lang) >= 1.35
 BuildRequires: rpmbuild(macros) >= 1.311
-BuildRequires: vala >= 0.20.0
+BuildRequires: vala >= 2:0.36.0
 BuildRequires: vala-libsecret
 BuildRequires: yelp-tools >= 3.2.0
 Requires(post,postun): gtk-update-icon-cache
@@ -74,6 +75,7 @@ klawiszem myszy w Nautilusie.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %cmake \
This page took 0.07149 seconds and 4 git commands to generate.