]> git.pld-linux.org Git - packages/dehydrated.git/blame - letsencrypt.sh.spec
looks complete; rel 1
[packages/dehydrated.git] / letsencrypt.sh.spec
CommitLineData
1780cc1f
ER
1Summary: letsencrypt/acme client implemented as a shell-script
2Name: letsencrypt.sh
3Version: 0.1.0
45bcc7f0 4Release: 1
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
7Source0: https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
eb6aa75d
ER
8# Source0-md5: eadd134cc5365753c03929dd70db341d
9Source1: apache.conf
10Source2: lighttpd.conf
3c33d40b 11Source3: config.sh
8f670f9f 12Source4: domains.txt
5765eca7 13Source5: hook.sh
a0535a11 14Source6: crontab
f5fc6721 15Patch0: pld.patch
1780cc1f
ER
16URL: https://github.com/lukas2511/letsencrypt.sh
17BuildRequires: rpmbuild(macros) >= 1.713
a0535a11 18Requires: crondaemon
1780cc1f
ER
19Requires: curl
20Requires: grep
21Requires: mktemp
60120665 22Requires: openssl-tools
1780cc1f 23Requires: sed
eb6aa75d
ER
24Requires: webapps
25Requires: webserver(access)
26Requires: webserver(alias)
1780cc1f
ER
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
eb6aa75d
ER
30%define _webapps /etc/webapps
31%define _webapp %{name}
32%define _sysconfdir %{_webapps}/%{_webapp}
33%define _appdir %{_datadir}/%{_webapp}
34
1780cc1f
ER
35%description
36This is a client for signing certificates with an ACME-server
37(currently only provided by letsencrypt) implemented as a relatively
38simple bash-script.
39
40Current features:
41- Signing of a list of domains
42- Signing of a CSR
43- Renewal if a certificate is about to expire or SAN (subdomains)
44 changed
45- Certificate revocation
46
47%prep
48%setup -q
f5fc6721 49%patch0 -p1
1780cc1f
ER
50
51%install
52rm -rf $RPM_BUILD_ROOT
a0535a11 53install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{acme-challenges,certs},/etc/cron.d}
eb6aa75d
ER
54
55install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
56
57cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
58cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
3c33d40b 59cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
8f670f9f 60cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
a0535a11 61cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/letsencrypt
5765eca7 62install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 63cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f
ER
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
eb6aa75d
ER
68%triggerin -- apache1 < 1.3.37-3, apache1-base
69%webapp_register apache %{_webapp}
70
71%triggerun -- apache1 < 1.3.37-3, apache1-base
72%webapp_unregister apache %{_webapp}
73
74%triggerin -- apache < 2.2.0, apache-base
75%webapp_register httpd %{_webapp}
76
77%triggerun -- apache < 2.2.0, apache-base
78%webapp_unregister httpd %{_webapp}
79
80%triggerin -- lighttpd
81%webapp_register lighttpd %{_webapp}
82
83%triggerun -- lighttpd
84%webapp_unregister lighttpd %{_webapp}
85
1780cc1f
ER
86%files
87%defattr(644,root,root,755)
88%doc README.md CHANGELOG LICENSE
a0535a11 89%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/letsencrypt
7410a329 90%dir %attr(750,root,http) %{_sysconfdir}
a113aaf6 91%dir %attr(700,root,root) %{_sysconfdir}/certs
eb6aa75d
ER
92%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
93%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
94%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
3c33d40b 95%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
8f670f9f 96%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
5765eca7 97%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
eb6aa75d
ER
98# challenges written here from letsencrypt.sh, need to be readable by webserver
99%dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
7410a329
ER
100
101%attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.079311 seconds and 4 git commands to generate.