]> git.pld-linux.org Git - packages/dehydrated.git/blame - letsencrypt.sh.spec
enable hook by default
[packages/dehydrated.git] / letsencrypt.sh.spec
CommitLineData
1780cc1f
ER
1Summary: letsencrypt/acme client implemented as a shell-script
2Name: letsencrypt.sh
eccbe1cf 3Version: 0.2.0
9f9f4d8c 4Release: 3
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
7Source0: https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
eccbe1cf 8# Source0-md5: 74974ab79d6879b92ba353bbf3d1257e
eb6aa75d
ER
9Source1: apache.conf
10Source2: lighttpd.conf
3c33d40b 11Source3: config.sh
8f670f9f 12Source4: domains.txt
5765eca7 13Source5: hook.sh
a0535a11 14Source6: crontab
f5fc6721 15Patch0: pld.patch
1780cc1f
ER
16URL: https://github.com/lukas2511/letsencrypt.sh
17BuildRequires: rpmbuild(macros) >= 1.713
a0535a11 18Requires: crondaemon
1780cc1f
ER
19Requires: curl
20Requires: grep
21Requires: mktemp
60120665 22Requires: openssl-tools
1780cc1f 23Requires: sed
eb6aa75d 24Requires: webapps
9f9f4d8c
ER
25Suggests: webserver(access)
26Suggests: webserver(alias)
1780cc1f
ER
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
eb6aa75d
ER
30%define _webapps /etc/webapps
31%define _webapp %{name}
32%define _sysconfdir %{_webapps}/%{_webapp}
33%define _appdir %{_datadir}/%{_webapp}
34
1780cc1f
ER
35%description
36This is a client for signing certificates with an ACME-server
37(currently only provided by letsencrypt) implemented as a relatively
38simple bash-script.
39
40Current features:
41- Signing of a list of domains
42- Signing of a CSR
43- Renewal if a certificate is about to expire or SAN (subdomains)
44 changed
45- Certificate revocation
46
47%prep
48%setup -q
f5fc6721 49%patch0 -p1
1780cc1f
ER
50
51%install
52rm -rf $RPM_BUILD_ROOT
a0535a11 53install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{acme-challenges,certs},/etc/cron.d}
eb6aa75d
ER
54
55install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
eb6aa75d
ER
56cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
57cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
3c33d40b 58cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
8f670f9f 59cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
a0535a11 60cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/letsencrypt
5765eca7 61install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 62cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f
ER
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
eb6aa75d
ER
67%triggerin -- apache1 < 1.3.37-3, apache1-base
68%webapp_register apache %{_webapp}
69
70%triggerun -- apache1 < 1.3.37-3, apache1-base
71%webapp_unregister apache %{_webapp}
72
73%triggerin -- apache < 2.2.0, apache-base
74%webapp_register httpd %{_webapp}
75
76%triggerun -- apache < 2.2.0, apache-base
77%webapp_unregister httpd %{_webapp}
78
79%triggerin -- lighttpd
80%webapp_register lighttpd %{_webapp}
81
82%triggerun -- lighttpd
83%webapp_unregister lighttpd %{_webapp}
84
1780cc1f
ER
85%files
86%defattr(644,root,root,755)
87%doc README.md CHANGELOG LICENSE
a0535a11 88%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/letsencrypt
7410a329 89%dir %attr(750,root,http) %{_sysconfdir}
a113aaf6 90%dir %attr(700,root,root) %{_sysconfdir}/certs
eb6aa75d
ER
91%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
92%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
93%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
3c33d40b 94%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
8f670f9f 95%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
5765eca7 96%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
eb6aa75d
ER
97# challenges written here from letsencrypt.sh, need to be readable by webserver
98%dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
7410a329
ER
99
100%attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.089672 seconds and 4 git commands to generate.